English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

27 Posts

06-08-2019

BE

57 Signins

365 Page Views

  • Posts: 27
  • Registered: ‎06-08-2019
  • Location: BE
  • Views: 365
  • Message 1 of 226

X1 extreme screen lag on "second screen only"

2019-07-13, 20:31 PM

Does anyone else have this issue? When the monitor conf is set to second screen only, there is a noticeable lag. This mostly only happens when the notebook has been used on battery first. The issue is solved by either rebooting the notebook on AC or enabling the native monitor.

 

We've bought 3 units and all 3 are displaying this issue (i7-8750H + 1050) . All 3 are being used for very other purposes so it's not probable there is a common third party software issue. 

 

Video : https://youtu.be/TRJvPQHvrWQ (sry for audio, machine was working)

 

1) Second screen only ,  moving notepad window is very laggy

2) Extended screen is enabled , moving notepad is smooth again

 

Notepad just as a simple example, everything behaves this way on second screen only (like scrolling)

 

All drivers are up to date and latest bios firmware is installed

Solved! See the solution
Reply
Options

2 Posts

11-20-2018

US

76 Signins

982 Page Views

  • Posts: 2
  • Registered: ‎11-20-2018
  • Location: US
  • Views: 982
  • Message 2 of 226

Re: X1 extreme screen lag on "second screen only"

2019-07-14, 22:05 PM

Same here.

 

I've also noticed that if you open the Start menu, what's behind it becomes smooth, but as soon  as you close it, everything jitters once again.

Reply
Options

27 Posts

06-08-2019

BE

57 Signins

365 Page Views

  • Posts: 27
  • Registered: ‎06-08-2019
  • Location: BE
  • Views: 365
  • Message 3 of 226

Re: X1 extreme screen lag on "second screen only"

2019-07-17, 12:09 PM

@Lenovo, any solution to this? It's not ok I cannot use my notebook with second screen only ....

Reply
Options

36 Posts

10-29-2017

US

152 Signins

980 Page Views

  • Posts: 36
  • Registered: ‎10-29-2017
  • Location: US
  • Views: 980
  • Message 4 of 226

Re: X1 extreme screen lag on "second screen only"

2019-07-18, 18:05 PM

Same thing here...

 

I'm on win 10 version 1803 with X1E and same issue after disconnected from external hdmi, running on battery with LCD only, and then reconnecting laptop to external hdmi, the mouse cursor and attached windows as video shows jumps and lags bad.

 

I often see 5% system process usage in task manager details for no apparent reason.  Rebooting solves the problem.  This is fairly recent, say in the last month or two that this has become an issue and is very consistent in occurrence.

Reply
Options

27 Posts

06-08-2019

BE

57 Signins

365 Page Views

  • Posts: 27
  • Registered: ‎06-08-2019
  • Location: BE
  • Views: 365
  • Message 5 of 226

Re: X1 extreme screen lag on "second screen only"

2019-07-18, 21:20 PM
Here it also started +- a month ago. The behavior is exactly as you describe
Reply
Options

2 Posts

06-17-2019

US

12 Signins

125 Page Views

  • Posts: 2
  • Registered: ‎06-17-2019
  • Location: US
  • Views: 125
  • Message 6 of 226

Re: X1 extreme screen lag on "second screen only"

2019-07-19, 20:52 PM
I have the same problem. Doesn't happen when "Discrete" mode is activated in the BIOS.
Reply
Options

36 Posts

10-29-2017

US

152 Signins

980 Page Views

  • Posts: 36
  • Registered: ‎10-29-2017
  • Location: US
  • Views: 980
  • Message 7 of 226

Re: X1 extreme screen lag on "second screen only"

2019-07-22, 16:26 PM
Well, that 'discrete' mode was a great clue, thx. So, it just happened again while on battery for a 20 minute meeting and reconnected to my external HDMI monitors and serious screen lag.

So I went into device manager and disabled the Intel UHD graphics 630 device and the problem went away. Re-enabled it and it the problem has not returned.

This looks like a temporary work-around until Lenovo gets this fixed.
Reply
Options

12 Posts

07-03-2019

SG

42 Signins

230 Page Views

  • Posts: 12
  • Registered: ‎07-03-2019
  • Location: SG
  • Views: 230
  • Message 8 of 226

Re: X1 extreme screen lag on "second screen only"

2019-07-24, 6:04 AM

Thanks. This setting to "discrete" is working for me. Hope they will come out with a fix soon. 

Reply
Options

27 Posts

06-08-2019

BE

57 Signins

365 Page Views

  • Posts: 27
  • Registered: ‎06-08-2019
  • Location: BE
  • Views: 365
  • Message 9 of 226

Re: X1 extreme screen lag on "second screen only"

2019-07-25, 11:24 AM
Doesnt this hurt battery too much ?
Reply
Options

27 Posts

06-08-2019

BE

57 Signins

365 Page Views

  • Posts: 27
  • Registered: ‎06-08-2019
  • Location: BE
  • Views: 365
  • Message 10 of 226

Re: X1 extreme screen lag on "second screen only"

2019-08-20, 21:57 PM

Hi Lenovo, Any solution to this problem?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete