Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

27 Posts

06-08-2019

Belgium

58 Signins

370 Page Views

  • Posts: 27
  • Registered: ‎06-08-2019
  • Location: Belgium
  • Views: 370
  • Message 1 of 234

X1 extreme screen lag on "second screen only"

2019-07-13, 20:31 PM

Does anyone else have this issue? When the monitor conf is set to second screen only, there is a noticeable lag. This mostly only happens when the notebook has been used on battery first. The issue is solved by either rebooting the notebook on AC or enabling the native monitor.

 

We've bought 3 units and all 3 are displaying this issue (i7-8750H + 1050) . All 3 are being used for very other purposes so it's not probable there is a common third party software issue. 

 

Video : https://youtu.be/TRJvPQHvrWQ (sry for audio, machine was working)

 

1) Second screen only ,  moving notepad window is very laggy

2) Extended screen is enabled , moving notepad is smooth again

 

Notepad just as a simple example, everything behaves this way on second screen only (like scrolling)

 

All drivers are up to date and latest bios firmware is installed

Reply
Answer
Options

11994 Posts

09-04-2014

Slovakia

33123 Signins

1241855 Page Views

  • Posts: 11994
  • Registered: ‎09-04-2014
  • Location: Slovakia
  • Views: 1241855

Re: X1 extreme screen lag on "second screen only"

2019-12-02, 9:44 AM

 wrote:

The new driver has solved the issue for me. However, I failed to install it from Vintage and had to manually install it and overwrote the "newer" existing driver.


Thanks for reporting your results, Vantage will always lag behind the support website when it comes to updates; it can be up to 14 days behind.

Manual driver download link.
https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-x1-extreme-gen-2/20qv/downloads/DS540278

 

Andy

 

Community Administrator
Lenovo eServices

Please remember to come back and mark the post that you feel solved your question as the solution, it earns the member + points 
Did you find a post helpfull? You can thank the member by awarding them a Thumbs Up
 

Please don't ask me questions by Personal Message; questions belong in the forums.


Using Browser Search to find your answers in Lenovo and Moto Community
Reply

Replies(233)
Options

2 Posts

11-20-2018

United States of America

77 Signins

987 Page Views

  • Posts: 2
  • Registered: ‎11-20-2018
  • Location: United States of America
  • Views: 987
  • Message 2 of 234

Re: X1 extreme screen lag on "second screen only"

2019-07-14, 22:05 PM

Same here.

 

I've also noticed that if you open the Start menu, what's behind it becomes smooth, but as soon  as you close it, everything jitters once again.

Reply
Options

27 Posts

06-08-2019

Belgium

58 Signins

370 Page Views

  • Posts: 27
  • Registered: ‎06-08-2019
  • Location: Belgium
  • Views: 370
  • Message 3 of 234

Re: X1 extreme screen lag on "second screen only"

2019-07-17, 12:09 PM

@Lenovo, any solution to this? It's not ok I cannot use my notebook with second screen only ....

Reply
Options

37 Posts

10-29-2017

United States of America

155 Signins

990 Page Views

  • Posts: 37
  • Registered: ‎10-29-2017
  • Location: United States of America
  • Views: 990
  • Message 4 of 234

Re: X1 extreme screen lag on "second screen only"

2019-07-18, 18:05 PM

Same thing here...

 

I'm on win 10 version 1803 with X1E and same issue after disconnected from external hdmi, running on battery with LCD only, and then reconnecting laptop to external hdmi, the mouse cursor and attached windows as video shows jumps and lags bad.

 

I often see 5% system process usage in task manager details for no apparent reason.  Rebooting solves the problem.  This is fairly recent, say in the last month or two that this has become an issue and is very consistent in occurrence.

Reply
Options

27 Posts

06-08-2019

Belgium

58 Signins

370 Page Views

  • Posts: 27
  • Registered: ‎06-08-2019
  • Location: Belgium
  • Views: 370
  • Message 5 of 234

Re: X1 extreme screen lag on "second screen only"

2019-07-18, 21:20 PM
Here it also started +- a month ago. The behavior is exactly as you describe
Reply
Options

2 Posts

06-17-2019

United States of America

12 Signins

125 Page Views

  • Posts: 2
  • Registered: ‎06-17-2019
  • Location: United States of America
  • Views: 125
  • Message 6 of 234

Re: X1 extreme screen lag on "second screen only"

2019-07-19, 20:52 PM
I have the same problem. Doesn't happen when "Discrete" mode is activated in the BIOS.
Reply
Options

37 Posts

10-29-2017

United States of America

155 Signins

990 Page Views

  • Posts: 37
  • Registered: ‎10-29-2017
  • Location: United States of America
  • Views: 990
  • Message 7 of 234

Re: X1 extreme screen lag on "second screen only"

2019-07-22, 16:26 PM
Well, that 'discrete' mode was a great clue, thx. So, it just happened again while on battery for a 20 minute meeting and reconnected to my external HDMI monitors and serious screen lag.

So I went into device manager and disabled the Intel UHD graphics 630 device and the problem went away. Re-enabled it and it the problem has not returned.

This looks like a temporary work-around until Lenovo gets this fixed.
Reply
Options

12 Posts

07-03-2019

Singapore

42 Signins

230 Page Views

  • Posts: 12
  • Registered: ‎07-03-2019
  • Location: Singapore
  • Views: 230
  • Message 8 of 234

Re: X1 extreme screen lag on "second screen only"

2019-07-24, 6:04 AM

Thanks. This setting to "discrete" is working for me. Hope they will come out with a fix soon. 

Reply
Options

27 Posts

06-08-2019

Belgium

58 Signins

370 Page Views

  • Posts: 27
  • Registered: ‎06-08-2019
  • Location: Belgium
  • Views: 370
  • Message 9 of 234

Re: X1 extreme screen lag on "second screen only"

2019-07-25, 11:24 AM
Doesnt this hurt battery too much ?
Reply
Options

27 Posts

06-08-2019

Belgium

58 Signins

370 Page Views

  • Posts: 27
  • Registered: ‎06-08-2019
  • Location: Belgium
  • Views: 370
  • Message 10 of 234

Re: X1 extreme screen lag on "second screen only"

2019-08-20, 21:57 PM

Hi Lenovo, Any solution to this problem?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms