English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

4 Posts

08-22-2019

PL

7 Signins

38 Page Views

  • Posts: 4
  • Registered: ‎08-22-2019
  • Location: PL
  • Views: 38
  • Message 11 of 226

Re: X1 extreme screen lag on "second screen only"

2019-08-22, 7:46 AM

The same issue on my brand new X1 Extreme. Extrenal display lag with hdmi connect and displayport too. Lenovo please give us solution for this, form my work this issues are critical!!!

Reply
Options

8 Posts

08-05-2019

AU

37 Signins

255 Page Views

  • Posts: 8
  • Registered: ‎08-05-2019
  • Location: AU
  • Views: 255
  • Message 12 of 226

Re: X1 extreme screen lag on "second screen only"

2019-08-23, 6:02 AM

Yep same here.

 

C'mon Lenovo, pull your finger out and give us a solution.

 

 

Reply
Options

4 Posts

08-22-2019

PL

7 Signins

38 Page Views

  • Posts: 4
  • Registered: ‎08-22-2019
  • Location: PL
  • Views: 38
  • Message 13 of 226

Re: X1 extreme screen lag on "second screen only"

2019-08-23, 6:59 AM

After update newest update from August (video, thunderbolt), is worse then before. No video detect after connect docking station (Original Lenovo USB-C Dock), more laggy screen on HDMI external monitor. Fix this issues or give my money back.

Reply
Options

25 Posts

07-21-2019

DE

56 Signins

423 Page Views

  • Posts: 25
  • Registered: ‎07-21-2019
  • Location: DE
  • Views: 423
  • Message 14 of 226

Re: X1 extreme screen lag on "second screen only"

2019-08-29, 8:27 AM

Sadly no solution, but I want to push this thread up since I have the same issue.

 

X1E + Thunderbolt 3 Workstation Dock, tried both HDMI and DisplayPort. More often than not the external monitor is laggy when connecting the X1E to the dock. Killing dwm.exe helps most of the time, but it is quite annoying nonetheless.

Reply
Options

2 Posts

08-31-2019

US

4 Signins

25 Page Views

  • Posts: 2
  • Registered: ‎08-31-2019
  • Location: US
  • Views: 25
  • Message 15 of 226

Re: X1 extreme screen lag on "second screen only"

2019-08-31, 20:08 PM

I've also confirmed the "workaround" of disabling/re-enabling the Intel UHD Graphics 630. This at least corrects the issue until it re-appears again, which seems to be when changing the display input or waking from a hibernated state. It's not the best fix but at least better than a reboot or log off/on.

 

This is by no means a "solution" though, and I worry that these issues are flying under the Lenovo radar and they won't get fixed. I have the X1 Carbon that I compare side-by-side, and in addition to the issue highlighted in this thread I even notice sluggish scrolling on certain websites in chrome (laptop mode, not external monitor) on the Extreme, but not the Carbon. Disabling hardware acceleration in Chrome fixes the sluggish scrolling, so yet another issue implicating the GPU (drivers most likely?).

 

This is very frustrating. These are not cheap laptops at all and these types of issues are just unacceptable. I'm considering returning the laptop and keeping the Carbon, but that's a last resort.

Reply
Options

14 Posts

08-31-2019

US

26 Signins

87 Page Views

  • Posts: 14
  • Registered: ‎08-31-2019
  • Location: US
  • Views: 87
  • Message 16 of 226

Re: X1 extreme screen lag on "second screen only"

2019-08-31, 21:24 PM

+1, exact same issue X1E, a few months old. Started to drive me insane and I spent a great deal of time suspecting it was a software issue lagging the Win 10 GUI until I finally spotted that it was only started after an external monitor was connected.

I'll contact Lenovo directly about the issue as disabling in BIOS to only use the 1050 will burn way too much battery, and having to disable / renable the Intel UHD every time you connect a monitor on a $2k+ laptop? This must be an issue for so many X1E owners right now and half prob don't even realise it's this, only sitting there baffled by terrible performance with external monitors.

Reply
Options

2 Posts

09-02-2019

TH

11 Signins

39 Page Views

  • Posts: 2
  • Registered: ‎09-02-2019
  • Location: TH
  • Views: 39
  • Message 17 of 226

Re: X1 extreme screen lag on "second screen only"

2019-09-02, 2:29 AM

My X1 Extreme Gen2 also having exactly the same problem but disable/enable intel 630 is also work

pufff

Reply
Options

27 Posts

06-08-2019

BE

57 Signins

365 Page Views

  • Posts: 27
  • Registered: ‎06-08-2019
  • Location: BE
  • Views: 365
  • Message 18 of 226

Re: X1 extreme screen lag on "second screen only"

2019-09-02, 9:03 AM
I'm not noticing a difference in battery life with 1050 only in BIOS. (+-4hours battery life) Connecting/Disconnecting an external screen is also almost instant instead of the +-30 second screen back and forward flicker.

Might be an indication that the intel 630 is really bugged at the moment. Maybe battery life is a lot more than 4hours if intel 630 would be working well.
Reply
Options

25 Posts

07-21-2019

DE

56 Signins

423 Page Views

  • Posts: 25
  • Registered: ‎07-21-2019
  • Location: DE
  • Views: 423
  • Message 19 of 226

Re: X1 extreme screen lag on "second screen only"

2019-09-02, 20:08 PM

I'am also using discrete graphics only at the moment as a workaround and some issues just disappeared for me:

- The long monitor-switching delay when connecting the laptop to the dock

- The lag issue when connecting to dock or wake-up from sleep connected to dock

- The occasional bluescreen when connecting. Granted, that just happened 2-3 times for me, so I'am not sure if the issue is completely solved, but haven't encountered it after setting the GPU to discrete only.

 

What puzzles me is that Lenovo doesn't acknowledge this problem. The reports of this issue (even with X1E Gen2) are far too frequent to just push it aside as bad luck with a monday product.

 

Even if it is a problem with the Intel driver and not strictly Lenovos fault a simple acknowledgment that the problem is known would be appreciated. We all know that hardware and software got more complex since the good, old IBM T40 days, but this silence is just irretating and I would expect that from some el-cheapo manufacturer that sells 500-bucks-machines at Walmart, not from a company that markets these 2000$+ machines at businesses.

Reply
Options

4 Posts

08-22-2019

PL

7 Signins

38 Page Views

  • Posts: 4
  • Registered: ‎08-22-2019
  • Location: PL
  • Views: 38
  • Message 20 of 226

Re: X1 extreme screen lag on "second screen only"

2019-09-05, 9:14 AM

Yesterday Lenovo Support send me an email with new firmwares bios, intel chipset, Intel graphic cards and ThunderBolt 3 Dock. After install everything is working fine, no more issues with external monitors, docking station and laggy screen. Below these links:

 

For X1 Extreme 1st gen

https://download.lenovo.com/consumer/options/lenovo_thunderbolt_3_graphics_dock_driver_v100044.exe
https://download.lenovo.com/consumer/options/thunderbolt_firmware_201712.zip

https://download.lenovo.com/pccbbs/mobiles/n2euj15w.exe
https://download.lenovo.com/pccbbs/mobiles/n2ech03w.exe
https://download.lenovo.com/pccbbs/mobiles/n2eda24w.exe

regards

Lukas

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete