Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

9 Posts

04-06-2019

Czech Republic

9 Signins

109 Page Views

  • Posts: 9
  • Registered: ‎04-06-2019
  • Location: Czech Republic
  • Views: 109
  • Message 211 of 234

Re:X1 extreme screen lag on "second screen only"

2020-08-24, 15:24 PM

Solution not working. Problem is there until reboot and then show again after one reconnection (HDMI)

Reply
Options

232 Posts

12-01-2019

Chile

253 Signins

2094 Page Views

  • Posts: 232
  • Registered: ‎12-01-2019
  • Location: Chile
  • Views: 2094
  • Message 212 of 234

Re:X1 extreme screen lag on "second screen only"

2020-08-25, 0:14 AM

I am having this issue too.

Reply
Options

1 Posts

08-28-2020

United States of America

1 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎08-28-2020
  • Location: United States of America
  • Views: 10
  • Message 213 of 234

Re:X1 extreme screen lag on "second screen only"

2020-08-28, 20:30 PM

Same issues with new P53 loaded with RTX5000. Disappointing that I cannot utilize a second screen for gaming.

Reply
Options

2 Posts

01-07-2020

United States of America

2 Signins

18 Page Views

  • Posts: 2
  • Registered: ‎01-07-2020
  • Location: United States of America
  • Views: 18
  • Message 214 of 234

Re:X1 extreme screen lag on "second screen only"

2020-09-11, 9:27 AM

Hi

I guess it's not only the display thing....In general performance of my lenovo p1 decrease. Today I was simply copying data from my nvme drive to pendrive connected to usb-c port. After starting copying process it started to lag every operation.

 

does anyone tried to return your laptops to seler/distributor as guarantee ? I'll try that option and will try to give my money back since this laptop in my opinion have serious flaw and is useless.

 

regard

Kris

Reply
Options

1 Posts

09-22-2020

United Kingdom of Great Britain and Northern Ireland

1 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎09-22-2020
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 5
  • Message 215 of 234

Re:X1 extreme screen lag on "second screen only"

2020-09-22, 19:47 PM

This problem is NOT resolved. I have all the latest drivers and BIOS and am experiencing severe lag on my external monitor when connected via USB-C. It works fine when connected directly via HDMI but when connected through a USB-C dock the performance is poor. I've seen that the dGPU is not being utilized except for when connected directly via HDMI. This is unacceptable

Reply
Options

25 Posts

11-06-2017

Romania

62 Signins

339 Page Views

  • Posts: 25
  • Registered: ‎11-06-2017
  • Location: Romania
  • Views: 339
  • Message 216 of 234

Re:X1 extreme screen lag on "second screen only"

2020-10-05, 19:57 PM

I started writing about my findings/observations on this issue. But I stopped. It's useless.

 

@ ToniV wrote:
 

 

I'm so tired ... and so disappointed...

I will never ever buy a high-end device from Lenovo.

And that, not because of this issue, but because of the indifference of the Lenovo company about us.

 

I guess this pretty much sums the feelings of many of us. For this Black Friday I'll probably go the HP or Huawei way. After T500, T530, P52, my fourth won't be, sadly a new Thinkpad.

 

not because of this issue,

 

Far too many issues. In my case, within almost 2 years: 

  • bricked docking station because automatic update; more than THREE months the automated update was there, bricking docking station after docking station
  • motherboard changed because faulty update of Intel Management Engine
  • motherboard changed because faulty BIOS update
  • screen changed because of really bad bleeding
  • thermal issues
  • and of course stuttering graphics which brought me to this thread

 

because of the indifference

 

Far too much indifference. A friend of mine bought a Lenovo Chrome book, which was not a bad product, but didn't meet his expectations. Since more than one month he's struggling to send the item back to Lenovo, because of a comedy-worthy ping-pong between Lenovo and TNT.

 

Best regards,

Cristian

 

 

Reply
Options

2 Posts

10-16-2020

United States of America

1 Signins

10 Page Views

  • Posts: 2
  • Registered: ‎10-16-2020
  • Location: United States of America
  • Views: 10
  • Message 217 of 234

Re:X1 extreme screen lag on "second screen only"

2020-10-16, 18:06 PM

Same problem here with my brand new X1 extreme gen 2 bought 2 months ago.  I don't do gaming and it's for my work.  I can get by but it's very annoying.  Not sure why this is flagged as solved!  

Reply
Options

2 Posts

10-16-2020

United States of America

1 Signins

10 Page Views

  • Posts: 2
  • Registered: ‎10-16-2020
  • Location: United States of America
  • Views: 10
  • Message 218 of 234

Re:X1 extreme screen lag on "second screen only"

2020-10-16, 18:32 PM

One observation from me is that when switching to "Second Screen Only" display (ctrl + P) while lid is open also slows down the graphic performance.  It works the best only when both the laptop screen and the secondary screen are on at same time.  Not sure if this gives any clues :-(

Reply
Options

47 Posts

08-28-2019

Germany

62 Signins

706 Page Views

  • Posts: 47
  • Registered: ‎08-28-2019
  • Location: Germany
  • Views: 706
  • Message 219 of 234

Re:X1 extreme screen lag on "second screen only"

2020-10-20, 23:01 PM

I have this issue with my Lenovo y540 in hybrid mode rtx 2060. It's very annoying 

Reply
Options

1 Posts

10-23-2020

United States of America

1 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎10-23-2020
  • Location: United States of America
  • Views: 0
  • Message 220 of 234

Re:X1 extreme screen lag on "second screen only"

2020-10-23, 1:51 AM

I tried the latest "NVIDIA Optimus Display Driver for Windows 10 (Version 1803 or later) - ThinkPad P1, X1 Extreme" 26.21.14.4332 from 05 Oct 2020

Had my hopes up since it said:


[Problem fixes] - Fixed an issue where dragging app interface was not smooth under external   monitor only mode when plugging the monitor for the first time.

Unfortunately it doesn't improve anything for me.

 

Every morning, I open up my laptop to enter my boot password. 

I have two monitors connected to my dock Thunderbolt 3 Workstation Dock Gen 2 - Type 40AN

one display port (3840x2160, 150% scaling, g-sync), one HDMI (2560x1440 100% scaling, no g-sync)

After I boot Windows 10 1809, I open an explorer window and drag it around. Everything is smooth.

I then close my laptop screen (close lid is configured to do nothing) and when I move the explorer window it is extremely choppy. 1-2 fps.

I then right click on "This PC" go to Manage, then Device Manager->Display Adapters->Intel(R) UHD Graphics 630

Right click, disable, right click enable and everything is smooth again.

 

I have to do this every time I turn on the system.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms