English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

1 Posts

10-23-2020

US

1 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎10-23-2020
  • Location: US
  • Views: 0
  • Message 221 of 228

Re:X1 extreme screen lag on "second screen only"

2020-10-23, 1:51 AM

I tried the latest "NVIDIA Optimus Display Driver for Windows 10 (Version 1803 or later) - ThinkPad P1, X1 Extreme" 26.21.14.4332 from 05 Oct 2020

Had my hopes up since it said:


[Problem fixes] - Fixed an issue where dragging app interface was not smooth under external   monitor only mode when plugging the monitor for the first time.

Unfortunately it doesn't improve anything for me.

 

Every morning, I open up my laptop to enter my boot password. 

I have two monitors connected to my dock Thunderbolt 3 Workstation Dock Gen 2 - Type 40AN

one display port (3840x2160, 150% scaling, g-sync), one HDMI (2560x1440 100% scaling, no g-sync)

After I boot Windows 10 1809, I open an explorer window and drag it around. Everything is smooth.

I then close my laptop screen (close lid is configured to do nothing) and when I move the explorer window it is extremely choppy. 1-2 fps.

I then right click on "This PC" go to Manage, then Device Manager->Display Adapters->Intel(R) UHD Graphics 630

Right click, disable, right click enable and everything is smooth again.

 

I have to do this every time I turn on the system.

Reply
Options

3 Posts

10-25-2020

US

7 Signins

25 Page Views

  • Posts: 3
  • Registered: ‎10-25-2020
  • Location: US
  • Views: 25
  • Message 222 of 228

Re:X1 extreme screen lag on "second screen only"

2020-10-25, 19:09 PM

I had the same issue with my brand new P1 gen 3 xeon 32gb T2000 laptop. I am currently running 3 dell up2716h monitors linked to laptop via two usb-c cables. One driving the one monitor and the other one driving 2 of them via MST. 

 

What I found was if I tried to turn off the laptop monitor the external monitors became laggy. If the external monitor and internal monitors were all on with the external monitor working using the quadro card and the laptop monitor with the intel graphics it seemed to work okay. It seems that when the system is setup with a hybrid setup in the bios it needs to have both graphics card working to share data between them. 

 

Because I wanted to have just 3 dell monitors working and the laptop screen shut I ended up changing the bios to discrete only. That seems to have solved all my problems. I know its not ideal but it is what it is at the moment. Hopefully lenovo will solve this soon so I can reactive the hybird graphics. On the plus side the T2000 graphics card with max q draws less power than older T2000 card.

 

 

 

Reply
Options

54 Posts

10-11-2018

US

93 Signins

1016 Page Views

  • Posts: 54
  • Registered: ‎10-11-2018
  • Location: US
  • Views: 1016
  • Message 223 of 228

Re:X1 extreme screen lag on "second screen only"

2020-10-31, 5:10 AM

I have a P1 gen 1, and the latest graphics driver from Lenovo did fix this issue for me.

 

The driver package is dated 05 Oct 2020 on the Lenovo support site, and contains these driver versions:

26.21.14.4332 (NVIDIA Graphics Driver)

27.20.100.8587 (Intel Graphics Driver)

Reply
Options

14 Posts

08-31-2019

US

26 Signins

87 Page Views

  • Posts: 14
  • Registered: ‎08-31-2019
  • Location: US
  • Views: 87
  • Message 224 of 228

Re:X1 extreme screen lag on "second screen only"

2020-10-31, 11:25 AM

You may actually be right. I just checked the README change log;

[Problem fixes] - Fixed an issue where dragging app interface was not smooth under external   monitor only mode when plugging the monitor for the first time. - Fixed an issue where maximum brightness decreased.

 

This may indicate that the exact issue has finally be found, but I'll wait and see. Downloading now.

Reply
Options

40 Posts

08-28-2019

DE

52 Signins

636 Page Views

  • Posts: 40
  • Registered: ‎08-28-2019
  • Location: DE
  • Views: 636
  • Message 225 of 228

Re:X1 extreme screen lag on "second screen only"

2020-11-07, 18:52 PM

I have this issue with my Lenovo Y540. Unfortunately, most people use discrete GPU mode since its a gaming laptop, so I'm pretty much the only one complaining about it.

 

Please give me some support.

Reply
Options

3 Posts

11-15-2020

DE

4 Signins

10 Page Views

  • Posts: 3
  • Registered: ‎11-15-2020
  • Location: DE
  • Views: 10
  • Message 226 of 228

Re:X1 extreme screen lag on "second screen only"

2020-11-17, 11:07 AM

Here is the YouTube Link to the solution

 

1. Download Lenovo setup files on a USB stick (Do not connect to external monitor, only connect AC charger). - Download all up-to-date drivers from November 2020 here: https://1drv.ms/u/s!AlrL2-qhBLVGgbxkI... (1.2 GB) 

2. Install Windows 10 (2004 !) (I have Pro, but Home should work as well) - https://www.itechtics.com/windows-10-... 

3. Install Lenovo Drivers from USB Stick in specific order - chipset, audio, network, bluetooth,display-graphics, camera_cardreader, fingerprint, mouse, powermanager, software_hotkey_thunderbolt, storage, usbdevice_thunderbolt - Intel GPU driver has to be version 26.20.100.7529 (n2odr08w.exe) !!! https://download.lenovo.com/pccbbs/mo... 

4. Connect to Internet & let Windows Update run and install everything 

5. Go to "Device Manager" & Revert back Intel GPU driver to "older version". - Revert back from Intel UHD Graphics 630 driver Version 26.20.100.7811 (Windows update version) to 26.20.100.7529 (your installed version from USB stick)

Reply
Options

1 Posts

08-16-2015

Switzerland

2 Signins

23 Page Views

  • Posts: 1
  • Registered: ‎08-16-2015
  • Location: Switzerland
  • Views: 23
  • Message 227 of 228

Re:X1 extreme screen lag on "second screen only"

2020-11-28, 16:24 PM

The problem is still there (P1 Gen2), more than a year after it had first been reported. Unbelievable. 

Reply
Options

7 Posts

10-09-2019

RO

17 Signins

94 Page Views

  • Posts: 7
  • Registered: ‎10-09-2019
  • Location: RO
  • Views: 94
  • Message 228 of 228

Re: X1 extreme screen lag on "second screen only"

2020-12-02, 13:19 PM
Hi Andy, After a year of messages denying the validity of this solution, it is still listed here. Ok, no one know how to solve it. I can accept that (even if it is deplorable talking about the top equipments of lenovo). But it's difficult for me to accept a false solution. We fight every single day with this issue. Thanks for understanding, Toni
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete