English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

2 Posts

08-31-2019

US

4 Signins

25 Page Views

  • Posts: 2
  • Registered: ‎08-31-2019
  • Location: US
  • Views: 25
  • Message 31 of 228

Re: X1 extreme screen lag on "second screen only"

2019-09-18, 16:03 PM

MichaelR2D2, 

 

For myself and others, the "fix" was to disable hybrid graphics in the BIOS. Yes, this did completely resolve the issue, although it's a shame that this is what needed to be done at all. As a brief explanation of the problem, this laptop has two graphics cards: An integrated Intel 630 gpu, and a more powerful discrete (separate) NVIDIA GeForce GTX 1650 gpu. By default, the laptop uses a "hybrid" mode which uses both graphics cards in an attempt to conserve battery; it will use the lower powered Intel gpu during low graphics operations, then it will dynamically switch to using the more powerful NVIDIA gpu during graphics intensive workloads. 

 

I imagine the problem here is with this gpu handoff which seems to occur when the laptop is docked and/or a larger external monitor is connected. By switching the display settings in the BIOS from "hybrid" to "discreet", you are telling the system to always use the NVIDIA gpu, and it will no longer use the Intel gpu thus eliminating this gpu handoff operation completely. The caveat to this is that it will most likely decrease your battery life. I personally didn't notice much of a battery drain difference and the change was effective and permanent. 

 

That being said, this is still unacceptable on Lenovo's part and this should be resolved with an update. I hope this helps.

Reply
Options

3 Posts

09-29-2019

US

14 Signins

63 Page Views

  • Posts: 3
  • Registered: ‎09-29-2019
  • Location: US
  • Views: 63
  • Message 32 of 228

Re: X1 extreme screen lag on "second screen only"

2019-09-29, 4:28 AM

I've been having the same issues with an external dispaly (connected via TB3 to Displayport) lagging with the laptop lid closed. I did all the bios updates and everything from Lenovo but still had the issue. Today I tried downloading the latest Nvidia driver directly from Nvidia and that seems to have actually done something... It has been a couple of hours and I haven't seen any lag yet. I am cautiously optimistic at this point...

Reply
Options

4 Posts

08-22-2019

PL

7 Signins

38 Page Views

  • Posts: 4
  • Registered: ‎08-22-2019
  • Location: PL
  • Views: 38
  • Message 33 of 228

Re: X1 extreme screen lag on "second screen only"

2019-09-30, 7:22 AM

thx. for this. Today new nvidia drivers (DCH Studio from nvidia web) installed and i think this lags and display problem on second screen with Lenovo TB3 Dock disapear. I've hope permamently.

Reply
Options

12 Posts

07-03-2019

SG

42 Signins

230 Page Views

  • Posts: 12
  • Registered: ‎07-03-2019
  • Location: SG
  • Views: 230
  • Message 34 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-01, 3:06 AM
Thanks. I have installed the latest driver V436.30
as well and it seems to be working fine now.
Reply
Options

33 Posts

10-24-2016

PL

50 Signins

321 Page Views

  • Posts: 33
  • Registered: ‎10-24-2016
  • Location: PL
  • Views: 321
  • Message 35 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-01, 7:06 AM

it does not solve the issue for me.. I am on X1E Gen2

Reply
Options

11 Posts

09-18-2019

US

29 Signins

231 Page Views

  • Posts: 11
  • Registered: ‎09-18-2019
  • Location: US
  • Views: 231
  • Message 36 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-02, 21:17 PM
me too, the problem still exists
Reply
Options

3 Posts

09-29-2019

US

14 Signins

63 Page Views

  • Posts: 3
  • Registered: ‎09-29-2019
  • Location: US
  • Views: 63
  • Message 37 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-03, 6:01 AM

I have the 2nd gen X1E. Did you guys make sure to do a full reboot and reconnecting the monitors after installing the driver? Mine was still lagging until I did that. I haven't seen any lag or stutter so far, so it seems to be working in my case at least.

Reply
Options

36 Posts

10-29-2017

US

152 Signins

980 Page Views

  • Posts: 36
  • Registered: ‎10-29-2017
  • Location: US
  • Views: 980
  • Message 38 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-03, 12:23 PM
x1e gen 1 running windows 1809, problem still exists after trying a couple of recent drivers, both the one that showed up in lenovo update and the one via nvidia geforce experience.

To see the lag, just grab a window with the mouse and move it around, it is really easy to see how jerky this is.

Disable and re-enable the Intel driver and that problem goes away. Easy to reproduce this way after reconnecting to external monitor from using the LCD only for a bit.

I'm also getting blue screens with Nvlddmkm.sys rather consistently using any browser (only when hw acceleration enabled) when going to amazon prime video page or news pages with videos on them. I will probably start a new thread on this.
Reply
Options

33 Posts

10-24-2016

PL

50 Signins

321 Page Views

  • Posts: 33
  • Registered: ‎10-24-2016
  • Location: PL
  • Views: 321
  • Message 39 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-03, 12:33 PM

Today, first time I woke up my X1E Gen2 at work, connected external screen - no lag.

I came back from a meeting later during the day, same exact steps - there is lag.

Issue replicated, drivers do not solve that issue.

 

EDIT:

Also I recommend creating shortcut to a task in task scheduler that kills DWM.exe process. That solves the issue as well and is way faster so much more convienient than disabling and re-enabling intel GPU.

Reply
Options

12 Posts

07-03-2019

SG

42 Signins

230 Page Views

  • Posts: 12
  • Registered: ‎07-03-2019
  • Location: SG
  • Views: 230
  • Message 40 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-04, 0:40 AM

I confirmed the driver V436.30 is not solving the issue.

Connected X1E to monitor and power up the X1E then closing the lid. 

The lag returned. 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete