English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

3 Posts

09-29-2019

US

14 Signins

63 Page Views

  • Posts: 3
  • Registered: ‎09-29-2019
  • Location: US
  • Views: 63
  • Message 41 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-04, 2:29 AM

Well, I was lag free for a little over 3 days and now it is back... This issue is really frustrating... Even if I kill the DWM.exe process, the lag just starts again like 5 minutes later. Having to kill a process or restart the computer every few minutes makes this laptop basically unusable with an external monitor. Sigh...

Reply
Options

11 Posts

09-18-2019

US

29 Signins

231 Page Views

  • Posts: 11
  • Registered: ‎09-18-2019
  • Location: US
  • Views: 231
  • Message 42 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-04, 3:12 AM
Hi, do you also encounter warm color and flashy screen when turning on Windows HD Color on your X1 Extreme Screeen in settings?
Reply
Options

7 Posts

10-09-2019

RO

17 Signins

94 Page Views

  • Posts: 7
  • Registered: ‎10-09-2019
  • Location: RO
  • Views: 94
  • Message 43 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-09, 17:58 PM

This is my sad story. (Short version)
I bought the X1 Extreme Gen2 3 weeks ago. I bought it together with 2 TB3 ds Gen2 230w in order to use it only on external display at home and office. 

The configuration of my X1 is: I7,1TB ssd, 32Gb, GF 1650. So, we are talking about a top configuration of this product.

From that moment until yesterday I done all updates from Microsoft, Lenovo (including for TP3) and from Nvidia. I set discreet mode in bios also. Anyway, at the end of day ... meaning today... I can't use external display throught TP3 and from the moment when I push the TB power button until the moment when I see the image on the external display it takes between 20 and 45 seconds depending the previous power state. But, I can't use it for another 10 sec because the display blinks twice and the system is hardly responsive in this interval.

I never had some kind of issues with another premium laptops.

 

So, thank you LENOVO for this traumatic experience.

 

And for the record, I also have one XPS 15 with same configuration like X1 (plus touch screen) and works spectacular.

Reply
Options

5 Posts

10-09-2019

AU

6 Signins

53 Page Views

  • Posts: 5
  • Registered: ‎10-09-2019
  • Location: AU
  • Views: 53
  • Message 44 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-09, 23:32 PM

I am seeing the same issue (lag on second screen) on my brand new fully updated X1. Would love to see Lenovo get involved and provide a solution. The machine is great otherwise so it is dissapointing to find this issue.

Reply
Options

1 Posts

10-18-2019

HK

1 Signins

15 Page Views

  • Posts: 1
  • Registered: ‎10-18-2019
  • Location: HK
  • Views: 15
  • Message 45 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-18, 23:31 PM

Sorry, not providing any help here, but good to know that I am not alone, had to restart my computer once everytime I turn my X1e 1st gen on for the last few months. 

 

Lenovo, this is a very fraustring expereinece.

Reply
Options

2 Posts

10-19-2019

SG

2 Signins

21 Page Views

  • Posts: 2
  • Registered: ‎10-19-2019
  • Location: SG
  • Views: 21
  • Message 46 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-19, 4:19 AM
got my thinkpad X1 extreme 3 weeks ago. it was fine for first week then the lag when hdmi output to my monitor happens on the 2nd screen only. now i only use it on duplicate mode. is there still no fix on this ?
Reply
Options

33 Posts

10-24-2016

PL

50 Signins

321 Page Views

  • Posts: 33
  • Registered: ‎10-24-2016
  • Location: PL
  • Views: 321
  • Message 47 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-19, 6:43 AM

For the moment only restart or a shortcut to kill DWM process

Reply
Options

25 Posts

07-21-2019

DE

56 Signins

423 Page Views

  • Posts: 25
  • Registered: ‎07-21-2019
  • Location: DE
  • Views: 423
  • Message 48 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-20, 16:41 PM

Problem persists for me, too. Only workaround at the moment is to restart the laptop, kill dwm.exe or deactivate and reactivate the intel gpu via device manager.

Reply
Options

27 Posts

06-08-2019

BE

57 Signins

365 Page Views

  • Posts: 27
  • Registered: ‎06-08-2019
  • Location: BE
  • Views: 365
  • Message 49 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-20, 20:42 PM
I am really troubled Lenovo persists to ignore this defect for so long. My colleagues that trusted in my Lenovo X1 recommendation are looking at stuttering screen for more than a half year now .Not a single answer or suggestion has been supplied by Lenovo itself. I'm deeply dissapointed.
Reply
Options

8 Posts

10-22-2019

US

11 Signins

76 Page Views

  • Posts: 8
  • Registered: ‎10-22-2019
  • Location: US
  • Views: 76
  • Message 50 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-22, 16:07 PM

Gen1 user here - no TB3 dock i use this one 

 

 

I've updated to the latest driver directly from the geforce experience center.

 

Set discrete graphics mode in BIOS and it dissappeared - will follow up with updates 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete