English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

33 Posts

10-24-2016

PL

50 Signins

321 Page Views

  • Posts: 33
  • Registered: ‎10-24-2016
  • Location: PL
  • Views: 321
  • Message 51 of 227

Re: X1 extreme screen lag on "second screen only"

2019-10-22, 16:26 PM

what is you battery life with nVidia GPU enabled all the time? Guess not very long... this is approach is far from being even close to a temporary solution for me.

Reply
Options

27 Posts

06-08-2019

BE

57 Signins

365 Page Views

  • Posts: 27
  • Registered: ‎06-08-2019
  • Location: BE
  • Views: 365
  • Message 52 of 227

Re: X1 extreme screen lag on "second screen only"

2019-10-23, 6:05 AM
Strangely enough, battery time is better for me when enabling hybrid only. I guess the bug that causes the issue eats cpu power as well. Can someone confirm this?
Reply
Options

33 Posts

10-24-2016

PL

50 Signins

321 Page Views

  • Posts: 33
  • Registered: ‎10-24-2016
  • Location: PL
  • Views: 321
  • Message 53 of 227

Re: X1 extreme screen lag on "second screen only"

2019-10-29, 6:17 AM

I did not have time to play around... but the lag issue is fixed for me. I am installing all the updates available except the faulty BIOS update. I do not exacly remember when as I work way too much and I just did not notice, but I no longer need to use my kill DWM shortcut.

Reply
Options

5 Posts

10-09-2019

AU

6 Signins

53 Page Views

  • Posts: 5
  • Registered: ‎10-09-2019
  • Location: AU
  • Views: 53
  • Message 54 of 227

Re: X1 extreme screen lag on "second screen only"

2019-10-29, 6:20 AM

Which one is the "faulty" one?

Reply
Options

33 Posts

10-24-2016

PL

50 Signins

321 Page Views

  • Posts: 33
  • Registered: ‎10-24-2016
  • Location: PL
  • Views: 321
  • Message 55 of 227

Re: X1 extreme screen lag on "second screen only"

2019-10-29, 6:26 AM

The newest one. It breaks you brightness control. The version number is  1.26. The last good one seems to be 1.25 (at least for me, but I did not find any information from other users that they do experience problems with it). I am looking at my Vantage now and last update applied to the system is Intel Management Engine Firmware. I am 100% sure if that fixed my screen lag issue, but it might be it - version 12.0.47.1524

Reply
Options

5 Posts

10-09-2019

AU

6 Signins

53 Page Views

  • Posts: 5
  • Registered: ‎10-09-2019
  • Location: AU
  • Views: 53
  • Message 56 of 227

Re: X1 extreme screen lag on "second screen only"

2019-10-29, 6:28 AM
OK, thanks.
Reply
Options

33 Posts

10-24-2016

PL

50 Signins

321 Page Views

  • Posts: 33
  • Registered: ‎10-24-2016
  • Location: PL
  • Views: 321
  • Message 57 of 227

Re: X1 extreme screen lag on "second screen only"

2019-10-29, 6:33 AM

Np. Ah... crap, its not gone :( false alarm... I forgot I have switched to extended desktop mode. The issue appears only with the notebook screen switched off and is NOT fixed :/.

Reply
Options

11 Posts

09-18-2019

US

29 Signins

231 Page Views

  • Posts: 11
  • Registered: ‎09-18-2019
  • Location: US
  • Views: 231
  • Message 58 of 227

Re: X1 extreme screen lag on "second screen only"

2019-10-29, 6:35 AM

If Lenovo keep ignoring this flaw, we could possibly file a class action. 

Reply
Options

68 Posts

10-30-2019

US

85 Signins

653 Page Views

  • Posts: 68
  • Registered: ‎10-30-2019
  • Location: US
  • Views: 653
  • Message 59 of 227

Re: X1 extreme screen lag on "second screen only"

2019-10-30, 16:21 PM

Just got my X1 Extreme Gen 2 (first Lenovo system) and noticed this on the first day since it gets triggered if you Remote Desktop into the system and then switch back to using it in-person while the lid is closed.  I hope this gets fixed, because the inability to use ANY business laptop with only secondary displays is unacceptable, never mind a flagship business laptop.

 

In the meantime though, I wrote a PowerShell script that I'm keeping on my desktop that disables and re-enables the Intel GPU.  It has built-in handling for elevating to admin privileges, so you can just right-click it and choose "Run with PowerShell" -- assuming of course you have admin privileges on your system, which many business users will not.  So Lenovo, step up and fix this....

 

I've posted the script below if anyone wants to use it.  Just save it as a .ps1 file.  It is validated on my own X1 Extreme Gen 2.  If the Instance ID of your Intel GPU is different, the last two lines of the script will need to be adjusted accordingly.  To check your Intel GPU's InstanceID, open PowerShell Console and run "Get-PnpDevice -FriendlyName "*Graphics*" | select FriendlyName,InstanceID | format-list".

 

Script:

function Elevate()
{
    # Check to see if we are currently running "as Administrator"
    if (!([Security.Principal.WindowsPrincipal][Security.Principal.WindowsIdentity]::GetCurrent()).IsInRole([Security.Principal.WindowsBuiltInRole]"Administrator"))
    {
        $ScriptPath = $script:MyInvocation.MyCommand.Path
        Start-Process powershell.exe -verb Runas -ArgumentList ("-executionpolicy bypass -noprofile -nologo -file `"$ScriptPath`"")
        # Exit this unelevated script with exit code for "Error: Not elevated"
        Exit 3;
    }
}
Elevate
Disable-pnpdevice -instanceid "PCI\VEN_8086&DEV_3E9B&SUBSYS_229F17AA&REV_00\3&11583659&0&10" -confirm:$false
Enable-pnpdevice -instanceid "PCI\VEN_8086&DEV_3E9B&SUBSYS_229F17AA&REV_00\3&11583659&0&10" -confirm:$false

 

Reply
Options

68 Posts

10-30-2019

US

85 Signins

653 Page Views

  • Posts: 68
  • Registered: ‎10-30-2019
  • Location: US
  • Views: 653
  • Message 60 of 227

Re: X1 extreme screen lag on "second screen only"

2019-10-30, 19:33 PM

BIOS 1.27 was released yesterday for the X1 Extreme Gen 2. The release notes don't mention anything about this issue (although there's a CPU microcode update that might be relevant?), but I just installed the update and haven't yet reproduced the lag issue even after multiple occasions of performing the steps were triggering it before.  It's still early of course, but I encountered the lag issue about 4 times in my first few hours using this system, and I haven't noticed it once since updating.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete