English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

1 Posts

10-30-2019

CZ

47 Signins

267 Page Views

  • Posts: 1
  • Registered: ‎10-30-2019
  • Location: CZ
  • Views: 267
  • Message 61 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-30, 20:49 PM
So I tried installing new BIOS (1.27) and it did not help, so I am stuck with re-enabling Intel Graphics... Sort of killed all the good feeling about this machine :(
Reply
Options

11 Posts

09-18-2019

US

29 Signins

231 Page Views

  • Posts: 11
  • Registered: ‎09-18-2019
  • Location: US
  • Views: 231
  • Message 62 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-30, 21:48 PM

Or maybe just switch to discrete graphics for a peace of mind.

Reply
Options

68 Posts

10-30-2019

US

85 Signins

653 Page Views

  • Posts: 68
  • Registered: ‎10-30-2019
  • Location: US
  • Views: 653
  • Message 63 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-30, 21:51 PM

Sorry to hear this, since it probably means this issue will persist on my system. But take a look at the script I posted just above if you want an easy workaround. Discrete Graphics is an easier workaround, but that carries a significant battery life penalty. Although my script requires that you be an administrator on your system. If you're not due to corporate policies, then you'll have to resort to other workarounds discussed here.

Reply
Options

4 Posts

10-31-2019

US

10 Signins

68 Page Views

  • Posts: 4
  • Registered: ‎10-31-2019
  • Location: US
  • Views: 68
  • Message 64 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-31, 2:36 AM

I have been having this exact same issue with my X1E 2 ever since it arrived a few weeks ago. Regardless of whether I use the thunderbolt dock, or plug the monitor directly into the HDMI port on the lapot this lag in "second screen only" mode persists. Restarting the laptop or disabling and then re-enabling the UHD 630 is the only thing that fixes it.

 

However, one thing that I wanted to point out that I noticed is that when I disable the UHD 630, my external montior actually becomes my main display. 

 

With the UHD 630 disabled, "PC Screen Only" mode actually turns on my external monitor and "Second Screen Only" mode turns on the laptops screen. When I re-enable the UHD 630 it reverts back to the correct configuration. 

 

Has anyone else noticed this? I hope Lenovo is reading this discussion and gets a fix out soon.  

Reply
Options

68 Posts

10-30-2019

US

85 Signins

653 Page Views

  • Posts: 68
  • Registered: ‎10-30-2019
  • Location: US
  • Views: 653
  • Message 65 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-31, 3:00 AM

Here is what I think accounts for that behavior based on what I know about the design of other systems that allow the user to choose which GPU has direct control of the built-in display (and in some cases the display output connectors).  On the systems I know about, the display and/or display outputs that are switchable in this way are wired to DisplayPort multiplexers, which are then wired back to both GPUs in the system.  The user then has a BIOS setting that allows them to choose which GPU drives that display or display output connector, like the Hybrid/Discrete BIOS setting on this system.  That setting controls which GPU path to the multiplexer is active.  If you're in Hybrid mode on this system, then it's the Intel GPU.  But if you disable that GPU, then my guess is that the system firmware simply notices that that path has gone dead and automatically enables the other path, namely the one fed by the NVIDIA GPU.  As for why the built-in display is secondary in that scenario rather than primary, that could be because the external display was active first or maybe because the display output connectors are wired to lower-indexed outputs on the GPU than the built-in panel.  I'm not sure there -- well, technically I'm not even sure that this is how this particular system works at all, but I do know this design is implemented elsewhere and it would account for this behavior.

Of course none of that explains why this lag issue occurs.  I would be very interested to understand the technical details of this bug, since the way it's triggered and the fact that it doesn't happen immediately after those actions are taken make it seem like some sort of resource leak that takes time to become a real problem.  And since laptops that have their display outputs directly wired to the discrete GPU are relatively rare, even isolating variables like drivers vs. firmware would be difficult.  Most systems that have dual GPUs still have all outputs wired to the Intel GPU for battery life reasons, since sometimes people run an external display/projector on battery power, and that design allows the discrete GPU to be completely shut down -- and systems typically don't offer DisplayPort multiplexers to allow the type of flexibility found on this system, presumably due to cost and complexity concerns.  I personally like that the display outputs are driven by the discrete GPU though, since the drawback of using the Intel GPU is that it makes certain technologies impossible to use, such as (right now) G-Sync, Adaptive V-Sync, VR, and stereoscopic 3D.  But all of those are possible when an NVIDIA GPU that supports those technologies has direct control of the display output.

Reply
Options

68 Posts

10-30-2019

US

85 Signins

653 Page Views

  • Posts: 68
  • Registered: ‎10-30-2019
  • Location: US
  • Views: 653
  • Message 66 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-31, 3:05 AM

However, one thing that I wanted to point out that I noticed is that when I disable the UHD 630, my external montior actually becomes my main display. 

 

With the UHD 630 disabled, "PC Screen Only" mode actually turns on my external monitor and "Second Screen Only" mode turns on the laptops screen. When I re-enable the UHD 630 it reverts back to the correct configuration. 

 

Has anyone else noticed this? I hope Lenovo is reading this discussion and gets a fix out soon.  


Well I've been trying to post a theory as to why this occurs based on what I know of how other systems with the ability to change which GPU drives the built-in display and sometimes the display outputs are wired, but my post keeps getting deleted, even after I removed references to the specific other (non-Lenovo) systems I was talking about -- even though I don't see any prohibitions in the Community Guidelines about discussing competitors' products.

Reply
Options

5 Posts

10-09-2019

AU

6 Signins

53 Page Views

  • Posts: 5
  • Registered: ‎10-09-2019
  • Location: AU
  • Views: 53
  • Message 67 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-31, 3:15 AM
Appreciate your efforts. If only Lenovo was as quick to fix this issue as they are to jump on what was a helpful post.
Reply
Options

8519 Posts

01-13-2008

US

77401 Signins

2201949 Page Views

  • Posts: 8519
  • Registered: ‎01-13-2008
  • Location: US
  • Views: 2201949
  • Message 68 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-31, 2:43 AM

The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Options

8519 Posts

01-13-2008

US

77401 Signins

2201949 Page Views

  • Posts: 8519
  • Registered: ‎01-13-2008
  • Location: US
  • Views: 2201949
  • Message 69 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-31, 3:22 AM

 wrote:
Appreciate your efforts. If only Lenovo was as quick to fix this issue as they are to jump on what was a helpful post.

Nobody "jumped" on  anything.  The post in question  - which I've restored - was nabbed by the automated spam filter.  It can sometimes be overly aggressive.

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Options

4 Posts

10-31-2019

US

10 Signins

68 Page Views

  • Posts: 4
  • Registered: ‎10-31-2019
  • Location: US
  • Views: 68
  • Message 70 of 228

Re: X1 extreme screen lag on "second screen only"

2019-10-31, 3:22 AM

This discussion was started in June. It really is not acceptable for Lenovo to not have pushed out a fix for this yet considering it is obviously wide-spread, it is easily reproducible almost 100% of the time, and seems to affect most people's machines in exactly the same way. Surely this should be a bug that could be fixed relatively quickly. 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete