cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MichaelR2D2
Punch Card
Posts: 18
Registered: ‎06-08-2019
Location: BE
Views: 2,080
Message 1 of 95

X1 extreme screen lag on "second screen only"

Does anyone else have this issue? When the monitor conf is set to second screen only, there is a noticeable lag. This mostly only happens when the notebook has been used on battery first. The issue is solved by either rebooting the notebook on AC or enabling the native monitor.

 

We've bought 3 units and all 3 are displaying this issue (i7-8750H + 1050) . All 3 are being used for very other purposes so it's not probable there is a common third party software issue. 

 

Video : https://youtu.be/TRJvPQHvrWQ (sry for audio, machine was working)

 

1) Second screen only ,  moving notepad window is very laggy

2) Extended screen is enabled , moving notepad is smooth again

 

Notepad just as a simple example, everything behaves this way on second screen only (like scrolling)

 

All drivers are up to date and latest bios firmware is installed

Herdkilling
Punch Card
Posts: 1
Registered: ‎11-20-2018
Location: US
Views: 2,005
Message 2 of 95

Re: X1 extreme screen lag on "second screen only"

Same here.

 

I've also noticed that if you open the Start menu, what's behind it becomes smooth, but as soon  as you close it, everything jitters once again.

MichaelR2D2
Punch Card
Posts: 18
Registered: ‎06-08-2019
Location: BE
Views: 1,971
Message 3 of 95

Re: X1 extreme screen lag on "second screen only"

@Lenovo, any solution to this? It's not ok I cannot use my notebook with second screen only ....

tbThink17
Serial Port
Posts: 34
Registered: ‎10-29-2017
Location: US
Views: 1,953
Message 4 of 95

Re: X1 extreme screen lag on "second screen only"

Same thing here...

 

I'm on win 10 version 1803 with X1E and same issue after disconnected from external hdmi, running on battery with LCD only, and then reconnecting laptop to external hdmi, the mouse cursor and attached windows as video shows jumps and lags bad.

 

I often see 5% system process usage in task manager details for no apparent reason.  Rebooting solves the problem.  This is fairly recent, say in the last month or two that this has become an issue and is very consistent in occurrence.

MichaelR2D2
Punch Card
Posts: 18
Registered: ‎06-08-2019
Location: BE
Views: 1,943
Message 5 of 95

Re: X1 extreme screen lag on "second screen only"

Here it also started +- a month ago. The behavior is exactly as you describe
King0fTheN0rth
Paper Tape
Posts: 2
Registered: ‎06-16-2019
Location: US
Views: 1,905
Message 6 of 95

Re: X1 extreme screen lag on "second screen only"

I have the same problem. Doesn't happen when "Discrete" mode is activated in the BIOS.
tbThink17
Serial Port
Posts: 34
Registered: ‎10-29-2017
Location: US
Views: 1,857
Message 7 of 95

Re: X1 extreme screen lag on "second screen only"

Well, that 'discrete' mode was a great clue, thx. So, it just happened again while on battery for a 20 minute meeting and reconnected to my external HDMI monitors and serious screen lag.

So I went into device manager and disabled the Intel UHD graphics 630 device and the problem went away. Re-enabled it and it the problem has not returned.

This looks like a temporary work-around until Lenovo gets this fixed.
Ahlun
Fanfold Paper
Posts: 11
Registered: ‎07-02-2019
Location: SG
Views: 1,812
Message 8 of 95

Re: X1 extreme screen lag on "second screen only"

Thanks. This setting to "discrete" is working for me. Hope they will come out with a fix soon. 

MichaelR2D2
Punch Card
Posts: 18
Registered: ‎06-08-2019
Location: BE
Views: 1,771
Message 9 of 95

Re: X1 extreme screen lag on "second screen only"

Doesnt this hurt battery too much ?
MichaelR2D2
Punch Card
Posts: 18
Registered: ‎06-08-2019
Location: BE
Views: 1,602
Message 10 of 95

Re: X1 extreme screen lag on "second screen only"

Hi Lenovo, Any solution to this problem?

Check out current deals!


Shop current deals

Top Kudoed Authors