English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

10 Posts

03-13-2010

Germany

25 Signins

137 Page Views

  • Posts: 10
  • Registered: ‎03-13-2010
  • Location: Germany
  • Views: 137
  • Message 21 of 87

Re: X100e BIOS Problems with WWAN Device Gobi 2000

2010-03-25, 8:15 AM

Hello Thinkpad-lover,

 

I'm not sure about the version of the x100e distributed in Singapore, but the version distributed in Germany is unlocked.

Reply
Options

4 Posts

03-24-2010

Israel

4 Signins

40 Page Views

  • Posts: 4
  • Registered: ‎03-24-2010
  • Location: Israel
  • Views: 40
  • Message 22 of 87

Re: X100e BIOS Problems with WWAN Device Gobi 2000

2010-03-25, 8:56 AM

Hello How did you manage to roll back, X100e does not let me roll back

 

Daniel

Reply
Options

7 Posts

03-24-2010

Finland

71 Signins

313 Page Views

  • Posts: 7
  • Registered: ‎03-24-2010
  • Location: Finland
  • Views: 313
  • Message 23 of 87

Re: X100e BIOS Problems with WWAN Device Gobi 2000

2010-03-25, 12:16 PM

 


wrote:

Hello How did you manage to roll back, X100e does not let me roll back

 

Daniel


 

 

Probably this won't be helping you much, but I just downloaded the BIOS upgrade (or downgrade) from here http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/6xuj02us.exe and ran the exe in windows. Then it managed to do the downgrade.

 

-Juho

Reply
Options

4 Posts

03-24-2010

Israel

4 Signins

40 Page Views

  • Posts: 4
  • Registered: ‎03-24-2010
  • Location: Israel
  • Views: 40
  • Message 24 of 87

Re: X100e BIOS Problems with WWAN Device Gobi 2000

2010-03-25, 13:25 PM

Hello all

 

the trik to d/l the file does not work,  there is an issue with the x100e model and the bios file - some mismatch

 

even a boot cd does not help

 

where is Lenovo when u need them......??????

 

Daniel

Reply
Options

10 Posts

03-24-2010

Singapore

21 Signins

183 Page Views

  • Posts: 10
  • Registered: ‎03-24-2010
  • Location: Singapore
  • Views: 183
  • Message 25 of 87

Re: X100e BIOS Problems with WWAN Device Gobi 2000

2010-03-25, 14:35 PM

"

Hello Thinkpad-lover,

 

I'm not sure about the version of the x100e distributed in Singapore, but the version distributed in Germany is unlocked.

"

So anybody in US can confirm if the gobi 2000 WWAN in X100e locked /unlocked by default?

In the Lenovo website i saw them allow buyer select one of three wireless carries: ATT, Sprint and Verizon

that really make me confused when decide. i decide to by this x100e in US market then probably move to European couple months for bussiness, so that why i made the question.

 

Thanks and regards

Reply
Options

10 Posts

03-13-2010

Germany

25 Signins

137 Page Views

  • Posts: 10
  • Registered: ‎03-13-2010
  • Location: Germany
  • Views: 137
  • Message 26 of 87

Re: X100e BIOS Problems with WWAN Device Gobi 2000

2010-03-27, 0:52 AM

Hi!

 

Since I need the WWAN device tomorrow I decided to roll back to the last working version (1.10a) again.

Now the BIOS update tool states the following:"The process does not recognize this system. The utility process has not completed."

 

Now I have a completely useless x100e standing right in front of me. Really great....

 

@Lenovo: Please react to this problem. Otherwise I will have to give this notebook back and reclaim my money.

 

Rotorhead

Reply
Options

32 Posts

03-21-2010

italy

45 Signins

567 Page Views

  • Posts: 32
  • Registered: ‎03-21-2010
  • Location: italy
  • Views: 567
  • Message 27 of 87

Re: X100e BIOS Problems with WWAN Device Gobi 2000

2010-03-27, 8:37 AM

Hi.

I have the same problem with downgrade from BIOS 1.20a to 1.10a...

I need a working Thinkpad not a Lenovo developers testing machine.

Reply
Options

32 Posts

03-21-2010

italy

45 Signins

567 Page Views

  • Posts: 32
  • Registered: ‎03-21-2010
  • Location: italy
  • Views: 567
  • Message 28 of 87

Thinkpad x100e: Few problems

2010-03-28, 12:27 PM

Hello everybody,

I bought a new Lenovo Thinkpad x100e one week after the release in Italy (22/02/2010). I received the box and I spent the weekend to unbox it.

I love Thinkpads, but...

I've not actived th wwan card. I've uninstalled office. I've installed office and then I've installed microsoft security essentials.

I transferring between old system and new system al my documents and outlook data.

I had problems with wifi and access connection then I decided to update all software.

First I run microsoft update then lenovo system update.

System update reported some updates including BIOS update. The BIOS version was 1.10a and the new was 1.16. I updated all including the BIOS.

It seemed to work only two icons had a little problems. The "Lenovo Think" icon in the application bar did not open anything and the the "Lenovo ThinkVantage Tools" in the start menu did open an explorers window.

I decided to remove this icons because I do not need.

At this point the system worked well and also access connection. But in the lenovo system updates window were two updates (wifi drivers and hdd issue). I installed two or three times, then I decided to ignore this issues.

I needed the the 3g connection to send an importatnt email from my car and then I saw that there are some problem with Gobi 2000. I cannot activate the hardware and I (and many other people) don't know how.

There is a problem with the BIOS 1.16 and wwan switch.

I searched on inet to resolve this other issue and I founded this forum.

I decide to downgrade the BIOS to version 1.10a but nothing to do. The Gobi 2000 wwan card do not swith on.

"Calm! The Lenovo support will release a patch. Other people have the same problem!"

I do a system restore then I've uninstalled office. I've installed office and then I've installed norton internet security.

I transferring between old system and new system al my documents and outlook data.

"Wait until release of a patch. Meanwhile I create recovery discs!"

On discs creation I had an error about disc validation. I repeated the operation three times with the same error.

"There are some errors in TVT update. Wait until release of a patch."

New BIOS was released 1.20a.

"Good! This solve my problems with wwan switch!"

Nothing to do.

"Roll back to 1.10a"

The process does not recognize this system. The utility process has not completed.

"Burn a cd!"

The process does not recognize this system. The utility process has not completed.

???????????????

"Wait until release of a patch."

I do a system restore then I've uninstalled office. I've installed office and then I've installed norton internet security.

I transferring between old system and new system al my documents and outlook data and nothing.

New access connectionis released!

"Where is other paches? Ok this can solve wwan issues. I need I can connect everywhere. I can wait for othes patches!"

Nothing to do. The wwan card do not work.

Practically now my system is a netbook (working). OS is Windows 7 Professional 32 bit (working). Office 2007 Enterprise Sp2 (working). Lenovo Think icon (not working). Lenovo ThinkVantage Tools icon (not working). Lenovo ThinkVantage ToolBox say me that the warranty is not idenfied (not working). Access Connection not reconnect on wifi lan on resume (not working). Gobi 2000 WWAN card is not recognize (not working). Umts connection (not working). Lenovo GPS (not working). System Recovery HDD (working). System Recovery CD sets is impossible to create (not working). System Recovery USB set is impossible to create (not working). BIOS update utility (not working). BIOS update cd (not working). System Update remind me that there are two updates (not working).

I have a Thinkpad x100e NOT WORKING and I cannot use the system for a week.

I CANNOT WORK FOR A WEEK!

Reply
Options

77 Posts

03-13-2010

NH

260 Signins

1326 Page Views

  • Posts: 77
  • Registered: ‎03-13-2010
  • Location: NH
  • Views: 1326
  • Message 29 of 87

Re: Thinkpad x100e: Few problems

2010-03-28, 13:28 PM

That sounds like an awful lot of installing and uninstalling things you've done, there.  :)  If it were me, I would either 1) roll back to the factory configuratation and start over with a clear head and maybe an initial call to tech support, 2) do a fresh install of WIndows, or 3) simply call tech support.  I would advise 3) for you since, with all due respect and no offense meant, you seem like you could use someone else guiding your efforts.

Reply
Options

32 Posts

03-21-2010

italy

45 Signins

567 Page Views

  • Posts: 32
  • Registered: ‎03-21-2010
  • Location: italy
  • Views: 567
  • Message 30 of 87

Re: Thinkpad x100e: Few problems

2010-03-28, 15:13 PM

Hi jvarszegi,

thank u for replay.

Whenever I say "I do a system restore" I mean a factory restore.

I called lenovo support and they open an assistance ticket, but if I bring the notebook back how I can work. I no longer have the old notebook.

Now I'm doing anther factory restore...

 

PS: Windows System classification exit with an error... It's impossible to grade the system (not work)

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete