Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

5 Posts

03-18-2011

VA, USA

5 Signins

49 Page Views

  • Posts: 5
  • Registered: ‎03-18-2011
  • Location: VA, USA
  • Views: 49
  • Message 1 of 40

X120e ABGN Driver issue in Windows 7 Pro x64

2011-03-18, 21:13 PM

I recently purchased an x120e and installed an SSD with my own copy of Windows 7 Professional 64-bit. I managed to install all drivers but my 2x2 ABGN wlan card driver refuses to install correctly. I keep getting a code 10 this device cannot start message and have tried to reinstall the drivers several times, and tried a fresh Windows install as well using my Win 7 Ultimate 64 DVD with the same result. I called Lenovo support and they remoted in and tried as well and couldn't get it to work. They sent me a replacement 2x2 wlan card and it too won't accept the drivers. Has anyone run into this issue?

 

I'm going to try installing a copy of Windows 7 32 next and see if its a 64-bit driver issue. If that doesn't resolve this, I'm guessing my only option is to call the warranty guy on-site and replace the system board. If anyone knows another fix or some other source for these broadcom drivers, please let me know. Thanks

 

Reply
Answer
Options

3538 Posts

07-12-2010

Malaysia

5065 Signins

104816 Page Views

  • Posts: 3538
  • Registered: ‎07-12-2010
  • Location: Malaysia
  • Views: 104816

Re: X120e ABGN Driver issue in Windows 7 Pro x64

2011-11-10, 16:36 PM
@All,

Driver has been released.

http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS014946

//JameZ
Reply

Replies(39)
Options

3322 Posts

07-31-2008

Pakistan

1715 Signins

151632 Page Views

  • Posts: 3322
  • Registered: ‎07-31-2008
  • Location: Pakistan
  • Views: 151632
  • Message 2 of 40

Re: X120e ABGN Driver issue in Windows 7 Pro x64

2011-03-18, 21:24 PM

Hi and welcome to the forum!


Try this, install the Hotkey Features, do a mandatory reboot, thereafter press Fn-F5 to radio on the wireless device, once that's done install the wireless driver.

 

Would be a good idea to check in the BIOS if the card is enabled in there.

 

Let us know the outcome.

------------------------------------------------------------

Maliha (I don't work for lenovo)
ThinkPads:- T400[Win 7], T60[Win 7], IBM 240[Win XP]

IdeaPad: U350

Apple:- Macbook Air [Snow Leopard]
Did someone help you today? Compliment them with a
Kudos!
Was your question answered today? Mark it as an Accepted Solution
de.gif  Lenovo Deutsche Community   es.gif  Lenovo Comunidad en Español 
Visit my YouTube Channel

Reply
Options

11 Posts

03-16-2011

USA

677 Signins

840 Page Views

  • Posts: 11
  • Registered: ‎03-16-2011
  • Location: USA
  • Views: 840
  • Message 3 of 40

Re: X120e ABGN Driver issue in Windows 7 Pro x64

2011-03-18, 21:51 PM

I ran into this exact same issue. Replacing the system board isn't likely to help as this is a driver problem. I played around with a fresh load of 64-bit sp1, but couldn't get wireless to work. I'm almost positive that I tried enabling the radio first. I ended up reverting to the system image. I may try to get a clean install working again but I'm holding off for now as I'll probably have to send my x120e back for its flickering backlight.

Reply
Options

5 Posts

03-18-2011

VA, USA

5 Signins

49 Page Views

  • Posts: 5
  • Registered: ‎03-18-2011
  • Location: VA, USA
  • Views: 49
  • Message 4 of 40

Re: X120e ABGN Driver issue in Windows 7 Pro x64

2011-03-18, 23:39 PM

Thanks for the replies.

 

I installed a 32-bit copy of Windows 7 and the 2x2 ABGN driver off Lenovo's website installed properly and the card is working perfectly now. There seems to be an issue with the 64-bit driver they have posted on the x120e driver matrix. Lenovo is mailing me recovery CDs for Win 7 64 which I'll have to use on my SSD until they release (hopefully) a new version that fixes the code 10 issues on Win 7 64 fresh installations

 

Here's the link to the driver I am referring to:

 

Version 5.100.82.27 (84W007WW)

http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-75618

 

If the mods can escalate this to Lenovo to fix the x120e's x64 drivers for fresh Win 7 installations, I'd appreciate it. 

 

Hope this info helps others that run into this same problem.

Reply
Options

86 Posts

03-14-2011

Atlanta, GA

274 Signins

770 Page Views

  • Posts: 86
  • Registered: ‎03-14-2011
  • Location: Atlanta, GA
  • Views: 770
  • Message 5 of 40

Re: X120e ABGN Driver issue in Windows 7 Pro x64

2011-03-19, 1:56 AM

When I installed my copy of WIn 7 SP1 64 bit, I downloaded the latest driver from Lenovo at the time and it is 5.60.350.21.  It worked great for me.

 

The product code is the same as yours 802.11a/b/g/n - broadcom 2x2 84W007W

 

I don't see it on Lenovo's site anymore so I uploaded it here if you want to give it a try:

http://www.megaupload.com/?d=76UQYCEG

x220 | 4286-CTO | i5-2520M | 8Gb G.Skill | OCZ SSD
Win 7 Home Premium SP1 64bit
Reply
Options

5 Posts

03-18-2011

VA, USA

5 Signins

49 Page Views

  • Posts: 5
  • Registered: ‎03-18-2011
  • Location: VA, USA
  • Views: 49
  • Message 6 of 40

Re: X120e ABGN Driver issue in Windows 7 Pro x64

2011-03-19, 17:01 PM

Thanks, tried the driver you uploaded. Unfortunately I had no luck. Same code 10 issue :(

Reply
Options

24 Posts

06-06-2010

Michigan, USA

19 Signins

147 Page Views

  • Posts: 24
  • Registered: ‎06-06-2010
  • Location: Michigan, USA
  • Views: 147
  • Message 7 of 40

Re: X120e ABGN Driver issue in Windows 7 Pro x64

2011-03-21, 3:22 AM

I too can confirm this is an issue.

 

Error code 10 after installing the driver from Lenovo's site on Windows 7 Professional 64-bit. I would appreciate it if Lenovo would escalate this issue and release drivers that work.

 

UPDATE: Since I still had my factory hard drive (I upgraded to SSD), I plugged it in via USB and tried installing the drivers that I know were working on that factory install. They didn't work. Same error 10.

Reply
Options

289 Posts

11-28-2007

United States of America

412 Signins

9231 Page Views

  • Posts: 289
  • Registered: ‎11-28-2007
  • Location: United States of America
  • Views: 9231
  • Message 8 of 40

Re: X120e ABGN Driver issue in Windows 7 Pro x64

2011-03-22, 13:50 PM

Here is the Lenovo driver:

 

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-75618

Reply
Options

11 Posts

03-16-2011

USA

677 Signins

840 Page Views

  • Posts: 11
  • Registered: ‎03-16-2011
  • Location: USA
  • Views: 840
  • Message 9 of 40

Re: X120e ABGN Driver issue in Windows 7 Pro x64

2011-03-22, 14:12 PM

???

 

Nobody had a problem finding the driver on the download page. That same link appears a few posts up. The issue is that installing that driver results in a code 10 error in device manager for the wireless card.

Reply
Options

289 Posts

11-28-2007

United States of America

412 Signins

9231 Page Views

  • Posts: 289
  • Registered: ‎11-28-2007
  • Location: United States of America
  • Views: 9231
  • Message 10 of 40

Re: X120e ABGN Driver issue in Windows 7 Pro x64

2011-03-22, 14:45 PM

Just put a 2x2 card (FRU 60y3251) into my X120e running Win7 Pro 65.

I uninstalled the previous wireless drivers, installed the card and booted.  Installed the Lenovo drivers, card works fine.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All