English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

10 Posts

06-28-2018

FR

26 Signins

288 Page Views

  • Posts: 10
  • Registered: ‎06-28-2018
  • Location: FR
  • Views: 288
  • Message 1 of 4

X1C6 charging problem: charging LED stuck "on" even unplugged & reports repeatedly unplugged/plugged

2019-01-09, 10:16 AM

Hi.
I have recently a charging problem with my X1C6.

Yesterday, I have plugged the USB-C charger into the USB-C port.

Then Windows repeatedly notices that the charger was plugged, then unplugged, then plugged (many events in Windows Event Viewer) and the Thunderbolt software (in systray keeps crashing/restarting).

The problem continued even with the charger unplugged, even after a reboot.

The charging orange LED was stuck "on" even with the charger unplugged (also with the computer off):

 

I had to restart the computer and disable the internal battery in the BIOS to restore the computer to a normal state.

In the Windows reliability monitor, I can see many Windows Hardware Error (related to USB-C UCM/USCI system : LKD_0x1D4_COMMAND_TIMEOUT_9_UcmUcsiAcpiClient_UcmUcsiCx!UcmUcsiCx::CxDevice::UnrecoverableFailureEncountered) and many Thunderbolt software and services crashes.

 

The battery was already replaced due to another problem (random 0% charge level reporting).
This charging problem had happened with the old one and the new one.

 

Anybody had already encountered this problem ?
Do you think it's a rather a USCI/EC/BIOS firmware problem or a faulty hardware ?

I think I will ask a motherboard replacement under warranty.

Solved! See the solution
Reply
Options

10 Posts

06-28-2018

FR

26 Signins

288 Page Views

  • Posts: 10
  • Registered: ‎06-28-2018
  • Location: FR
  • Views: 288
  • Message 2 of 4

Re: X1C6 charging problem: charging LED stuck "on" even unplugged & reports repeatedly

2019-01-09, 12:00 PM

I have found 2 other people with the same problem on Reddit :

https://www.reddit.com/r/thinkpad/comments/9520ac/thinkpad_x1c6_not_plugged_in_but_icon_shows/ (5 month ago)

https://www.reddit.com/r/thinkpad/comments/8lavhj/thinkpad_x1_carbon_gen_6_charging_without_charger/ (7 month ago)

 

The motherboard may be faulty.

 

Reply
Options

13 Posts

05-31-2015

US

26 Signins

159 Page Views

  • Posts: 13
  • Registered: ‎05-31-2015
  • Location: US
  • Views: 159
  • Message 3 of 4

Re: X1C6 charging problem: charging LED stuck "on" even unplugged & reports repeatedly

2019-03-14, 2:28 AM
Easy way to fix this is hard resetting the machine. You can do this in BIOS. In power, there should be the option "Disable built-in battery" (see https://support.lenovo.com/us/en/solutions/pd025206). It should hard reset the machine and it should start working correctly.

0 person found this solution to be helpful.

This helped me too

Reply
Options

10 Posts

06-28-2018

FR

26 Signins

288 Page Views

  • Posts: 10
  • Registered: ‎06-28-2018
  • Location: FR
  • Views: 288
  • Message 4 of 4

Re: X1C6 charging problem: charging LED stuck "on" even unplugged & reports repeatedly

2019-03-14, 8:13 AM

Hi.
Thanks for your help.
Disabling the built-in battery hard resets the machine and fix the problem.

Another quick fix is to press the hard reset button (hole at the bottom case).

 

This problem is also reported by other X1 Carbon 6th Gen or X1 Yoga 3rd gen users : https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/Help-X1-Carbon-6th-Gen-thinks-it-s-plugged-in-amp-charging/td-p/4319276

 

I think there is a bug in the BIOS or EC.

 

Lenovo has a recently released a new BIOS for Carbon (1.37) and Yoga (1.30):

- (Fix) Fixed an issue where incorrect wattage is displayed when attach an AC adaptor.

The problem haven't  happenned since I have updated, but I don't know if it can fix this problem (I rarely use my Thikpad on battery and charge it).

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete