English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

14 Posts

01-09-2018

CH

39 Signins

478 Page Views

  • Posts: 14
  • Registered: ‎01-09-2018
  • Location: CH
  • Views: 478
  • Message 1 of 2

X1E BIOS 1.17 - Stuck at "Configuring Thunderbolt Controller"

2019-01-23, 17:47 PM

I read about the recent issues concerning Thunderbolt BIOS Assist Mode, and I understood the related issues had been solved by recent BIOS updates. I am using Linux, so today I took the plunge, entered the BIOS settings (v1.17), and did the following:

  • I disabled the "Wake by Thunderbolt"
  • I enabled "Thunderbolt BIOS Assist Mode". The message informed me that reconfiguration may take up to 15 seconds.
  • Security Level was already set to "No Security" and "Pre Boot" support was disabled (it was never enabled)
  • Saved the BIOS settings. The X1 Extreme restarted.

At this point, I got the message: "Configuring Thunderbolt Controller... Please do not power off!" and waited.

 

After five minutes, still at the same page. After ten minutes, still stuck. I silently screamed. After twenty minutes, still there. I disconnected the power adapter, and tried to press the power button for several seconds. Nothing. Completely stuck.

 

I took a paperclip and pressed the emergency reset button on the bottom part of the case. The machine shut off, and I really prayed that the machine wasn't dead.

 

Switched it on, and thankfully the computer booted up. The BIOS settings showed the selected options in place, but I cannot know whether the controller is really working correctly, or whether the controller firmware is half-flashed or otherwise corrupted.

 

I entered the BIOS settings again and disabled the "Thunderbolt BIOS Assist Mode". Reboot. Stuck again at the "Configuring Thunderbolt Controller" page. No response whatsoever.

 

In the end I pressed again the emergency reset button, restarted, and disabled Thunderbolt in the I/O page. I don't dare to connect any device to the ports at this point.

 

So, it seems there are still some Thunderbolt-related issues on the X1 Extreme, even with the 1.17 BIOS. Thankfully they are not fatal, but certainly the process does not always work correctly, unfortunately. And I don't know in what condition that left the Thunderbolt controller firmware and settings, on my machine.

Lenovo System Update does not show any BIOS or Thunderbolt-related update at this time.

 

Suggestions? If anyone at Lenovo wants to investigate, I'll be happy to help.

Reply
Options

14 Posts

01-09-2018

CH

39 Signins

478 Page Views

  • Posts: 14
  • Registered: ‎01-09-2018
  • Location: CH
  • Views: 478
  • Message 2 of 2

Re: X1E BIOS 1.18 - Stuck at "Configuring Thunderbolt Controller"

2019-02-04, 21:54 PM

This is still a problem with BIOS 1.18. When I enable or disable "Thunderbolt BIOS Assist Mode" and restart, the machine hangs indefinitely on the message "Configuring Thunderbolt Controller": I have to hard reset it by using the hardware reset button under the computer.

This happens regardless of whether the "Wake by Thunderbolt" or "Pre-boot" options are enabled or not.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save