Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

4 Posts

04-03-2019

Switzerland

7 Signins

42 Page Views

  • Posts: 4
  • Registered: ‎04-03-2019
  • Location: Switzerland
  • Views: 42
  • Message 1 of 9

X1E struggling with external 4K monitor

2019-04-03, 14:31 PM

Hi All

 

I recently bought an X1E in hope for better performance. After connecting it with my external 4K monitor (LG 27UK650) i noticed sluggish performance. The GPU is only at 20-30%. When i change the displaysettings from 4K to 2K (2560x1440) it works fine. 

 

Since i have the montor connected with an USB-C to DP cable, i thought this might cause the performance drop.

 

I thought the X1E can power 2 montiors simultaneously at 4K. What am i doing wrong here?

 

Thanks

Ramon

Reply
Answer
Options

4 Posts

04-03-2019

Switzerland

7 Signins

42 Page Views

  • Posts: 4
  • Registered: ‎04-03-2019
  • Location: Switzerland
  • Views: 42

Re: X1E struggling with external 4K monitor

2019-04-05, 13:59 PM

Ok, i could resolve the issue. 

 

I installed an older driver (LG monitor driver) and resetted all bios configs... it worked after this. 
I also noticed, the GPU's are much smoother now, using less calculating-power.

 

Thanks PunchCard trying to help +1!! .

Reply

Replies(8)
Options

63 Posts

05-31-2011

Germany

234 Signins

986 Page Views

  • Posts: 63
  • Registered: ‎05-31-2011
  • Location: Germany
  • Views: 986
  • Message 2 of 9

Re: X1E struggling with external 4K monitor

2019-04-04, 10:25 AM

I have my 4K monitor connected via USB-C, too, and it works fine.

 

I'm even gaming in 4K on it (older games: DOA5, Kotor II) without any problems.

 

My monitor supports native USB-C (Eizo 3285).

Reply
Options

4 Posts

04-03-2019

Switzerland

7 Signins

42 Page Views

  • Posts: 4
  • Registered: ‎04-03-2019
  • Location: Switzerland
  • Views: 42
  • Message 3 of 9

Re: X1E struggling with external 4K monitor

2019-04-05, 8:53 AM

Thanks Punch Card for reply. 

 

Generally my monitor works too, the problem on my 4K monitor running on 4K resolution. it's dragging and lagging, even if you just move a window around. When i switch the 4K res. to 2K, it's fine.... just like a perfect working monitor.

 

I just updated my graphics driver, refreshed the monitor driver, even tried with HDMI.... still the same problem.

Is it possible that a 1050ti + 630 onboard graphics is struggling? 

 

Thanks

Ramon

Reply
Options

63 Posts

05-31-2011

Germany

234 Signins

986 Page Views

  • Posts: 63
  • Registered: ‎05-31-2011
  • Location: Germany
  • Views: 986
  • Message 4 of 9

Re: X1E struggling with external 4K monitor

2019-04-05, 10:29 AM

I had performance issues with my former notebooks when connecting external monitors.

 

With this notebook I am positively surprised about the performance in 4K.

I never thought about being able to game on a notebook in 4K, yet here I am.

 

I would suggest the following things:

 

- make sure that the GPU is indeed working. It may be disabled in the bios or in power settings. 4K may indeed be too much for a Intel 630. You can see that in the task manager: look for the column "GPU module" (you may need to configure it). There should be two entries there then connected to an external monitor: "GPU-0" (integrated) and "GPU-1" (dedicated).

 

- try your notebook on a different monitor. I have an external mobile notebook monitor that can also be connected via USB-C. However that monitor is driven by an software emulation protocol "DisplayLink", so that it can also connect via an USB 3.0 port. "DisplayLink" however is not as performant as a native "DisplayPort" connection by far.

 

- try a different connection cable. With USB 3.0, 3.1, 3.1 Gen 2 and Thunderbolt (all over USB-C connectors) it's a jungle out there regarding cables.

Reply
Answer
Options

4 Posts

04-03-2019

Switzerland

7 Signins

42 Page Views

  • Posts: 4
  • Registered: ‎04-03-2019
  • Location: Switzerland
  • Views: 42
  • Message 5 of 9

Re: X1E struggling with external 4K monitor

2019-04-05, 13:59 PM

Ok, i could resolve the issue. 

 

I installed an older driver (LG monitor driver) and resetted all bios configs... it worked after this. 
I also noticed, the GPU's are much smoother now, using less calculating-power.

 

Thanks PunchCard trying to help +1!! .

0 person found this solution to be helpful.

This helped me too

Reply
Options

3 Posts

08-05-2019

United States of America

3 Signins

21 Page Views

  • Posts: 3
  • Registered: ‎08-05-2019
  • Location: United States of America
  • Views: 21
  • Message 6 of 9

Re: X1E struggling with external 4K monitor

2019-08-05, 2:43 AM

Hello

I am having the same issue with dragging and lagging on my external 4K monitor, even if you just move a window around.

Thinkpad X1 Extreme is brand new, and the external monitor HP Z27 4K is also brand new, connected via Lenovo Thunderbolt 230W Dock.

 

Please help with any advise

 

thanks

Reply
Options

33 Posts

10-24-2016

Poland

50 Signins

321 Page Views

  • Posts: 33
  • Registered: ‎10-24-2016
  • Location: Poland
  • Views: 321
  • Message 7 of 9

Re: X1E struggling with external 4K monitor

2019-09-26, 12:53 PM

you need to kill DWM

 

https://www.reddit.com/r/thinkpad/comments/cnarfe/strange_displayrelated_lag_x1e_gen_2/

 

it affects many notebook w/ hardware MUX

 

hope there will be a fix for that ... should be from Lenovo but in most of the threads I have read people have no idea whether this is HW or SW related, windows or drivers....

Reply
Options

3 Posts

08-05-2019

United States of America

3 Signins

21 Page Views

  • Posts: 3
  • Registered: ‎08-05-2019
  • Location: United States of America
  • Views: 21
  • Message 8 of 9

Re: X1E struggling with external 4K monitor

2019-09-26, 17:37 PM

okay thank you much.

Let me try killing the DWM process.

Until now the workaround that I have been doing when it lags is to restart the computer (warm reboot)

Reply
Options

3 Posts

08-05-2019

United States of America

3 Signins

21 Page Views

  • Posts: 3
  • Registered: ‎08-05-2019
  • Location: United States of America
  • Views: 21
  • Message 9 of 9

Re: X1E struggling with external 4K monitor

2019-09-28, 5:32 AM

killing the DWM works (and the DWM restarts right away).

This is the temporary workaround for now.

I have created a run script shortcut which I placed on the Desktop to kill the DMW when the external monitor lags.

Thank you for the help !

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms