cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
valveradio59
Fanfold Paper
Posts: 18
Registered: ‎08-01-2011
Location: UK
Views: 751
Message 1 of 5

X201 slow with SSD

Hi all

 

I cloned my existing hard drive (Windows 7 Pro) to a new 128GB Crucial M4 SSD a couple of weeks ago and am very disappointed at the speed of the SSD.  It doesn't seem much faster than the hard drive it replaced (and is perhaps a little slower), and having just run Crystal Diskmark and compared the results to those of others, there seems to be something not quite right - I would have attached a screenshot of the results but there doesn't seem to be any way of doing this.

 

Starting the machine even from hibernate takes almost a minute, but I've seen other X201's cold boot from SSD in under 30 seconds!

 

Any ideas anyone?

 

Many thanks

 

 

VR

Community SeniorMod
Community SeniorMod
Posts: 11,845
Registered: ‎06-06-2011
Location: RU
Views: 742
Message 2 of 5

Re: X201 slow with SSD

Hi,

open command prompt window (win+r, cmd) and type in the following string:
wmic partition get BlockSize, Index, Name, StartingOffset

post output here



x220 • Gobi 2000 3g | hdd, msata ssd, wwan, wifi, gps -- unique hand-made config
ThinkPad 25 Special Anniversary Edition. #retro. Signed by D.Hill
T470p | X1 Carbon Gen3 | Miix 2 10" | Yoga Tablet 2-1050F (Android) + BT Keyboard
ThinkPad Stack • 2.4/5 Wireless Router, HDD 1 TB, BT Speaker, Power Bank, Mobile Projector

Do it well, worse becomes itself

Communities:   English    Deutsche    Español    Portugues    Русскоязычное    Česká    Slovenská    Українська   Moto English

valveradio59
Fanfold Paper
Posts: 18
Registered: ‎08-01-2011
Location: UK
Views: 729
Message 3 of 5

Re: X201 slow with SSD

Hi

 

Thanks for your reply.

 

C:\Users\VR>wmic partition get BlockSize, Index, Name, StartingOffset
BlockSize  Index  Name                   StartingOffset
512        0      Disk #0, Partition #0  1048576
512        1      Disk #0, Partition #1  5059379200

Community SeniorMod
Community SeniorMod
Posts: 11,845
Registered: ‎06-06-2011
Location: RU
Views: 718
Message 4 of 5

Re: X201 slow with SSD

Fortunately, the cause I've thought about first of all, is absent. It's a partition alignment for modern drives with 4k phisical sector. Everything is properly in this context.

So, I'd advice to check out SSD firmware version, in drive and on Crucial site.



x220 • Gobi 2000 3g | hdd, msata ssd, wwan, wifi, gps -- unique hand-made config
ThinkPad 25 Special Anniversary Edition. #retro. Signed by D.Hill
T470p | X1 Carbon Gen3 | Miix 2 10" | Yoga Tablet 2-1050F (Android) + BT Keyboard
ThinkPad Stack • 2.4/5 Wireless Router, HDD 1 TB, BT Speaker, Power Bank, Mobile Projector

Do it well, worse becomes itself

Communities:   English    Deutsche    Español    Portugues    Русскоязычное    Česká    Slovenská    Українська   Moto English

valveradio59
Fanfold Paper
Posts: 18
Registered: ‎08-01-2011
Location: UK
Views: 715
Message 5 of 5

Re: X201 slow with SSD

Yes, the 4k alignment was set during the cloning operation, so I didn't think it was the problem.

 

Thanks anyway.

 

VR

Check out current deals!


Shop current deals

Top Kudoed Authors