Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Paper Tape
Posts: 4
Registered: ‎11-12-2010
Location: Palo Alto
0 Kudos

X201i (Windows 7 x64) cannot resume WiFi after sleep mode

My X201i cannot reconnect to WiFi after the sleep mode (closing lid). Is it any method to fix it? 


I am pretty sure I update drivers and bios. This problem is vey annoying.


Thanks in advance.

Posts: 3,220
Registered: ‎07-31-2008
Location: Pakistan
0 Kudos

Re: X201i (Windows 7 x64) cannot resume WiFi after sleep mode

Hi and welcome to the forum!

Go to Device Manager, right-click the wireless network adapter and then select Properties. Now head over to the Power Management tab, uncheck the option that says “Allow the computer to turn off this device to save power”, and click OK. Now go to the Advanced tab and make sure Transmit Power is set to maximum.

Also go into lenovo Power Manager, switch to Advanced mode and make certain that for wireless card Maximum Power is selected for both battery and AC Adapter.

Hope this helps.


Maliha (I don't work for lenovo)
ThinkPads:- T400[Win 7], T60[Win 7], IBM 240[Win XP]

IdeaPad: U350

Apple:- Macbook Air [Snow Leopard]
Did someone help you today? Compliment them with a
Was your question answered today? Mark it as an Accepted Solution
de.gif  Lenovo Deutsche Community   es.gif  Lenovo Comunidad en Español 
Visit my YouTube Channel

What's DOS?
Posts: 1
Registered: ‎11-28-2010
Location: Singapore
0 Kudos

Re: X201i (Windows 7 x64) cannot resume WiFi after sleep mode



I'm facing the same problem too.


My Lenovo X201i Thinkpad was connected to the home WLAN network and it went to screensaver mode, and subsequently sleep mode after I left the laptop on to run some errands.


When I returned and re-activated the laptop, I realised that I had no internet access, but was still connected to the WLAN. This was the first time such a situation occurred. Normally I had no problems with the internet access after re-activating the laptop from sleep mode as it would automatically reconnect to the WLAN.


As I could connect to the internet via my home WLAN using another laptop, my router should be working fine.

But when I brought my Thinkpad to a friend's home, the same problem persisted: connection to the WLAN network was established, but no internet access.


I ensured that the option "Allow the computer to turn off this device to save power" is unchecked; as well as the Transmit Power is set to maximum, but still to no avail.


Please help!