Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit our eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

19 Posts

05-21-2011

USA

23 Signins

122 Page Views

  • Posts: 19
  • Registered: ‎05-21-2011
  • Location: USA
  • Views: 122
  • Message 1 of 7

X220: How do I turn off screen orientation hotkeys?

2011-06-01, 3:59 AM

Problem:  Windows virtual PC captures the mouse pointer, and the hotkey combo to release the pointer to the host OS (Win7) is Ctrl-Alt-Left arrow.    When I type that key combination, it's interpreted as a screen orientation chage to portrait mode, top to left.

Workaround: Minimize all with WIndows-M key combination., which also releases mouse control back to Win7

 

 

I've tried:

1. Right click Desktop, Graphics Options, Hot Keys, Disable.

2. Right click desktop,  Graphics Properties, Options and Support, Hot Key Manager. Unchecked the Enable box, or change the hotkey for "Rotate to 90 degrees"to something other than ctrl-alt-Left.

 

None of these work, the screen still rotates to the left when I hit Ctrl-Alt-Left arrow. 

The video driver is at current level.

 

Any thoughts?

 

 

 

Solved! See the solution
Reply
Options

213 Posts

12-06-2007

United States of America

431 Signins

7269 Page Views

  • Posts: 213
  • Registered: ‎12-06-2007
  • Location: United States of America
  • Views: 7269
  • Message 2 of 7

Re: X220: How do I turn off screen orientation hotkeys?

2011-06-02, 12:42 PM

Assuming this is the Intel graphics panel. Press ctrl+alt+F12 to get the intel control panel up. Enter advance mode and go into options. You'll see the enable/disable there. Or you can remap the keys.

Reply
Options

19 Posts

05-21-2011

USA

23 Signins

122 Page Views

  • Posts: 19
  • Registered: ‎05-21-2011
  • Location: USA
  • Views: 122
  • Message 3 of 7

Re: X220: How do I turn off screen orientation hotkeys?

2011-06-02, 19:41 PM

Doesn't work.

 

Either of the two disable methods, AND, defining a new hotkey combination to replace Ctrl-Alt-Left changes nothing. 

Hitting Ctrl-Alt-Left still rotates the screen 90 degrees CCW.

 

I tried uninstalling the driver package, and that got rid of the hotkeys, but the issue returned when I reinstalled it.

 

 

Reply
Options

5438 Posts

04-25-2008

United States of America

39755 Signins

759519 Page Views

  • Posts: 5438
  • Registered: ‎04-25-2008
  • Location: United States of America
  • Views: 759519
  • Message 4 of 7

Re: X220: How do I turn off screen orientation hotkeys?

2011-06-02, 21:50 PM

Hi dnw333!

 

The Lenovo Reading Optimizer also uses those same rotation hot keys. Try uninstalling it.

 

Hope this helps!

USB-C: Just cos it fits don't mean it works.
I don't work for Lenovo. I'm a crazy volunteer!

0 person found this solution to be helpful.

This helped me too

Reply
Options

19 Posts

05-21-2011

USA

23 Signins

122 Page Views

  • Posts: 19
  • Registered: ‎05-21-2011
  • Location: USA
  • Views: 122
  • Message 5 of 7

Re: X220: How do I turn off screen orientation hotkeys?

2011-06-03, 0:30 AM

The reading optimizer showed disabled, but I uninstalled it anyway, and it fixed the problem. - Thanks.

 

So, this program is bugged, in that it duplicates the screen rotation function of the Intel video driver, and makes it appear that the Intel software is faulty because the feature can't be disabled.

 



Reply
Options

31 Posts

07-08-2009

Toulon, France

50 Signins

366 Page Views

  • Posts: 31
  • Registered: ‎07-08-2009
  • Location: Toulon, France
  • Views: 366
  • Message 6 of 7

Re: X220: How do I turn off screen orientation hotkeys?

2013-04-19, 6:53 AM

Hello,

 

I was unable to deactivate this feature in the options panel.

 

Howeer, the desinstallation of the program works.

 

Regards,

Lenovo X220 4287-CTO / Intel Core i7 2640M @ 2.8 / Corsair Vengeance 16 Go@1866 MHz CL10 / Samsung SSD 840 PRO 512 Go / Bios 1.38 / Linux Xubuntu 14.04LTS / eGPU ATI Radeon 5870 Eyefinity 6 / 2x DELL U2142M / 2x DELL U2212HM
Reply
Options

7 Posts

01-26-2012

Australia

4 Signins

29 Page Views

  • Posts: 7
  • Registered: ‎01-26-2012
  • Location: Australia
  • Views: 29
  • Message 7 of 7

Re: X220: How do I turn off screen orientation hotkeys?

2013-06-02, 17:08 PM

The solution is to uninstall a buggy piece of software? That's pretty ridiculous - I think the solution is for Lenovo engineers to fix the issue, granted they probably have higher priority things to work on....

 

Just open source the software and I (or someone else) will fix it!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms