Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

78 Posts

05-15-2011

USA

991 Signins

1823 Page Views

  • Posts: 78
  • Registered: ‎05-15-2011
  • Location: USA
  • Views: 1823
  • Message 11 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-05-25, 20:47 PM

petrov,

 

Oddly, I'm not 100% sure what leads to this behavior.  It happens now with every unplug/replug of my AC adapter.  The screen blanks for around 1 second and then the picture returns, the refresh rate having switched accordingly.  If on battery, it switches on its own to 50 Hz.  If plugged in, 60 Hz.  You can manually change it at will from within the Intel Graphics software, but you must do it every single time as it recurs no matter what you change.  The Windows Power Settings also do not seem to be to blame.

 

For what it's worth, JameZ reported today to T420s owners that engineering has now replicated this behavior.  It does indeed seem to be a problem that (hopefully) can be fixed by Lenovo:

 

http://forums.lenovo.com/t5/T400-T500-and-newer-T-series/T420S-Display-Switching-To-50Hz-On-Battery-Power/m-p/442541#M44304

 

-Steve

Owner/Technology Specialist
Triple-S Computers - http://www.TripleSComputers.com
Reply
Options

86 Posts

03-14-2011

Atlanta, GA

274 Signins

770 Page Views

  • Posts: 86
  • Registered: ‎03-14-2011
  • Location: Atlanta, GA
  • Views: 770
  • Message 12 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-05-26, 15:00 PM

This was one of the issues that was driving me crazy when i first got the x220.  The result of 50Hz refresh rate was a wavey-pulsing aross the screen from bottom to top.  After changing it to force 60Hz in both the intel driver and the Lenovo Power Manager, the screen seems to stay at 60Hz now.

x220 | 4286-CTO | i5-2520M | 8Gb G.Skill | OCZ SSD
Win 7 Home Premium SP1 64bit
Reply
Options

23 Posts

05-21-2011

Germany

26 Signins

152 Page Views

  • Posts: 23
  • Registered: ‎05-21-2011
  • Location: Germany
  • Views: 152
  • Message 13 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-05-31, 14:19 PM

The problem seems to be Lenovo's Power Manager. I have just uninstalled the Power Manager and now the screen stays at 60hz when I unplug the power cord. Also the screen does not blank out anymore after unplugging.  I guess I will just stop using the Power Manager. 

 

I still have a "wavey-pulsing aross the screen from bottom to top" when I lower the screen brightness down from 15 (60hz) :-(

Reply
Options

23 Posts

05-21-2011

Germany

26 Signins

152 Page Views

  • Posts: 23
  • Registered: ‎05-21-2011
  • Location: Germany
  • Views: 152
  • Message 14 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-06-01, 13:52 PM

Unfortunately I had to restore my windows. Now the screen sets back to 50hz once I unplug the power. Trying the same steps as yesterday does not change anything :-(

 

Edit: Right now I am testing with a Win 7 Prof 64 clean install and nothing but Intel Chipset and HD drivers (from Lenovo). Once I unplug the power, the screen blacks out for a second and the refreshrate is set to 50hz. So the power manager is not the problem, it's intel. 

Reply
Options

55 Posts

05-24-2011

New York City

342 Signins

1403 Page Views

  • Posts: 55
  • Registered: ‎05-24-2011
  • Location: New York City
  • Views: 1403
  • Message 15 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-06-03, 11:53 AM

wrote:

This was one of the issues that was driving me crazy when i first got the x220.  The result of 50Hz refresh rate was a wavey-pulsing aross the screen from bottom to top.  After changing it to force 60Hz in both the intel driver and the Lenovo Power Manager, the screen seems to stay at 60Hz now.


How did you force it to stay there in the intel driver? Did you just change it manually to 60hz and it kept it there.

I have done all the changes in the intel settings SET IT TO 60HZ and in windows monitor settings SET IT TO 60HZ and on power manager to NEVER DECREASE REFRESH RATE, but still this issue wont go away. I also trying the maximum performance setting for the graphics card while on battery and still get switched to 50hz when unplugging ac adapter. Can anyone suggest anything else? I have already updated graphics hd drivers to the latest on the lenovo site.
Reply
Options

5884 Posts

11-24-2007

United States of America

12810 Signins

291275 Page Views

  • Posts: 5884
  • Registered: ‎11-24-2007
  • Location: United States of America
  • Views: 291275
  • Message 16 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-06-03, 12:47 PM

wrote:
Can anyone suggest anything else?

did you try what i suggested here?   this is controlled by intel's own igfxpers.exe process.   disabling it will remove all ability for intel's software to switch refresh rates.

ThinkStation P700      ThinkPad X1C7

Reply
Options

55 Posts

05-24-2011

New York City

342 Signins

1403 Page Views

  • Posts: 55
  • Registered: ‎05-24-2011
  • Location: New York City
  • Views: 1403
  • Message 17 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-06-03, 13:33 PM

wrote:

wrote:
Can anyone suggest anything else?

did you try what i suggested here?   this is controlled by intel's own igfxpers.exe process.   disabling it will remove all ability for intel's software to switch refresh rates.


 

Yes, Ill be doing that later today. I saw it after on that thread. Thanks.
Reply
Options

41 Posts

06-08-2011

United States

572 Signins

916 Page Views

  • Posts: 41
  • Registered: ‎06-08-2011
  • Location: United States
  • Views: 916
  • Message 18 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-06-08, 12:58 PM

I am also experiencing this issue and have not yet found what seems to be an official solution. I understand that the workaround provided here does prevent the switching from 60 to 50 hz, but I simply don't feel comfortable disabling the service that manages my graphics card.

 

Installing the latest Intel HD Graphics drivers did not fix the issue, but it did have an unrelated effect of increasing the windows rating of my graphics from 4.6 to 4.7, as well as vastly reducing the brighness range for my monitor (not as dark at minimum, not as bright at maximum), and breaking lenovo's OSD.

 

Setting the "Decrease refresh rate" timer in Lenovo's power manager, setting the refresh rate to 60hz in Intel's graphics properties, and setting it to 60hz in the monitor properties all do nothing to prevent 50 hz when I unplug.

Reply
Options

6937 Posts

10-29-2009

United States of America

17812 Signins

166152 Page Views

  • Posts: 6937
  • Registered: ‎10-29-2009
  • Location: United States of America
  • Views: 166152
  • Message 19 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-06-08, 14:58 PM

I think JameZ already posted the official answer in the thread about T420s that was linked up above.  This is a problem with the Intel graphics driver.  It is not a problem with BIOS, with Power Manager, or with any other graphics driver (like nVidia).  I think we are going to have to wait for an update from Intel as JameZ said.  I hope it comes soon because this problem is driving me crazy also.

 

erik, thanks for the tip about killing igfxpers.exe - that's what i'm doing now to prevent this annoying issue.

Reply
Options

5884 Posts

11-24-2007

United States of America

12810 Signins

291275 Page Views

  • Posts: 5884
  • Registered: ‎11-24-2007
  • Location: United States of America
  • Views: 291275
  • Message 20 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-06-09, 0:45 AM

wrote:

erik, thanks for the tip about killing igfxpers.exe - that's what i'm doing now to prevent this annoying issue.


no problem.   it's a hack workaround but a workaround nonetheless.

 

good to know this is indeed a 100% intel issue as suspected.   that's a load off a few shoulders. ;)

ThinkStation P700      ThinkPad X1C7

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All