Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

24 Posts

05-20-2011

USA

150 Signins

533 Page Views

  • Posts: 24
  • Registered: ‎05-20-2011
  • Location: USA
  • Views: 533
  • Message 31 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-08-12, 16:39 PM

This has not been fixed in the latest driver for me, unfortunately.

 

I uninstalled the old one, uninstalled it again through the device manager, installed the new driver, and I still get the refresh rate changing to 50hz on battery uncontrollably.

Reply
Options

45 Posts

06-28-2011

Sweden

65 Signins

299 Page Views

  • Posts: 45
  • Registered: ‎06-28-2011
  • Location: Sweden
  • Views: 299
  • Message 32 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-08-12, 18:59 PM

Works fine for me :)

Reply
Options

11 Posts

05-25-2011

USA

70 Signins

237 Page Views

  • Posts: 11
  • Registered: ‎05-25-2011
  • Location: USA
  • Views: 237
  • Message 33 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-08-12, 23:30 PM

The new drivers have also worked for me.  Make sure that reducing refresh to 50 Hz is also disabled in the thinkvantage power manager.

Reply
Options

24 Posts

05-20-2011

USA

150 Signins

533 Page Views

  • Posts: 24
  • Registered: ‎05-20-2011
  • Location: USA
  • Views: 533
  • Message 34 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-08-13, 3:35 AM

I did. I'm going to play around more and see if it's a setting in the driver.

 

For now, I just did the registry edit fix.

Reply
Options

24 Posts

05-20-2011

USA

150 Signins

533 Page Views

  • Posts: 24
  • Registered: ‎05-20-2011
  • Location: USA
  • Views: 533
  • Message 35 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-08-16, 16:57 PM

I figured it out. In the intel settings, the power setting on battery must be set to "Maximum Performance" to not have the auto refresh rate change.

 

Other than the refresh rate, does anyone know what things the power setting changes?

Reply
Options

1 Posts

08-25-2011

Sao Paulo

3 Signins

14 Page Views

  • Posts: 1
  • Registered: ‎08-25-2011
  • Location: Sao Paulo
  • Views: 14
  • Message 36 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-08-25, 0:30 AM

I don´t know why everybody is saying the issue has been fixed, because clearly the issue has not been fixed.

Power Manager is set to Maximum performance

Intel graphics manager is set to maximum performance on both battery and plugged modes

even on windoes power sources i manually changed all settings within the profiles to maximum performance

the driver update is also installed

however the problem remains. The only thing that changed now is that

Plugged - 60 hz

Unplugged - switch back to 50hz

Plug again - switches automatically back to 60hz (this is new).

 

Overall I am quite disappointed with the x220 display. It sucks that I even had to find out about this problem because no display should show vertical lines because of hz rate at 50 hz. What a pity...

Reply
Options

5523 Posts

04-25-2008

United States of America

39861 Signins

763813 Page Views

  • Posts: 5523
  • Registered: ‎04-25-2008
  • Location: United States of America
  • Views: 763813
  • Message 37 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-08-25, 13:49 PM

Hi pbagin, and welcome to the Lenovo User Community!

 

I think you have two issues there. 50Hz on battery, and vertical lines.

 

Have you tried setting the refresh rate to 60Hz when on battery? Does it subsequently stay at 60Hz on battery? It should if the updated drivers are installed.

 

You are the first to report vertical lines. I suggest starting a separate thread regarding that question.

USB-C: Just cos it fits don't mean it works.
I don't work for Lenovo. I'm a crazy volunteer!
Reply
Options

84 Posts

04-12-2011

United Arab Emirates

1097 Signins

1711 Page Views

  • Posts: 84
  • Registered: ‎04-12-2011
  • Location: United Arab Emirates
  • Views: 1711
  • Message 38 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-09-06, 19:58 PM

Have tried this suggested fix but it keeps switching back and forth 60-50hz is there any permanent fix available yet.

Reply
Options

5884 Posts

11-24-2007

United States of America

12810 Signins

291275 Page Views

  • Posts: 5884
  • Registered: ‎11-24-2007
  • Location: United States of America
  • Views: 291275
  • Message 39 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-09-06, 20:03 PM

wrote:

Have tried this suggested fix but it keeps switching back and forth 60-50hz is there any permanent fix available yet.


as suggested here, disabling the igfxpers.exe process is permanent.   the only drawback is that you lose any color/gamma/saturation tweaks set in the intel control panel.   however, setting your windows color profile to sRGB and not using the lenovo monitor INF file typically results in excellent color overall.

ThinkStation P700      ThinkPad X1C7

Reply
Options

32 Posts

06-03-2011

UK

269 Signins

668 Page Views

  • Posts: 32
  • Registered: ‎06-03-2011
  • Location: UK
  • Views: 668
  • Message 40 of 55

Re: X220 uncontrollably switches to 50Hz refresh rate upon unplug from power source

2011-09-26, 12:54 PM

Hi have been using the initial fix (editing the intel driver) and that has been working fine. But since installing the updated driver 8.15.10.2418 (now linked in the solution, not editing the drivers) the display keeps switching back to 50Hz on battery again. "Lower Display Refresh Rate" in the Lenovo Power Manager is set to Never for both battery and AC settings of the profile I am using (Power Source Optimized). I have also tried to set the power plan on the Intel Graphics control panel to Maximum Performance for both Plugged in and On Battery, but it's still the same. Display Power Saving Technology for On Battery has also been turned off.

 

Any ideas on what else could be wrong? I guess I could just edit the drivers again...

 

Best Regards,

Gundy 

X220 4286 CTO, i7-2620M, 8GB RAM (2x4), 320GB HDD+Intel mSATA 80 GB, IPS display, BT 3.0, Intel 6205 WiFi, Finger Print Reader, Win7 Pro 64
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms