English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

58 Posts

10-29-2009

US

65 Signins

401 Page Views

  • Posts: 58
  • Registered: ‎10-29-2009
  • Location: US
  • Views: 401
  • Message 1 of 10

X230 intermitent audio problems

2012-10-05, 15:15 PM

Hello everyone,

 

I have a new X230. I have had it for about a month and a half, and for the most part I am happy with it. However, there is a little problem that's bothering me: often, I lose all sound when I go from power to sleep and back on, sometimes from ac power to battery. Each time this occurs, I have to disable the realtek sound card and reenable it, and the problem is fixed. I have the latest drivers installed and all. Any suggestions? I am not a fan of calling tech support, so I thouht I would ask here first. Any help is welcome. Cheers. 

 

Robert

Solved! See the solution
X230
x200
T410
X240
TP Tablet 2

Reply
Options

661 Posts

09-10-2012

DC Metro area

907 Signins

14979 Page Views

  • Posts: 661
  • Registered: ‎09-10-2012
  • Location: DC Metro area
  • Views: 14979
  • Message 2 of 10

Re: X230 intermitent audio problems

2012-10-05, 15:25 PM

Whenever I'm faced with an intermittent problem that seems to be resolved with a deactivation and reactivation of a device, I try to narrow down the field of culprits.

 

Did you change any settings or install/remove any software prior to the problem?

Did you uninstall, reboot, then reinstall any software that might be an issue? Here it could be the audio drivers or the power management software.

 

Reply
Options

58 Posts

10-29-2009

US

65 Signins

401 Page Views

  • Posts: 58
  • Registered: ‎10-29-2009
  • Location: US
  • Views: 401
  • Message 3 of 10

Re: X230 intermitent audio problems

2012-10-05, 19:21 PM

Thank you for your reply. I am pretty sure that it's related to either the sound card, the sound driver, or the dolby software (I read in another forum that other X230 owners have had problems with the dolby audio controls). I don't want to uninstall the dolby software, because the sound is nicer, but I get frustrated when, all of a sudden, there is no sound. 

X230
x200
T410
X240
TP Tablet 2

Reply
Options

1 Posts

10-09-2012

San Diego

1 Signins

7 Page Views

  • Posts: 1
  • Registered: ‎10-09-2012
  • Location: San Diego
  • Views: 7
  • Message 4 of 10

Re: X230 intermitent audio problems

2012-10-09, 20:23 PM

We've recently been battling a similar symptom (on x230 Laptop, x230 Tablets, T430 Laptops using an internal W7x64 Image build not the OEM).  The Audio service would not start consistently.  It shows in the task bar with a red slash through it, then you click on it and a wizard runs to repair it.  When the wizard completes the service is started and it works normally.  However, upon reboot it doesn’t work again.  The system event log shows Event ID: 7009, 7000, and 7001 at startup.  We narrowed the problem to the RapidBoot Shield v1.23, we uninstalled it and after a reboot everything returned to normal.

 

Here is Lenovos response:  "Rapid boot is not needed.  The following link outlines changes that Rapid Boot makes to decrease boot time.  http://support.lenovo.com/en_US/downloads/detail.page?DocID=HT051827

Our level 2 states that they are not aware of any known issues with it at this point."

 

Please post any new information regarding this issue, did you resolve it a different way?  Thank you.

Reply
Options

3 Posts

08-27-2013

13 Signins

80 Page Views

  • Posts: 3
  • Registered: ‎08-27-2013
  • Location:
  • Views: 80
  • Message 5 of 10

Re: X230 intermitent audio problems

2013-08-27, 22:59 PM

What version of Windows are you running?  I just rolled out over 200 x230t's at my job and after a week I've had about 6 calls of intermittent audio issues.  I was running Realtek Audio driver version 6.0.1.6914 for Win7 64 bit. 

 

The laptop would randomly cut out audio and I would also be unable to use the built-in Mic.

 

I tried swapping out the hard disk on an exact model x230t to rule out hardware issues and I still had trouble.  (Could still be possible a hardware problem - but I was unable to replicate it on the other hard disk)I've uninstalled the Dolby software with no affect. I also tried installing the newest driver from the Realtek website to no avail.

 

So far, uninstalling the Realtek driver and using the Microsoft driver pushed out via Windows was the only thing that seemed to have prevented this from happening.  I called into Lenovo and opened a case with them but I was unable to get any kind of actual response.

Reply
Options

3 Posts

08-27-2013

13 Signins

80 Page Views

  • Posts: 3
  • Registered: ‎08-27-2013
  • Location:
  • Views: 80
  • Message 6 of 10

Re: X230 intermitent audio problems

2013-08-28, 14:28 PM

Just an update...  The image on these laptops is fairly bare... Windows 7 64 bit Professional with Office Pro Plus 2013 (32 bit), SEP 11, Bradford NAC, Adobe Reader 11, MS Touch Pack, and VMWare Horizon View Client.  Drivers are up to date via Lenovo System Update tool, and Windows updates are up to date.

 

After some further testing I've found that using the Realtek driver version R 2.68 or earlier will work fine.  Anything above R 2.68 provides intermittent audio/mic.  If I boot the computer up and just let it sit there it will go in and out.  I don't need to do anything on the laptop in order the replicate the issue.

Reply
Options

3 Posts

08-27-2013

13 Signins

80 Page Views

  • Posts: 3
  • Registered: ‎08-27-2013
  • Location:
  • Views: 80
  • Message 7 of 10

Re: X230 intermitent audio problems

2013-09-03, 21:11 PM
Sorry for the delayed update but I spoke too soon. After further testing, on Friday I realized the older Realtek driver was still causing the problem. Only removing any Realtek drivers prevents the error.

0 person found this solution to be helpful.

This helped me too

Reply
Options

1 Posts

01-01-2016

United Kingdom

1 Signins

7 Page Views

  • Posts: 1
  • Registered: ‎01-01-2016
  • Location: United Kingdom
  • Views: 7
  • Message 8 of 10

Re: X230 intermitent audio problems

2016-01-01, 8:13 AM

I think I found the solution to the problem, well my problem at the least. The maximum battery life feature provided in lenovo's power saving software was the cause of my problem. If I turn on the feature unless I restart the laptop next time, there was no audio and gave me an error saying your audio device is being used in sound settings in control panel. When I'm in performance or power optimised mode I had no problems at all.

Hope this will be helpful.

Nice

x230

Reply
Options

3 Posts

01-06-2016

United States

6 Signins

43 Page Views

  • Posts: 3
  • Registered: ‎01-06-2016
  • Location: United States
  • Views: 43
  • Message 9 of 10

Re: X230 intermitent audio problems

2016-01-06, 1:10 AM

My X230 audio output was working fine on Window 10 for more than 1 month until today. The audio icon has a red x and despite the system showing it is fix, there is still no sound and the red x remain. Troubleshooting indicate there is no audio output devise installed and despite,  installing the latest Realtek High Defination audio Driver from Lenovo website, it still does not fix the problem. I contacted Microsoft tech support and they also tried to fix the problem by installing the latest Realtek audio driver and updates but without any success after more than half an hour.  They suspect the driver and setting may not be compatible and ask me to contact Lenovo. Need help.

Reply
Options

27 Posts

07-13-2016

UK

27 Signins

216 Page Views

  • Posts: 27
  • Registered: ‎07-13-2016
  • Location: UK
  • Views: 216
  • Message 10 of 10

Re: X230 intermitent audio problems

2019-08-04, 16:51 PM

I am getting the exact same profile. Do you know which setting of the Maximise Battery Life hpower profile causes the issue?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete