cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
BigMikeX270
Fanfold Paper
Posts: 4
Registered: ‎04-20-2017
Location: US
Views: 8,230
Message 1 of 25

X270 Bios Update v1.11 Broke my M.2 SSD (WWAN slot) HardDrive

Gurus,

 

Here is what I know so far, could use some help understanding if I'm using a hard drive that is no longer supported (brand new laptop and hdd)

 

I have an X270 with PCIe SSD

I added an M.2 SSD in the WWAN slot (confirmed with Lenovo support and parts department that this was supported for my configuration)

 

This worked great in BIOS version 1.10, I had it setup with the M.2 SSD as my boot drive with Win10, and the secondary (stock) SSD as my Data/Storage drive.

 

The other day I applied BIOS update version 1.11 for the X270.  The BIOS was applied successfully, and after restart, I get an error:

"2102 Detection Error on storage device (M.2 SATA SSD)"   and won't boot into Windows (that's by boot drive)

 

I was able to roll back to BIOS 1.10 and it again recognizes the M.2 SSD drive

I applied the latest BIOS version 1.12, and I get the 2102 Detection Error.  Same with v1.11

 

 

Is it possible that BIOS 1.11 removes my ability to use M.2 WWAN Slot drives, or just certain ones?

It seems like I can't upgrade my BIOS anymore, on a brand new laptop...

 

 

Thanks,

Mike

veriton
Token Ring
Posts: 164
Registered: ‎06-23-2011
Location: GB
Views: 8,131
Message 2 of 25

Re: X270 Bios Update v1.11 Broke my M.2 SSD (WWAN slot) HardDrive

I suggest you post the make and model of the M.2 SSD too.

 

It would be most interesting to hear whether anyone has had any SSD running in that WWAN slow with the newer BIOS versions.

_____
X1C5 May 17 | i7-7600U 16G 1TB LTE W10-1709 | USB3 dock + two 1080p displays, 25% on road
X220: i7, 16GB, m500 960GB, F5521gw
BigMikeX270
Fanfold Paper
Posts: 4
Registered: ‎04-20-2017
Location: US
Views: 8,105
Message 3 of 25

Re: X270 Bios Update v1.11 Broke my M.2 SSD (WWAN slot) HardDrive

The M.2 SSD I added was this one:

 

Transcend 256GB SATA III 6Gb/s MTS400 42 mm M.2 SSD Solid State Drive (TS256GMTS400)

http://amzn.to/2nvm9H3

 

It installed with no issues and was recognized on first boot under v1.10 of the Bios/Uefi.

 

 

Do any of these version updates sound like they would break m2 ssd functionality in the WWAN slot?

https://download.lenovo.com/pccbbs/mobiles/r0iuj05ww.txt

 

 

CHANGES IN THIS RELEASE
 Version 1.11
 
[Important updates]
- Fix TypeC docking detection.


[New functions or enhancements]
- (New) Updated LnvVpd.exe
- (New) Core Merge (v4.0.1.312) to trunk directory (SCT).
- (New) Updated Skylake D0/K1 MCU to MC0406E3_000000B1_000000B2.
- (New) Disabled ASPM and Aic support for Alpine Ridge.
- (New) disable all notification by PPM_RESET.
- (New) add 3 port solution. 
- (New) add TBT dock workaround.
- (New) remove useless Charger IC setting to avoid conflict.

[Problem fixes]
- (Fix) Fix system hang after Legacy PXE fail exit with Realtek USB LAN and USB key.
- (Fix) Fix boot delay with ME Lock.
- (Fix) Fix unexpected parameter is set by OPTION_LENOVO_SUPPORT_PS2MOUSE_PARAMOVERRIDE and typo
- (Fix) Fix a problem that brightness control did not work on Win7 with WQHD panel.
- (Fix) Fixed S4 hang issue w/ Win32.

 

HawkeyeQ
Punch Card
Posts: 30
Registered: ‎12-21-2013
Location: GB
Views: 8,025
Message 4 of 25

Re: X270 Bios Update v1.11 Broke my M.2 SSD (WWAN slot) HardDrive

Hello.
I wanted you to know that I'm facing almost the same problem.

The difference in my case is that I have a Samsung 960 NVMe as my boot drive and an ADATA SP600 M.2 in the WWAN slot as a secondary drive. I also tried with the Transcend MTS400.
Same drive detection error message with latest BIOS version (1.12).

I had to remove the ADATA drive for my laptop to work.


HawkeyeQ
Vir sapit qui pauca loquitur...

----------------------------
Community SeniorMod
Community SeniorMod
Posts: 12,004
Registered: ‎06-06-2011
Location: RU
Views: 8,002
Message 5 of 25

Re: X270 Bios Update v1.11 Broke my M.2 SSD (WWAN slot) HardDrive

Hello everyone

Issue might be caused by outdated SSD firmware. At least Transcend drive in the 1st post mentioned (MTS400) had the same issue in older ThinkPads.

So, install Transcend application SSD Scope on the laptop/with BIOS with SSD recognized and perform firmware upgrade.

Details and download:
https://www.transcend-info.com/Support/Software-10/



x220 • Gobi 2000 3g | hdd, msata ssd, wwan, wifi, gps -- unique hand-made config
ThinkPad 25 Special Anniversary Edition. #retro. Signed by D.Hill
T470p | X1 Carbon Gen3 | Miix 2 10" | Yoga Tablet 2-1050F (Android) + BT Keyboard
ThinkPad Stack • 2.4/5 Wireless Router, HDD 1 TB, BT Speaker, Power Bank, Mobile Projector

Do it well, worse becomes itself

Communities:   English    Deutsche    Español    Portugues    Русскоязычное    Česká    Slovenská    Українська   Moto English

HawkeyeQ
Punch Card
Posts: 30
Registered: ‎12-21-2013
Location: GB
Views: 7,998
Message 6 of 25

Re: X270 Bios Update v1.11 Broke my M.2 SSD (WWAN slot) HardDrive

Hello.

 

Both the drives I tried have the latest firmware (I checked using SSD Scope for Transcend and SSD Toolbox for ADATA on a ThinkPad T450).


HawkeyeQ
Vir sapit qui pauca loquitur...

----------------------------
thinkpadboi
Paper Tape
Posts: 5
Registered: ‎05-21-2017
Location: US
Views: 7,802
Message 7 of 25

Re: X270 Bios Update v1.11 Broke my M.2 SSD (WWAN slot) HardDrive

Just wanted to chime in and say that I'm running BIOS 1.13 and booting off an m.2 SSD in the WWAN card slot with no problems right now (edit: this worked on every BIOS I tried from 1.09 - 1.13.)  It's a 256GB ADATA SP600NS34.  I bought the SATA x270 and added the SSD, so I only have one SSD in my system, no NVMe.  Possibly related?

BigMikeX270
Fanfold Paper
Posts: 4
Registered: ‎04-20-2017
Location: US
Views: 7,793
Message 8 of 25

Re: X270 Bios Update v1.11 Broke my M.2 SSD (WWAN slot) HardDrive

Same as Hawkeye.  Transcend Scope SSD says my drive has the latest firmware, no update available.

 

Is there something specific about that drive or bios that I can reference if I contact Transcend for support?

 

Though it seems to me if the drive works fine with Bios 1.10, and no longer works in 1.11 and 1.12, then something in the BIOS killed it.

 

I haven't tried Bios 1.13 yet, but the release notes don't really indicate a potential issue with SSDs has been solved.  Anyone disagree?

 

CHANGES IN THIS RELEASE
 Version 1.13
 
[Important updates]
  Nothing.

[New functions or enhancements]
- Update UEFI Diag 03.10.001.

[Problem fixes]
- Fixed UEFI PXE booting issue.

n

HawkeyeQ
Punch Card
Posts: 30
Registered: ‎12-21-2013
Location: GB
Views: 7,715
Message 9 of 25

Re: X270 Bios Update v1.11 Broke my M.2 SSD (WWAN slot) HardDrive

Hello.

  I might have some good news.

  A new BIOS version has been released and in the important updates list I see:

[Important updates]
- Fix PL1/PL2 in KBL SKU incorrect.
- Fix M.2 SATA SSD can't be detected in NVMe SKU.

  I will update the BIOS and try the M.2 again.

  Once I'm done I will come back with the outcome of the process.


HawkeyeQ
Vir sapit qui pauca loquitur...

----------------------------
HawkeyeQ
Punch Card
Posts: 30
Registered: ‎12-21-2013
Location: GB
Views: 7,687
Message 10 of 25

Re: X270 Bios Update v1.11 Broke my M.2 SSD (WWAN slot) HardDrive

Good news guys!

 

I updated the BIOS to version 1.14, put my M.2 back into the X270 and it worked fine again.


HawkeyeQ
Vir sapit qui pauca loquitur...

----------------------------

Check out current deals!


Shop current deals

Top Kudoed Authors