cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PierU
Fanfold Paper
Posts: 8
Registered: ‎05-22-2018
Location: FR
Views: 82
Message 1 of 2

X301 near-bricked :(

Hi,

 

I recently grabed a X301 which was working fine. However, I learned that the SSD (a 1.8" 128GB from Samsung) was not supporting the TRIM : I first tried to update the SSD firmware with a version that supports the TRIM, by using the Samsung tool for that (that is Maindiag.exe, from a bootable USB drive with FreeDos), but without success. Then I decided to erase completely the SSD, still with Maindiag.exe, in order to restart with a fresh SSD that I could partition to 100GB, leaving 28GB for the overprovisioning (which is apparently a good thing to do if no TRIM can be used).

 

The erase with Maindiag apparently went OK, although it was surprinsingly fast (2 seconds to erase 128GB...?). But then things have gone ugly...

 

- When I power on the X301, the LEDs are blinking and the CD drive is operating during a few seconds, as usual
- Nothing more happens during about 10 minutes (!), and the screen remains blank
- After 10mn some text if briefly displayed (2 seconds before it goes). I could take a photo and I can read :
"tpm tpm0: A TPM error (28) occurred continue selftest"
"tpm tpm0: TPM self test failed"

http://prntscr.com/mb9iro

 

During all this sequence there's no opportunity at all to enter the BIOS... The usual startup screen with "To interrupt [the normal sequence ? don't remember exactly] press the ThinkVantage blue button" never shows up.

 

After that it depends on the presence of a bootable USB drive :

- without any bootable USB drive, I end up with a screen telling me that no operating system has been found, which confirms that the SSD has undergone some erasement... https://prnt.sc/mbf0zp

- With a Linux (Ubuntu) live USB drive, the X301 normally boots on it. However, the internal SSD is not visible at all, and if I try installing Ubuntu the SSD does not appear in the list of available drives.

- With the FreeDos USB drive, the X301 also normally boots on it. And Maindiag detects the SSD.

I don't know what happened to the SSD, maybe I've bricked it, but actually I don't really mind... What really worries me is what happened to the X301, and is it recoverable ?

 

Note that the X301 behaves the same (10mn before booting on a USB drive, no access to BIOS) even if I unplug the SSD.

 

Any help would be highly appreciated !

PierU
Fanfold Paper
Posts: 8
Registered: ‎05-22-2018
Location: FR
Views: 32
Message 2 of 2

Re: X301 near-bricked :(

I "solved" the problem by reverting to an old BIOS version (1.08)...

Check out current deals!


Shop current deals

Top Kudoed Authors