Showing results for 
Search instead for 
Do you mean 
Paper Tape
Posts: 1
Registered: ‎02-11-2011
Location: Denmark
Message 1 of 4 (4,168 Views)

X301 with newly mounted 256 GB Lenovo SSD Windows 7 install format partition error 0x80070057

The X301 have already been updated with the newes BIOS 3.14. Type 2774-LEG.

Complete error message when attempting install of Windows 7:

Windows could not format a partition on disk 0. The error occurred while

Preparing the partition selected for installation. Error code: 0x80070057


Latest SSD firmware upgrade (fwss22.iso) didn't find anything to upgrade.


SSD recognized as Toshiba THNSFC256GAMJ-(S1).


AHCI as well as Compatibility mode tried. Same error.


I had the same error using a Kingston 256GB SSD. Kingston accepted a return of the SSD due to incompatibility with the X301. Their recommendation was to use the Lenovo 256GB SSD for the X301 instead. As I now have the same error paying more money for it, I'm somewhat disappointed.


It would seem the X301 or my particular specimen have an undocumented and unsearchable error using 256GB SSD's.



Any help solving this is greatly appreaciated.



Lenovo Employee
Posts: 62
Registered: ‎06-01-2009
Location: Germany
Message 2 of 4 (4,094 Views)

Re: X301 with newly mounted 256 GB Lenovo SSD Windows 7 install format partition error 0x80070057



sorry to say this, but the 256GB SSD from Lenovo is not compatible with the X301. It just won't work.


Nothing else I can say.


Return it to Lenovo.


Sorry to be so blunt



Thinkpad T410s -- 8GB of RAM -- 128GB SSD as boot drive -- 500GB Seagate Hybrid HDD with 4GB of SSD Memory as data drive
Fanfold Paper
Posts: 16
Registered: ‎11-29-2008
Location: Australia
Message 3 of 4 (3,972 Views)

Re: X301 with newly mounted 256 GB Lenovo SSD Windows 7 install format partition error 0x80070057

[ Edited ]

I had the same experience with X301 (2776) with latest 3.14 BIOS with both the Toshiba 256GB SSD and the Samsung 256GB SSD, both supplied by Lenovo. Even though Lenovo says these parts are compatible with the X301, and even lists it in the maintenance manual as a compatible part, I could get neither of them to work. AHCI or IDE/Compatible mode makes no difference. The symptoms are reads and read tests work fine, but writes will create somewhat random corruption. Same problems with Window 7 or several versions of Linux I tried.


With IDE mode and Windows you'l experience slow performance and occasionably 60 second 'pauses' where all disactivity freezes. With ACHI you won't see the pauses, but the disk content will gradually get more and more corrupted.


With Linux and IDE you'll the IDE connection 'hard reset' regularly to slower IDE rates until the file system eventually gets remounted read-only. With Linux and AHCI you'll see lots of lost/missed interrupts. Both way you'll see disk corruption.


There are encrypted drives, but setting or not setting a BIOS/Disk password makes no difference.


I tried contacting Lenovo support but they wouldn't offer any support for the drives, said I had to talk to 'sales', like they could help :-)


Seems the SSD controllers in these drives is not compatible with X301 motherboard and/or BIOS. This whole experience makes me very unhappy with Lenovo - they still list these drives as compatible with all X301 models, and I paid extra to buy it from them to ensure exactly this sort of problem wouldn't happen. Going to have to think hard before I buy another.

What's DOS?
Posts: 1
Registered: ‎07-02-2011
Location: Switzerland
Message 4 of 4 (3,471 Views)

Betreff: X301 with newly mounted 256 GB Lenovo SSD Windows 7 install format partition error 0x800700

Hi All,


I've bought a Lenovo 43N3417 256GB FDE SSD SATA 3Gb/s 1.8" and tried to install Windows 7 from scratch. However it didn't work. My vendor sent the hardisk back to Lenovo and after 6 Weeks I've got a new SSD.

I had still the same problem, but after several trials I managed to install a "Backup Windows 7". This worked quite well for about 3 weeks until Windows started to have a lot of bluescreens error and some Programms did not work anymore.


So yesterday I brought this SSD back to my Vendor, which sent it to Lenovo again.


What is Lenovo doing to solve this kind of problem? Which "big" SSD are suitable for an X301?


My System is a X301 with bios 3.14 and a 64GB Lenovo SSD.


Best regards



Top kudoed Authors