Showing results for 
Search instead for 
Do you mean 

X61 - Can't get sysprep'ed image to boot on it.

by Retired SuperMod on ‎03-30-2011 12:14 PM - edited on ‎03-30-2011 01:46 PM by (1,665 Views)


I was sent a brand new X61 to configure for another employee at our company.

The X61 originally came with Vista preloaded but I slapped XP SP2 on it using the enclosed bootable Rescue CD and six XP recovery CDs.

Since we already use a single working corporate image for the 6 different non-Lenovo hardware platforms we currently use, I want to deploy the same image to this user.

I was the person that created the image from scratch and I see no problem with it actually working on the X61.

To create an image for the laptop, one of our fastest desktops was imaged with our corporate master image and brought up normally as if the PC was being readied for deployment.
Once everything had completed, the HD in the desktop had the proper Lenovo x61 drivers added to it and the SATA drivers added to the sysprep.inf file as well.
After that it was sysprepped, shutdown and left lying in its original desktop ready to be cloned over to the drive in the X61 where it would be booted up for the first time after sysprep, in the X61.

So I would still be able to keep the preload on the x61's original hard drive, I used a SATA laptop hard drive from one of our current non-Lenovo systems for the image transfer to the x61.

When I clone the sysprepped image from the desktop hard drive over to the laptop hard drive, it refuses to boot in the IBM.
It just sits at the screen with a blinking cursor doing nothing.

Troubleshooting so far
I have put the corporate image on the x61's original hard drive [with the XP preload] by just replacing the original data partition and leaving the recovery partition alone = blinking cursor.

I have cloned the whole source drive over to the Lenovo preload HD, removing the recovery partition completely = blinking cursor.

I have installed XP from the original CD using a USB-floppy drive and the F6 key to add the SATA driver during startup.
Once completely installed, I figured that it had a valid boot sector and I Ghosted over the sysprepped image without the IB switch and I still get the blinking cursor.

I have researched on the Internet using Google and have found a couple of links that seem to indicate what the problem might be and have listed them below

Predesktop Authentication
This has nothing to do with the issue at hand as this option lies in the BIOS under Security,FingerPrint.
Its BIOS description also states that this option decides whether fingerprint access is required to boot the laptop and this option has been in the disabled state even while the laptop was booting the Factory Preload.

SATA set to Compatibility instead of AHCI
This setting only affects how the OS sees the HD, not how the laptop sees it and I tried it anyway and it has no effect.
If your XP image isnt properly sysprepped to handle the SATA drive using the proper driver, you will need to set it to Compatibility mode to get into Windows.
As it stands, this is not an issue as I have edited the sysprep.inf to add the SATA driver reference for this laptop and if it ever boots the image, I expect it to never BSOD but thats if it ever boots which it hasnt so far.

Ghosting using the IB switch
I was SO sure that this would fix the issue but I get the same blinking cursor.
Booting into DOS and using Ghost 8.3, I ran "ghost -ib" and selected the sysprepped desktop drive as the source and the laptop drive as the destination and it still leaves me at the blinking cursor when I try it in the laptop.

Re-creating the MBR
I have done this two different ways, one using Norton GDISK and one using a regular Windows 98 bootdisk.
The Windows 98 bootdisk kept saying "No fixed disks present" so it never worked.
Nortons GDISK didnt have any issues re-creating the MBR on the laptop or on the laptop HD plugged in the desktop but the drive still doesnt boot.

Signature failure error
I have heard about people having the same issue as me and getting this error but so far I have not received this error.


Here is the solution and the explanation, hopefully, I dont miss anything because I would like this all in one place so it can be referenced in the future.


The Lenovo's use a recovery partition and the boot table that references it appears to be based on some form of Linux as also is the recovery partition itself.


As far as I know, all flavors of Linux use 8,192 bytes for a boot table [4 sectors of 2048 bytes each] whereas a standard boot table is only 1 sector and 2048 bytes long.


This is the reason for the problem that happens with OEM laptops like this one.


What you need to do to get the image to boot is the following [BSODs after booting is another issue]



  • Create the image to a ghost file on whatever platform you want but use the IB switch in Ghost to create the image with the boot table intact.
  • Deploy the image to the Lenovo laptop hard drive ALSO using the IB switch
  • When doing ANY image deployment to the laptop, the hard drive MUST be IN the laptop itself. The laptop writes its boot sector differently so the hard drive must be in it for the image to work. I was doing everything right but this step and I was still having the issue so this is crucial.
  • If you are testing the image by deploying straight from the test PC to the laptop by using the Ghost Peer-2-Peer TCP/IP option, start Ghost on both ends with the IB switch but remember the destination SATA drive MUST be in the laptop itself.

Was this information helpful?