Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

2 Posts

07-12-2009

Cambridge, MA

2 Signins

10 Page Views

  • Posts: 2
  • Registered: ‎07-12-2009
  • Location: Cambridge, MA
  • Views: 10
  • Message 1 of 2

X61 Vista32: Cannot install driver for Intel Wifi 4965AGN (unable to open registry key)

2009-07-12, 17:56 PM

Hi,

 

I have an X61 with Vista Business 32bits and the Wireless card (Intel Wifi 4965AGN) does not work anymore. Here is the chronology of events:

 

- A few days ago I realized that the Fn+F5 hot key was not working.

- I tried to solve this problem by uninstalling the Intel wifi driver and reinstalling.

- Uninstall was OK. When I restarted the computer, the system automatically detected the Wifi card as new hardware and tried to install the driver, but I got an error message "Unable to open the driver specific registry key for this device".

- I have tried to uninstall and install the driver several times but I have been unable to fix the problem.

- I have downloaded the latest driver from the Intel and Lenovo websites but the problem persists.

- When I access the device manager there is an exclamation point on the Wifi4965AGN. If i try to update driver it returns a message saying thatthe driver is up to date.

- I have tried to recover the system from the last backup point but when the system restarts it says that there was an undetermined error in the recovery and that it didn't happen.

 

It seems like there is something wrong in my Windows registry but I don't know enough to solve it. It doesn't seem like a big problem because I actually created it by trying to fix the Fn+F5 problem so I should be able to solve it!

 

Any ideas before I reinstall Windows? 

Reply
Options

263 Posts

07-08-2009

Atlanta, GA

116 Signins

3023 Page Views

  • Posts: 263
  • Registered: ‎07-08-2009
  • Location: Atlanta, GA
  • Views: 3023
  • Message 2 of 2

Re: X61 Vista32: Cannot install driver for Intel Wifi 4965AGN (unable to open registry key)

2009-07-14, 18:35 PM

You may want to check the following again just to be sure everything was done

 

1) Make sure the correct driver for Intel Wifi 4965 AGN is installed (Do you have XP or Vista?)

2) Use System Restore (Start -> All Programs -> Accessories -> Systems Tools -> System Restore) to rollback your settings to an earlier calendar date prior to the  time the issue has occurred.

 

Were you trying to restore using Microsoft's System Restore, or using the Rescue and Recovery tool?

 

If this fails, you may need to reload Windows.

Power off, then power on and tap F11 repeately to access Rescue and Recovery from our recovery partition. 

 

Hope this helps,

 

Mark

 

 

 

Do NOT PM me with technical issues. Post in the forum for assistance. Thanks
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms