Support in other languages: 
Showing results for 
Search instead for 
Do you mean 

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team

Community Spotlight

Visit the Community Blog

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Blue Screen Again
Posts: 86
Registered: ‎06-04-2010
Location: Diamond Bar, CA
0 Kudos

clean install question

i got a new hard drive and decided to do a clean install but because of the problem that i described i just decided to do a factory restore on the new hard drive and call it a day.

 

the problem was that after installing the latest video drivers and hotkey drivers, whenever i raise or lower the brightness, it would skip 2-3 increments. so for example, it would start from 2 and skip to 4 and then 7 and then 9. does anyone know why this problem happened? i don't have the clean install anymore but i am still curious as to what the problem could have been. after the clean install there were no problems in device manager and all drivers are the latest that i downloaded from the lenovo website. the laptop is an x201 with windows 7 home premium.

 

please help.

Highlighted
Serial Port
Posts: 19
Registered: ‎09-12-2009
Location: Cairo, Egypt
0 Kudos

Re: clean install question

[ Edited ]

I have an X201 (3680-g78), and using the latest drivers, I have the same problem. I noticed that if I uninstall the Intel drivers (using the standard vga drivers instead), the brightness control works fine.

 

Edit: Lenovo just released new Intel video drivers (as of 9/9). They seem to have slipstreamed a reg fixed into the setup process. It works for me Smiley Happy

Blue Screen Again
Posts: 86
Registered: ‎06-04-2010
Location: Diamond Bar, CA
0 Kudos

Re: clean install question

[ Edited ]

so after using that driver you get the correct increments after clean install? man wish i can try it out but i already gave up on it. lol

 

edit: under the changelog for the newest drivers, it doesn't seem to list that problem as a "fix" but it still worked? do you experience any other problem with the new driver? also what's weird is that the original drivers from lenovo work if you are doing a factory restore so i don't know why it wouldn't work for clean install lol.

Serial Port
Posts: 19
Registered: ‎09-12-2009
Location: Cairo, Egypt
0 Kudos

Re: clean install question

Yes, I'm sure it worked, because one of the things it executes before the driver is a registry key file that has brightness in the filename. The version of the driver a few days ago broke the brightness control, but this driver definitely fixed it.

Blue Screen Again
Posts: 86
Registered: ‎06-04-2010
Location: Diamond Bar, CA
0 Kudos

Re: clean install question

thanks. any idea on why the previous driver had problem with brightness control only on a clean install but worked fine if it was upgrading the existing display drivers from a factory install?