Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Highlighted
Blue Screen Again
Posts: 1
Registered: ‎08-04-2011
Location: Germany
0 Kudos
Accepted Solution

x121e NO Network device installed!!

[ Edited ]

I bought the new x121e (model number: 30515QG), which here in Germany might be the same as x120 over there.
Installed Win7 x64 by USB HDD, worked fine except of all the Network drivers. The devices are not recognised. No matter if I use the Lenovo drivers or original manufacture drivers.

If I try to install the drivers I get following message:
"The Realtek Controller Network was not found
If Deep Sleep Mode is enabled. Please plug the Cable."

But the cable is plugged in, working (tested)! I noticed that the LEDs of the LAN port are both disabled. Could it be the onboard LAN is damaged?
Of course the bios has every Lan device enabled.

I tried every driver I could find, and finally managed to get Wireless to work with the driver 88_92ce_WindowsDriver_1005.24.0712.2011.zip
I have no wlan to test, but it finds the one of my neighbours.

But there are still 3 devices left marked with yellow!: ethernetcontroller, pci-device, unknown device.

The first one is supposed to be the LAN, but how to I get it to work?

Or should I return the Pad to my seller due to malfunction?

 

Thanks

Posts: 3,392
Topics: 26
Kudos: 421
Solutions: 259
Registered: ‎01-21-2010
Location: Etters, PA
0 Kudos

Re: x121e NO Network device installed!!

[ Edited ]

http://support.lenovo.com/en_US/detail.page?LegacyDocID=TVSU-UPDATE

 

Download and install Lenovo's System Update and let it find and install your drivers for you.

 

You will need to install Microsoft Net.Framework 1.1 at least.  Stay away from 4.0, there were issues.

 

Dave 

_______________________________________________________
T430u, x301, x200T, x61T, x61, x32, x41T, x40, U160, ThinkPad Tablet 1838-22R, Z500 touch, Yoga Tab 2 Windows 8.1, Yoga Tablet 3 Pro
Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
If someone helped you today, pay it forward. Help Someone Else!
English English Community   Deutsche Deutsche Community   Español Comunidad en Español   ru.gif Русскоязычное Сообщество