English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

1 Posts

01-21-2010

Canada

3 Signins

40 Page Views

  • Posts: 1
  • Registered: ‎01-21-2010
  • Location: Canada
  • Views: 40
  • Message 1 of 1

x200s w/ Intel 5300 - New driver leaves me wireless-less.

2010-01-21, 15:57 PM

Hi All,

I'm hoping this forum can be more helpful than the support line...

 

The pre-installed wifi driver on my x200s was giving me problems from the time it arrived.  After a day of wifi usage, Windows would slow to a crawl.  After some digging, I verified that the wifi driver was causing DPC latency issues.

 

I upgraded the wifi driver to the Lenovo v13 module and all ability to use the wifi card stopped.  I tried using the ThinkVantage tools to upgrade, I tried complete uninstall, re-installs using the downloaded driver from the Lenovo site.  Nothing worked.  I can see the device in device manager without error, however, fn+f5 doesn't show any wireless cards but the network center CAN see the wireless device and shows full green bars.

 

I could not downgrade my driver since I couldn't find it on the Lenovo site.

 

I did install the Intel generic driver for the 5300 and that was able to have me connected, but once again, I was left with one day of usage then a reboot.  Failing to reboot eventually leads to a BSOD.

 

I've called Lenovo support and the fellow there says, "The only reason their driver wouldn't work is if the hardware was broken."  Which I find a little hard to stomach since it does 'work' using a different driver.  He's asked me to reinstall my whole OS which seems unreasonable.  He then asked me to ship my laptop to them to replace the card... again, seems like a "last effort" scenario.  We compromised on having me bring it to a service center.

 

So, before I go to the hassle of replacing one wifi card with another; Has is anyone else having similar problems?  Does anyone else think it's a bit daft that a software driver issue must be fixed by installing new hardware?  It seems to me that the problem is in convincing Windows that the card is powered on...  I doubt a hardware swap will change anything.

 

Your thoughts?  Suggestions?

 

Details...

7465-CTO (x200s, 1.86GHz, 4GB, Intel 5300)

Vista Business 64-bit

wifi driver v13.0.0.107 (complete failure)

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete