Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

86 Posts

03-14-2011

Atlanta, GA

274 Signins

770 Page Views

  • Posts: 86
  • Registered: ‎03-14-2011
  • Location: Atlanta, GA
  • Views: 770
  • Message 1 of 93

x220 Brightness Keys Fail after Hibernate

2011-05-09, 3:15 AM

As seen on the x120e

 http://forums.lenovo.com/t5/X-Series-ThinkPad-Laptops/x120e-Funtion-keys-for-brightness-not-working/td-p/408377

 

Occasionally, brightness keys stop working when the x220 resumes from hibernate.  It seems to occur more often when the power source changes while hibernated.  IE - put into hibernate on AC power, resume on batery or vice versa.

 

Are other x220 owners experiencing this?

x220 | 4286-CTO | i5-2520M | 8Gb G.Skill | OCZ SSD
Win 7 Home Premium SP1 64bit
Reply
Options

116 Posts

04-06-2011

USA

708 Signins

1265 Page Views

  • Posts: 116
  • Registered: ‎04-06-2011
  • Location: USA
  • Views: 1265
  • Message 2 of 93

Re: x220 Brightness Keys Fail after Hibernate

2011-05-09, 3:31 AM

I've had this problem all the time with x120e but have not had it happen with X220. But I use sleep, not hibernate.

Reply
Options

9644 Posts

12-27-2009

Canada

3313 Signins

95283 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95283
  • Message 3 of 93

Re: x220 Brightness Keys Fail after Hibernate

2011-05-09, 3:41 AM
It looks like a general thing; it's been over on the T-series forum and W-series communities.

It has no immediately obvious cause; my T400 suffered from it rarely for a while. My X100e suffered from it 100% for a while until a reinstall, where it has never happened so far.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Options

86 Posts

03-14-2011

Atlanta, GA

274 Signins

770 Page Views

  • Posts: 86
  • Registered: ‎03-14-2011
  • Location: Atlanta, GA
  • Views: 770
  • Message 4 of 93

Re: x220 Brightness Keys Fail after Hibernate

2011-05-10, 3:49 AM
JameZ - this is happening about 50% of the time or more on my x220 when I bring it out of hibernate. I know when it happens because usually when it starts up it will show the brightness HUD bar with the current brightness setting. When the brightness function keys fail, that HUD does not show.
x220 | 4286-CTO | i5-2520M | 8Gb G.Skill | OCZ SSD
Win 7 Home Premium SP1 64bit
Reply
Options

86 Posts

03-14-2011

Atlanta, GA

274 Signins

770 Page Views

  • Posts: 86
  • Registered: ‎03-14-2011
  • Location: Atlanta, GA
  • Views: 770
  • Message 5 of 93

Re: x220 Brightness Keys Fail after Hibernate

2011-05-14, 13:41 PM

Looks like TPHKLOAD.exe is failing.  I have one of these in my event viewer that corresponds to every time I resume from Hibernate and the brightness keys do not work. 

 

Event 1000: Application Error

 

Faulting application name: TPHKLOAD.exe, version: 1.0.0.0, time stamp: 0x4cf84e8a
Faulting module name: ole32.dll, version: 6.1.7601.17514, time stamp: 0x4ce7c92c
Exception code: 0xc0000005
Fault offset: 0x0000000000029fa6
Faulting process id: 0x684
Faulting application start time: 0x01cc11133eabe0f3
Faulting application path: C:\Program Files\LENOVO\HOTKEY\TPHKLOAD.exe
Faulting module path: C:\Windows\system32\ole32.dll
Report Id: 75a891b8-7e2e-11e0-837c-f0def1592eb1

 

 

x220 | 4286-CTO | i5-2520M | 8Gb G.Skill | OCZ SSD
Win 7 Home Premium SP1 64bit
Reply
Options

575 Posts

03-20-2011

Canada

7411 Signins

12474 Page Views

  • Posts: 575
  • Registered: ‎03-20-2011
  • Location: Canada
  • Views: 12474
  • Message 6 of 93

Re: x220 Brightness Keys Fail after Hibernate

2011-05-14, 16:12 PM

 


wrote:
I know when it happens because usually when it starts up it will show the brightness HUD bar with the current brightness setting. When the brightness function keys fail, that HUD does not show.

Exactly the same I'm seeing on the X120e. Normally the brightness shows up when you open the lid. If it doesnt, the brightness keys wont work.

 

---------------------
| X220 i7-2620M | 12.5" HD IPS | Intel 180GB SSD | Crucial 480GB mSATA SSD | 8GB DDR3 | Intel 7260 AC |
| X260 i7-6600U | 12.5" FHD IPS | Samsung 860Pro 512GB SSD | 16GB DDR4 | Intel 8260 AC |
Reply
Options

56 Posts

05-12-2011

USA

68 Signins

402 Page Views

  • Posts: 56
  • Registered: ‎05-12-2011
  • Location: USA
  • Views: 402
  • Message 7 of 93

Re: x220 Brightness Keys Fail after Hibernate

2011-05-14, 20:05 PM

This is happening to me too.  Generally happens when im in SLEEP mode, put the laptop on my ultrabase, and take it out of sleep, after its already on the ultrabase.  

 

Very annoying, because i have to restart.  Does anyone know of a solution?

Reply
Options

56 Posts

05-12-2011

USA

68 Signins

402 Page Views

  • Posts: 56
  • Registered: ‎05-12-2011
  • Location: USA
  • Views: 402
  • Message 8 of 93

Re: x220 Brightness Keys Fail after Hibernate

2011-05-15, 20:26 PM

Everyone in the thread should try this, asap.  This solution was given to me by thinkpad priorty support.  If it works, give me "kudos" for the post :smileytongue:

 

1. Go to this page: Lenovo Support - Drivers and software - ThinkPad X220, X220 Tablet, X220i, X220i Tablet
2. Download: "Power Management Driver"
3. Download: "Hotkey utility"
4. Download: "Power Manager"
5. Uninstall, "Lenovo System Interface Driver"
6. Uninstall, "Thinkpad Power Management Driver"
7. Uninstall, "Thinkpad Power Manager"
8. Reboot. (Don't skip this reboot)
9. Install: "Power Management Driver"
10. Reboot (Don't skip this reboot)
11. Install: "Hotkey utility" (When you install this one, make sure you select the check boxes for all the options.)
12. Reboot: (Don't skip this reboot)
13. Install: "Power Manager"
14. Reboot: (Don't skip this reboot)
15. And finally, I rebooted again for good luck.

Reply
Options

56 Posts

05-12-2011

USA

68 Signins

402 Page Views

  • Posts: 56
  • Registered: ‎05-12-2011
  • Location: USA
  • Views: 402
  • Message 9 of 93

Re: x220 Brightness Keys Fail after Hibernate

2011-05-16, 1:42 AM

Thought I should report back that the problem is still happening... The directions above definitly reduced the amount of occurances, but it still does happen.

 

Man is this frustrating for a brand new machine like this!!!

Reply
Options

86 Posts

03-14-2011

Atlanta, GA

274 Signins

770 Page Views

  • Posts: 86
  • Registered: ‎03-14-2011
  • Location: Atlanta, GA
  • Views: 770
  • Message 10 of 93

Re: x220 Brightness Keys Fail after Hibernate

2011-05-22, 1:49 AM
I saw in the x120e thread that JameZ says there is a new driver in the testing phase. I don't know if this driver will apply to the x220 as well.
x220 | 4286-CTO | i5-2520M | 8Gb G.Skill | OCZ SSD
Win 7 Home Premium SP1 64bit
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms