cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
ggaudr
What's DOS?
Posts: 2
Registered: ‎12-23-2012
Location: canada
Views: 1,013
Message 1 of 4

x220 hardware radio switch

Hi,

 

So I have a Thinkpad x220, with Ubuntu 12.04 installed on it, and since this morning, the wireless does not work anymore. I often play with the wireless switch, so I figured this might be the problem, it might have gotten stuck or something, because now it seems like my wireless card isn't recognized anymore. The wireless light below the screen doesn't turn on anymore, and when I try to look at the status of my card, it seems like it's just not connected anymore. The command "iwlist" scanning just outputs that lo and eth0 doesn't support scanning (no mention of wlan0), "rfkill" doesn't output anything, and if I type in "ifconfig wlan0 up" then I just get an error saying that there is not such device, wlan0.

 

I also tried to boot up with a live version of Debian, and even then, the card is just not recognized.

 

Anyone has any idea how to fix this? Also maybe I could open it up and try to see if it is indeed disconnected and try to put it back myself? What do you think?

ishaan
Bit Torrent
Posts: 3,304
Registered: ‎06-27-2012
Location: India
Views: 986
Message 2 of 4

Re: x220 hardware radio switch

You can try check if really the wifi switch is stuck. I am not sure but opening your laptop may void your warranty.
Ishaan Ideapad Y560(i3 330m), Hp Elitebook 8460p!(i5-2520M) Hp Pavilion n208tx(i5-4200u)
If you think a post helped you, then you can give Kudos to the post by pressing the Star on the left of the post. If you think a post solved your problem, then mark it as a solution so that others having the same problem can refer to it.
ggaudr
What's DOS?
Posts: 2
Registered: ‎12-23-2012
Location: canada
Views: 926
Message 3 of 4

Re: x220 hardware radio switch

yes ill try to open it because it keeps on switching off, i, just scared it could ruin the warranty

SMG47
802.11n
Posts: 233
Registered: ‎12-18-2008
Location: Northern NJ
Views: 904
Message 4 of 4

Re: x220 hardware radio switch

Odds are the switch is broken.  Don't try to fix it yourself as it is attached to the motherboard.  Use your warrantee and have Lenovo fix it.  If the switch is broken they will replace the motherboard.

Check out current deals!


Shop current deals

Top Kudoed Authors