Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Tablet and Helix Laptops
All Forum Topics
Options

50 Posts

04-27-2013

USA

65 Signins

273 Page Views

  • Posts: 50
  • Registered: ‎04-27-2013
  • Location: USA
  • Views: 273
  • Message 1 of 7

Helix track pad driving me insane

2013-05-19, 1:28 AM

OK, I'm having a real hard time with this thing. I'm not sure if it's the Helix or all trackpads. On my X201 I shut it off for the past 3 years.

 

Whenever I tried to right click by clicking on the bottom left of the track pad on the Helix, I invariably move the cursor 15-25 pixels, and therefore end up missing the target of the right click.

 

Is there a keystroke combo that disables any mouse movement on the trackpad? Like holding down Fn+<Something> and then "Right clicking"?

 

 

Reply
Answer
Options

39 Posts

04-19-2013

Canada

135 Signins

867 Page Views

  • Posts: 39
  • Registered: ‎04-19-2013
  • Location: Canada
  • Views: 867

Re: Helix track pad driving me insane

2013-05-27, 21:41 PM

I had this problem too and fixed it following the advice on that link. BUT you have to make an adjustment for the Helix.

 

These instructions point to the registry entry that ends "TouchPadPS2". I have that in my registry, but the settings under that entry are fine. There's one right underneath that ends TouchPadSMB2c. That's the one you have to fix. On my Helix the 2FingerTapAction key was already set to 2 and did not need to be changed. However, the MultiFingerTapFlags key was a 2 and needed to be changed to 3. After making the change and restarting I had two-finger tap again!

 

Thanks to the original poster for fixing a hugely annoying and seriously bush league problem,

Reply

Replies(6)
Options

21115 Posts

12-20-2008

Australia, Melbourne

20622 Signins

444194 Page Views

  • Posts: 21115
  • Registered: ‎12-20-2008
  • Location: Australia, Melbourne
  • Views: 444194
  • Message 2 of 7

Re: Helix track pad driving me insane

2013-05-19, 1:58 AM
The Fn shortcut is no longer present in the updated ThinkPad (which is stupid if you ask me). You have to do it through control panel under mouse, or do it through the BIOS.
Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
Reply
Options

33 Posts

11-12-2012

Netherlands

119 Signins

637 Page Views

  • Posts: 33
  • Registered: ‎11-12-2012
  • Location: Netherlands
  • Views: 637
  • Message 3 of 7

Re: Helix track pad driving me insane

2013-05-19, 10:18 AM

can't you activate the two finger tab right click gesture? In that way you won't have do the pysical click at all. On my X220 this trackpad is also really bad designed, giving the same problems as you discribe. Also drawing in Paint or so is a complete hell. 

Reply
Options

32 Posts

04-11-2013

Michigan

250 Signins

901 Page Views

  • Posts: 32
  • Registered: ‎04-11-2013
  • Location: Michigan
  • Views: 901
  • Message 4 of 7

Re: Helix track pad driving me insane

2013-05-19, 13:20 PM

wrote:

OK, I'm having a real hard time with this thing. I'm not sure if it's the Helix or all trackpads. On my X201 I shut it off for the past 3 years.

 

Whenever I tried to right click by clicking on the bottom left of the track pad on the Helix, I invariably move the cursor 15-25 pixels, and therefore end up missing the target of the right click.

 

Is there a keystroke combo that disables any mouse movement on the trackpad? Like holding down Fn+<Something> and then "Right clicking"?

 

There are extensive customizations of the track pad available.   Go into control panel  mouse->track pad and ajdust the sensitive areas for buttons and gestures.   I used to be driven crazy as well, but now it seems just fine.

 

Reply
Options

42 Posts

05-10-2013

Chicago, IL

36 Signins

335 Page Views

  • Posts: 42
  • Registered: ‎05-10-2013
  • Location: Chicago, IL
  • Views: 335
  • Message 5 of 7

Re: Helix track pad driving me insane

2013-05-20, 18:33 PM
I have the same trouble trying to use the lower right "button" for right-click, so I set mine up so a two-finger "click" (press down on the trackpad) is a right-click.

The funny thing is when I first got my Helix a two-finger "tap" would do a right click (like a single finger tap is a "normal" click). But once I started playing with the trackpad settings in the control panel that two-finger tap went away and I can't find any option to turn it back on. So the two-finger click is the next best thing, I never get any cursor movement when I do that.

You can also setup a "tap zone" for right click, on my older Win7 Dell laptops I used to set the top right corner up as a zone for a single tap being a right click, but on the Helix I haven't done that as the two-finger click works well and you can do it anywhere on the trackpad.
JT
Lenovo ThinkPad Helix 36984SU
Reply
Options

33 Posts

11-12-2012

Netherlands

119 Signins

637 Page Views

  • Posts: 33
  • Registered: ‎11-12-2012
  • Location: Netherlands
  • Views: 637
  • Message 6 of 7

Re: Helix track pad driving me insane

2013-05-21, 5:21 AM

I had the same problems.

 

you need to change something in the reg. 

 

check out this topic http://forums.lenovo.com/t5/X-Series-Tablet-ThinkPad-Laptops/two-finger-tap-right-click-not-working-anymore/td-p/1122291

Reply
Answer
Options

39 Posts

04-19-2013

Canada

135 Signins

867 Page Views

  • Posts: 39
  • Registered: ‎04-19-2013
  • Location: Canada
  • Views: 867
  • Message 7 of 7

Re: Helix track pad driving me insane

2013-05-27, 21:41 PM

I had this problem too and fixed it following the advice on that link. BUT you have to make an adjustment for the Helix.

 

These instructions point to the registry entry that ends "TouchPadPS2". I have that in my registry, but the settings under that entry are fine. There's one right underneath that ends TouchPadSMB2c. That's the one you have to fix. On my Helix the 2FingerTapAction key was already set to 2 and did not need to be changed. However, the MultiFingerTapFlags key was a 2 and needed to be changed to 3. After making the change and restarting I had two-finger tap again!

 

Thanks to the original poster for fixing a hugely annoying and seriously bush league problem,

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms