Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Tablet and Helix Laptops
All Forum Topics
Options

7 Posts

07-25-2008

Savannah

8 Signins

39 Page Views

  • Posts: 7
  • Registered: ‎07-25-2008
  • Location: Savannah
  • Views: 39
  • Message 1 of 8

Installed Vista - lost ThinkVantage, etc..

2008-07-25, 12:33 PM

I have a X61 Tablet (XP Tablet - still under warranty) that I did a clean install of Vista Ultimate.  I suppose that during this process the HD was reformatted and it appears I lost all of the ThinkVantage drivers, etc.....in fact I can find nothing that relates to any of the Lenovo "stuff".  All works properly, with no problems, except the missing Lenovo "stuff", Bluetooth, etc, etc....

 

I have looked all over the Lenovo site for downloads that would reinstall the missing software, etc.......no luck.

 

Would really appreciate any assistance that would point me in the right direction.

 

Thanks in advance.

 
Reply
Answer
Options

5884 Posts

11-24-2007

United States of America

12810 Signins

291275 Page Views

  • Posts: 5884
  • Registered: ‎11-24-2007
  • Location: United States of America
  • Views: 291275

Re: Installed Vista - lost ThinkVantage, etc..

2008-07-25, 12:48 PM

the fastest and easiest method would be to install thinkvantage system update and use it to find, specify, and install missing drivers and software.

 

your other option is to install everything manually by downloading individual drivers from this page.

 

with either method the end result will be the same.

ThinkStation P700      ThinkPad X1C7

Reply

Replies(7)
Answer
Options

5884 Posts

11-24-2007

United States of America

12810 Signins

291275 Page Views

  • Posts: 5884
  • Registered: ‎11-24-2007
  • Location: United States of America
  • Views: 291275
  • Message 2 of 8

Re: Installed Vista - lost ThinkVantage, etc..

2008-07-25, 12:48 PM

the fastest and easiest method would be to install thinkvantage system update and use it to find, specify, and install missing drivers and software.

 

your other option is to install everything manually by downloading individual drivers from this page.

 

with either method the end result will be the same.

ThinkStation P700      ThinkPad X1C7

0 person found this solution to be helpful.

This helped me too

Reply
Options

7 Posts

07-25-2008

Savannah

8 Signins

39 Page Views

  • Posts: 7
  • Registered: ‎07-25-2008
  • Location: Savannah
  • Views: 39
  • Message 3 of 8

Re: Installed Vista - lost ThinkVantage, etc..

2008-07-25, 15:13 PM

Thank you very much Erik......everything downloaded and installed except the last update - Update BIOS.  I think there

may be a problem - the final portion of the BIOS update is "Flash new BIOS".......AND it has been in that state for over

30 minutes...mouse is frozen.....should I close down and see what happens or keep on waiting...?

 

Thanks

Reply
Options

5884 Posts

11-24-2007

United States of America

12810 Signins

291275 Page Views

  • Posts: 5884
  • Registered: ‎11-24-2007
  • Location: United States of America
  • Views: 291275
  • Message 4 of 8

Re: Installed Vista - lost ThinkVantage, etc..

2008-07-25, 15:24 PM

just to be safe, give it another 30 minutes.   if it remains stuck then power off the X61T by holding the power button for four seconds.   then, burn a copy of the BIOS to CD using the bootable .iso version, then reboot with the CD installed to flash the BIOS manually.

 

hopefully everything turns out ok.   i've never personally seen a BIOS hang like that but must admit that i use the .iso version most of the time.

ThinkStation P700      ThinkPad X1C7

Reply
Options

7 Posts

07-25-2008

Savannah

8 Signins

39 Page Views

  • Posts: 7
  • Registered: ‎07-25-2008
  • Location: Savannah
  • Views: 39
  • Message 5 of 8

Re: Installed Vista - lost ThinkVantage, etc..

2008-07-25, 15:26 PM
Thanks.....will do .....will let you know how it turns out..
Reply
Options

7 Posts

07-25-2008

Savannah

8 Signins

39 Page Views

  • Posts: 7
  • Registered: ‎07-25-2008
  • Location: Savannah
  • Views: 39
  • Message 6 of 8

Re: Installed Vista - lost ThinkVantage, etc..

2008-07-25, 18:19 PM

Erik.....didn't have to use CD....the BIOS didn't update, which is ok.....I can do it later....One other problem that seems to

have "popped-up".   My X61 has 4gb RAM, however, Windows Task Manager Performance only shows 1gb and the Vista

Sidebar continually shows RAM being 75-90% utilized AND it has slowed down.  As an aside, my desktop, also running Vista

has 4gb RAM and it shows.  I have disabled most Startups on my X61.......Any suggestions.?  Thanks in advance....Bill

Reply
Options

7 Posts

07-25-2008

Savannah

8 Signins

39 Page Views

  • Posts: 7
  • Registered: ‎07-25-2008
  • Location: Savannah
  • Views: 39
  • Message 7 of 8

Re: Installed Vista - lost ThinkVantage, etc..

2008-07-25, 20:06 PM

Erik......I resolved problem re: RAM ..... the Max Memory in BOOT Advanced Options was checked and had 999....unchecked

and all is well...Thanks

Reply
Options

5884 Posts

11-24-2007

United States of America

12810 Signins

291275 Page Views

  • Posts: 5884
  • Registered: ‎11-24-2007
  • Location: United States of America
  • Views: 291275
  • Message 8 of 8

Re: Installed Vista - lost ThinkVantage, etc..

2008-07-25, 20:47 PM

ahh, good deal.   glad you got it figured out.   i was off doing whatever it is i do for a living and not paying attention to the forum.   lol :D

 

enjoy your weekend! :)

ThinkStation P700      ThinkPad X1C7

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms