English Community

ThinkPad NotebooksThinkPad: X Series Tablet and Helix Laptops
All Forum Topics
Options

1 Posts

06-27-2016

US

14 Signins

112 Page Views

  • Posts: 1
  • Registered: ‎06-27-2016
  • Location: US
  • Views: 112
  • Message 1 of 32

Thinkpad Helix pen stopped working (a supported tablet was not found on the system)

2016-06-27, 17:21 PM

I updated my Helix to Windows 10 shortly after it was released, and the pen worked great for several months. Then it just quit one day. I have tried everything I can find across the forums to fix it. I've tried updating to the Windows 10 wintab driver, I've tried rolling back to the Windows 8.1 wintab driver. I checked to make sure the firmware was up to date. Nothing is working, and if I try to install the wacom isd driver I get the error a supported tablet was not found on the system. If I go into device manager I can see a driver with a yellow exclamation point pop up under universal serial bus controllers when the pen is removed from its silo. Does anyone have any other suggestions I could try? Or is this most likely a hardware problem?

Reply
Options

17 Posts

03-15-2016

Perth, Western Australia

40 Signins

194 Page Views

  • Posts: 17
  • Registered: ‎03-15-2016
  • Location: Perth, Western Australia
  • Views: 194
  • Message 2 of 32

Helix Gen 1 Lost digitizer pen after Windows 10 annual upgrade

2017-07-07, 9:26 AM

I recently performed a system restore and somehow ended up with the latest WIN10 release (1703) and I cannot for the life of me get my Helix to see the Digitizer Pen at all.  I have searched Lenovo Support for days and cannot find a driver!  

has anyone else had this problem and have they been able to resolve.

 

**HINT HINT** some help from LENOVO would be GREAT!

Reply
Options

17 Posts

03-15-2016

Perth, Western Australia

40 Signins

194 Page Views

  • Posts: 17
  • Registered: ‎03-15-2016
  • Location: Perth, Western Australia
  • Views: 194
  • Message 3 of 32

Helix Gen 1 Lost digitizer pen after Windows 10 annual upgrade

2017-07-09, 6:45 AM

Did you ever get this problem fixed?

 

I see the great level of Lenovo Support has gone all out to help you out here!

Reply
Options

4218 Posts

01-22-2010

US

38572 Signins

578521 Page Views

  • Posts: 4218
  • Registered: ‎01-22-2010
  • Location: US
  • Views: 578521
  • Message 4 of 32

Helix Gen 1 Lost digitizer pen after Windows 10 annual upgrade

2017-07-09, 22:13 PM

Hi noremac_22,

 

I merged your other thread onto this one.

 

I have a Helix Gen. 1 and it has been upgraded to Win. 10, 1703 and the pen is working as it should be.  When you take the pen out of its holder and you see the yellow mark in Device Manager, open the device that has the yellow mark.  Click on driver and see if any driver has been installed.  If it has, tell me what version of the driver is there.

 

Regards,

Dave


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so. Using Browser Search To Find Answers in the Lenovo and Moto Communities
Reply
Options

17 Posts

03-15-2016

Perth, Western Australia

40 Signins

194 Page Views

  • Posts: 17
  • Registered: ‎03-15-2016
  • Location: Perth, Western Australia
  • Views: 194
  • Message 5 of 32

Re: Helix Gen 1 Lost digitizer pen after Windows 10 annual upgrade

2017-07-10, 5:12 AM

Hi Dave,

Prior to attempting to install WIN7 (compat mode) drivers from Lenovo Support downloads this is what the HID Devices looked like, as you can see no Pen/Digitizer drivers.

 

 

 

When I select the Driver Details button I get the popup message above.  Assuming this is because its running in Compat Mode??

 

I noted the driver was 2006 so tried doing an update but it keeps saying the latest drivers are already installed.

 

I can open Windows Ink Workspace and use OneNote/SketchPad but only with my finger.  I thought the digitizer might be faulty but if this was the case the tablet wouldnt work at all right, ie not even recognise me moving my finger around on the screen?

 

I've spent days trying to resolve this to no avail and am now thinking about moving back to WIN8 but unsure if that will fix the problem.  Is there a way to check if the Pen or Digitizer that recognises the Pen is faulty?

I have tried running the Hardware Check but that comes up with everything is ok.

 

I have done a Windows Update and Lenovo System Update, even tried updating drivers using Drive Booster over the wekeend but nothing seems to be able to see that the Pen is even there.  Which is making me think the Pen or Digitizer that recognises the Pen is faulty.

 

One more thing I should add, when I originally got the Helix it was completely wiped by my IT team and WIN7 was installed as that was our OS at the time, so at that point in time the Pen wasnt working with WIN7 (or at least my IT Team couldnt be bothered getting it to).  When I left the company I decided to do a clean WIN8 recovery install and since then the free WIN10 update.  I recently had to do a reset a few weeks back and when I did I somehow ended up with the newest WIN10 release but made sure I did a driver update using both Windows and System Update.

 

I'm dumbfounded why I cannot get this to work when I know the tablet is still ok given it accepts my swipes and finger drawing :D.

 

any help would be greatly appreciated!

Reply
Options

4218 Posts

01-22-2010

US

38572 Signins

578521 Page Views

  • Posts: 4218
  • Registered: ‎01-22-2010
  • Location: US
  • Views: 578521
  • Message 6 of 32

Re: Helix Gen 1 Lost digitizer pen after Windows 10 annual upgrade

2017-07-10, 23:23 PM

Hi noremac_22,

 

One way to test if the hardware is working is to run a Linux Live flash drive or a cd and see if Linux can pick up the pen and touchscreen. I run Android in a VR on mine and the pen and touchscreen work ok.

 

My Device manager looks a lot different from yours, I don't have anything in there that says Wacom like yours does.  

 

When you take the pen out of the holder, does Device Manager change and add anything to the list of devices? Is what it is adding the Wacom devices?

 

When I got mine, it had the Windows 8.1 preload on it and I upgraded it to Windows 10 Pro.  The pen and touchscreen has worked on every update and upgrade.  

 

Regards,

Dave

 

 


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so. Using Browser Search To Find Answers in the Lenovo and Moto Communities
Reply
Options

17 Posts

03-15-2016

Perth, Western Australia

40 Signins

194 Page Views

  • Posts: 17
  • Registered: ‎03-15-2016
  • Location: Perth, Western Australia
  • Views: 194
  • Message 7 of 32

Re: Helix Gen 1 Lost digitizer pen after Windows 10 annual upgrade

2017-07-11, 2:18 AM

Hi Dave,

 

BTW Scott is my name :).

 

Removing the Pen from the silo does nothing to the Device Manager list.  The Wacom drivers you see in my list were added once I installed the WIN7 (Compat Mode) drivers, but they have no effect what so ever on my Pen.

 

I can see the touch pad drivers looks to be the same between our systems and my touch screen works just fine with my hand/finger swipes etc but it ignores the Pen.  I'll assume then my Pen driver should be the same as yours not the Wacom one as shown in mine, prob because it's the WIN7 one.

Given the touch screen works just fine I'm beginning to think the Pen and/or the device that triggers the Pen when removed from silo is faulty.

 

I've never worked with Linux Live flash drive before, (not as tech savy as some), but I'll google and youTube it today and give it a go.

 

Thanks for your help so far :)

Scott

 

 

Reply
Options

4218 Posts

01-22-2010

US

38572 Signins

578521 Page Views

  • Posts: 4218
  • Registered: ‎01-22-2010
  • Location: US
  • Views: 578521
  • Message 8 of 32

Re: Helix Gen 1 Lost digitizer pen after Windows 10 annual upgrade

2017-07-12, 1:22 AM

Hi Scott,

 

Looking at the driver in Device Manager, my driver version is the same as yours except it is labeled different.  Mine says in the General tab that the location is on USB Input Device and yours says on Wacom Virtual Hid Driver.  It looks like your pen is being recognized, just not in the way it is supposed to be. I can also open the Details tab without your error popping up.  I also don't have anything in there that says Virtual Hid Driver.  

 

I remember having a problem with an X61 tablet when System Update tried to give me an update for a Virtual Hid Driver and the pen wouldn't work.  I had to run System Restore to put the machine back before the update happened.  I know that is not an option for you.  Let's see if Linux can help.

 

Regards,

Dave


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so. Using Browser Search To Find Answers in the Lenovo and Moto Communities
Reply
Options

17 Posts

03-15-2016

Perth, Western Australia

40 Signins

194 Page Views

  • Posts: 17
  • Registered: ‎03-15-2016
  • Location: Perth, Western Australia
  • Views: 194
  • Message 9 of 32

Re: Helix Gen 1 Lost digitizer pen after Windows 10 annual upgrade

2017-07-12, 2:18 AM

Hi Dave,

 

hmm I dont know what happened to my last update here but it seems to have disappeared, geee I am having the best luck....

 

I downloaded Linux Flash, although it took me most the day (very slow internet here in OZ) and the best part of an hour trying to get to the Helix bios to boot to USB.

 

In short, Linux recognises the touch screen, finger swipes etc but not the Pen.  On opening Linux Settings there is a hardware option for Wacom Tablet, but when I select it, it says no Tablet Installed, so it sees it but it doesn't really see it, :smileymad:

 

I wonder, is there a way for you to dump your drivers on here for me to try and install?

 

By the way, it didnt dawn on me until last night (Homer Simpson moment.. DOH!) but I figured my WIN8 installation USB (ISO) would have the drivers on it so I went looking for my installation USB and tried updating the drivers pointing to the USB, no luck there either.  I'm really starting to think the device that recognises the Pen is faulty. :smileysad:

 

cheers again for all your help/advice

Reply
Options

4218 Posts

01-22-2010

US

38572 Signins

578521 Page Views

  • Posts: 4218
  • Registered: ‎01-22-2010
  • Location: US
  • Views: 578521
  • Message 10 of 32

Re: Helix Gen 1 Lost digitizer pen after Windows 10 annual upgrade

2017-07-12, 10:41 AM

Hi Scott,

 

I found this thread on a Google search, did you see this in your searching?  Maybe something over here will help.  Maybe the trick is to install the Wacom drivers with the pen out of its holder.

 

Dave


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so. Using Browser Search To Find Answers in the Lenovo and Moto Communities
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete