Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Tablet and Helix Laptops
All Forum Topics
Options

83 Posts

03-28-2013

USA

168 Signins

786 Page Views

  • Posts: 83
  • Registered: ‎03-28-2013
  • Location: USA
  • Views: 786
  • Message 1 of 2

USB hub not working after Helex Bios update

2013-07-08, 14:43 PM

Sorry for repost but the subject in my other post got changed and is miss leading

 

Hi all,

 

I did the "official" bios update.  Since the up date my ORICO W8PH4 Portable 4 - Port USB3 does not work reliably.  It sends power out, but does not communicate.  Occasionally it will kick in but mostly no.  Any one have ideas?

 

thanks

 

dave 

Reply
Options

83 Posts

03-28-2013

USA

168 Signins

786 Page Views

  • Posts: 83
  • Registered: ‎03-28-2013
  • Location: USA
  • Views: 786
  • Message 2 of 2

Re: USB hub not working after Helex Bios update

2013-07-10, 17:17 PM

Update,

 

It most likely is not he bios update.  Got a new hub and it seems to work, so the other one stopped working, for reasons unkown.  It just happen directly after the update so that is why I was thinking the update did something..  Do not know why and suggests this model might be iffy.  Having a portable hub is nice though.

 

dave

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms