Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Tablet and Helix Laptops
All Forum Topics
Options

210 Posts

12-20-2007

NY

560 Signins

2994 Page Views

  • Posts: 210
  • Registered: ‎12-20-2007
  • Location: NY
  • Views: 2994
  • Message 1 of 8

Wrong system from repair center..3 weeks so far I still get nothing

2008-06-13, 0:08 AM

I don't know if anyone here could help alleviating this problem. My issue is my x61 tablet was unable to turn on. Then I sent to repair on May 16, 2008. The process was very quick so that I got a tracking number of returning my x61t on May 18, 2008 and got the box on May 19, 2008.

Unfortunately, the system I got was not mine; it's Thinkpad T43. I called customer service and shipped that wrong machine back the day later (May 20, 2008).

I have numbers of talks with many reps. However, so far, almost a month now, I still have nothing. 

First week, I called customer service, they said they would take care of my machine and had to wait to see how it goes. If they still couldn't work on that, they might be able to issue a replacement for me.

Second week, I called them again asking for any status of my case. No one knows what I am talking about. Seems like I had to start it over again. Then on May 28, 2008 the rep named Greg (tel. 800xxxxxxx) took care of me so well and told me to wait for any progress on my case. Yes, as you expected no good news.

Third week, Mr. Greg called me on June 3, 2008 I have to wait for 2 days to be able to contact him since that customer was on vacation. Huh?? I have to wait for his vacation as well, right? and last 2 weeks Lenovo did nothing to contact him, didn't they? Unfortunately, nothing happened. They still couldn't contact that customer again

4th week, on Monday Jun 9, 2008, Greg told me that it's the 1st time they could contact that customer and arranged to ship my system back asap. I decided to call Jim xxxxxxx, Mobile/Think Centre Customer Satisfaction Advocate, who replied me on a survey about how I felt about Lenovo service. He promised to take care of my issue and would call me back on any progresses. Hours later, Jim called me that my system should be at repair center pretty soon. And it did (I guess??) since Jim called me again on Jun 10, 2008 that I would be able to get my system any day from then. *UNFORTUNATELY* again I have waited patiently for 2 DAYS after I have been told that repair center got my machine. Today, my hope was gone, DHL came by my apartment and had nothing for me. I talked with Jim again. He told me that he would check on that mess. I asked if there is any chance I could get a replacement now. He answered if he couldn't find any progress, he might be able to help. But after a while he called me to ask about when is the date someone told him that the machine was at the repair center. I think he was no sure whether I or other rep told him that. Then I asked if he could do a replacement unit now? since I have no trust of any progress after all this saga. He replied me that my machine was in the box and ready to ship and no one touches it why would I have to ask for a replacement?

That was shock. Yet no tracking number? How could I believe him? since a min ago he asked when and where about my machine. But now he came up with knowing where my system is.

That was really BAD service from Lenovo or IBM? I don't really know. But with all your fault, I couldn't work. Anyone here please help solving my problem? I have to work to live my life like you guys. I have no work done almost a month now. Will Lenovo compensate for that, but excuses day by day??

Moderator Note; Phone number and full names of Lenovo employees edited as per forum rules



Message Edited by andyP on 06-13-2008 08:32 AM
Reply
Answer
Options

210 Posts

12-20-2007

NY

560 Signins

2994 Page Views

  • Posts: 210
  • Registered: ‎12-20-2007
  • Location: NY
  • Views: 2994

Re: Wrong system from repair center..3 weeks so far I still get nothing

2008-07-01, 4:00 AM

Hi Mark,

 

Sorry that I haven't updated my thread after the last time.  I got my machine back on Friday June 20, 2008. That was 36th day since I had sent for repairing. My machine works well as it used to and I found in Windows log that there were a usage on May 17, 2008--the first day it was at repair center--and May 19, 2008--the day it supposed to be at my room (or the day I got a wrong unit.) After that, there was no log of turning my machine on. (or it was deleted?) That leave me a big curiosity of where my machine was for a whole month--which no one could not find.

 

All in all, I got my X61T back. I'm happy with it, but I still feel bad about IBM repair center. It's only the matter of time, I guess

Reply

Replies(7)
Options

3290 Posts

02-17-2008

Australia

1962 Signins

50408 Page Views

  • Posts: 3290
  • Registered: ‎02-17-2008
  • Location: Australia
  • Views: 50408
  • Message 2 of 8

Re: Wrong system from repair center..3 weeks so far I still get nothing

2008-06-15, 5:07 AM
Sorry to hear about all your problems, hopefully one of the Lenovo administrator like Mark_Lenovo could resolve the mess for you.
Reply
Options

210 Posts

12-20-2007

NY

560 Signins

2994 Page Views

  • Posts: 210
  • Registered: ‎12-20-2007
  • Location: NY
  • Views: 2994
  • Message 3 of 8

Re: Wrong system from repair center..3 weeks so far I still get nothing

2008-06-15, 6:30 AM
Thanks, wjli2


weirder part is  I called them again on Friday, both of reps I had contacted were off and another guys who talked to me tried to trace my laptop with all notes in the case. What he found was nothing, he couldn't even tell whether the customer who got mine shipped the machine back or not.

At this point, I don't know what to hope for anymore. :smileysad:

note:
my case#20V7CB3; it was closed on May 19, 2008 and not able to see via the web anymore.
Reply
Options

3290 Posts

02-17-2008

Australia

1962 Signins

50408 Page Views

  • Posts: 3290
  • Registered: ‎02-17-2008
  • Location: Australia
  • Views: 50408
  • Message 4 of 8

Re: Wrong system from repair center..3 weeks so far I still get nothing

2008-06-15, 9:49 AM
Mark is the most helpful person around, he usually solve many difficult cases that other people wouldn't even touch.
Reply
Options

8095 Posts

11-19-2007

United States of America

10101 Signins

400183 Page Views

  • Posts: 8095
  • Registered: ‎11-19-2007
  • Location: United States of America
  • Views: 400183
  • Message 5 of 8

Re: Wrong system from repair center..3 weeks so far I still get nothing

2008-06-16, 21:44 PM
Sipp11,
 
A formal complaint has been created on your behalf - sending you the case number via PM.
 
The representative assigned should be touch with you within 24 hours.
 
Apologies for this situation.
 
Mark
 
 
 
Reply
Options

210 Posts

12-20-2007

NY

560 Signins

2994 Page Views

  • Posts: 210
  • Registered: ‎12-20-2007
  • Location: NY
  • Views: 2994
  • Message 6 of 8

Re: Wrong system from repair center..3 weeks so far I still get nothing

2008-06-19, 19:59 PM
Well my case is almost over now.

At the beginning of this week, Lenovo rep called me that they would give me a replacement since they couldn't find my laptop. The day later, another rep called me about spec of a replacement machine which was lower than my unit. So she told me that she would check if it's possible to get a spec (1.8GHz) I had, then she would call me back.

2 days passed no one called me back. So I called them to ask how was my case today; still had to wait for a call back though since the person who took care of mine was not there.

a hour later, she called me to tell that they found my machine and prepared to ship back.

Yes, I'm glad that my X61T will be home tomorrow (If there is no any bad luck again) BUT I felt like I had been slapped on the face twice because it seemed like they gave me a hope to get a new machine just to buy an extra time... I really have nothing to say...

Very disappointing for this kind of service, very unprofessional IMO. I hope I would be the last who faced this situation.
Reply
Options

8095 Posts

11-19-2007

United States of America

10101 Signins

400183 Page Views

  • Posts: 8095
  • Registered: ‎11-19-2007
  • Location: United States of America
  • Views: 400183
  • Message 7 of 8

Re: Wrong system from repair center..3 weeks so far I still get nothing

2008-06-30, 22:28 PM

Sipp11,

 

I certainly understand why you would feel disappointed in the situation.  Could you update this thread as to whether the system was returned to you in repaired condition, and otherwise satisfactory?

 

I ask since your title leaves the situation open.  

 

Thanks

 

Mark

Reply
Answer
Options

210 Posts

12-20-2007

NY

560 Signins

2994 Page Views

  • Posts: 210
  • Registered: ‎12-20-2007
  • Location: NY
  • Views: 2994
  • Message 8 of 8

Re: Wrong system from repair center..3 weeks so far I still get nothing

2008-07-01, 4:00 AM

Hi Mark,

 

Sorry that I haven't updated my thread after the last time.  I got my machine back on Friday June 20, 2008. That was 36th day since I had sent for repairing. My machine works well as it used to and I found in Windows log that there were a usage on May 17, 2008--the first day it was at repair center--and May 19, 2008--the day it supposed to be at my room (or the day I got a wrong unit.) After that, there was no log of turning my machine on. (or it was deleted?) That leave me a big curiosity of where my machine was for a whole month--which no one could not find.

 

All in all, I got my X61T back. I'm happy with it, but I still feel bad about IBM repair center. It's only the matter of time, I guess

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms