English Community

ThinkPad NotebooksThinkPad: X Series Tablet and Helix Laptops
All Forum Topics
Options

4 Posts

12-12-2016

US

7 Signins

71 Page Views

  • Posts: 4
  • Registered: ‎12-12-2016
  • Location: US
  • Views: 71
  • Message 1 of 2

Having issues with my X230i Laptop

2016-12-12, 19:07 PM

Pretty new to the forum, so I apologize if something like this has been brought up before.

 

I'm having some strange issues with my laptop.  When I first start the thing up, everything works fine and dandy... but whenever I put it into sleep or hibernation mode, that's when things start to go wrong.  For example, that on-screen display that shows up when you increase or decrease the volume will be there when I first turn it on, but will never show up again after resuming from sleep/hibernation.  My USB Bluetooth dongle will also work just fine, until I put the computer to sleep/hibernation... once I resume, it just won't work anymore (it'll detect things, but will pretty much instantly disconnect from them a few seconds later).  My wifi connection will also take a hit when I resume from sleep/hibernation, as it seems to take it a good minute or two for the computer to realize it's finally there before I can continue using it again.  There are other examples of this (the built-in webcam flat-out refusing to work after resuming from sleep/hibernation, sometimes the digital pen won't work, the monitor won't auto-rotate when I switch the laptop into tablet mode, etc.), but these are my most-common issues.

 

I'm not sure how to describe this problem exactly, other than the computer just seems to "Forget" it can do certain things when it wakes up.  

 

Has anyone else encountered an issue like this?  Sure, I suppose I can solve this by just shutting down the computer every time I'm done using it, but I often have a lot open on my Laptop that I like to keep on hand in the taskbar, which is why I usually put the computer to sleep or hibernation.  Not only that, I travel around quite a bit, and having it start up on the fly is pretty valuable to me.

 

Anyone have any ideas?  Is it a hardware issue?  Can re-installing Windows fix it?  I really have no idea, so any help will be greatly appreciated.  

 

 

Some of my Laptop specs are...

X230i Tablet Laptop

Windows 7 x64

8gb of ram, 2.6ghz processor (can turbo to 3.3)

Intel HD 4000, i5 core 3320m

 

I've had the thing for about a year, though I did buy it used.  I could swear it didn't do this when I first got it, but I really can't remember.  I'm assuming it's something I might've done...

 

Also, in case anyone's curious, the Bluetooth dongle works just fine on other computers I have access to, even when I resume those PC's from sleep or hibernation.  It only seems to have issues on my Lenovo Laptop.

 

If I need to provide any more info, please let me know.

 

Reply
Options

4 Posts

12-12-2016

US

7 Signins

71 Page Views

  • Posts: 4
  • Registered: ‎12-12-2016
  • Location: US
  • Views: 71
  • Message 2 of 2

Re: Having issues with my X230i Laptop

2016-12-21, 1:41 AM

Well, despite the lack of assistance here, I think I was able to solve my issues with the Laptop.

 

Turns out, it was Lenovo Power Management.  I'm not sure why or how, but when I removed it, things seemed to go back to normal.  Now whenever I resume from sleep or hibernation, the Wifi works just fine, and even the bluetooth doesn't fail to connect to my devices anymore.  Sadly, I did lose the on-screen indicator whenever you increase or decrease the volume or screen brightness, but I can live with that.

 

Guess my problems have been solved.  I thought I'd go ahead and post my solution here though, just in case anyone else has a similar problem.  

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete