English Community

ThinkPad NotebooksThinkPad: X Series Tablet and Helix Laptops
All Forum Topics
Options

1 Posts

09-26-2019

US

3 Signins

22 Page Views

  • Posts: 1
  • Registered: ‎09-26-2019
  • Location: US
  • Views: 22
  • Message 1 of 2

Helix 1st Gen won't boot after fan replacement

2019-09-26, 10:53 AM

I just finished replacing the fan and heat sink in the tablet portion with new heatsink compound.  Initially the tablet portion was working ok but the keyboard was not working.  I couldn't get anything after trying several times to reset the keyboard and the tablet.  I took the tablet apart and double checked all of my connections and when I put it back together it won't boot up now.  I've tried reseating all the cables and resetting the tablet many times and nothing is working.

 

I really like this laptop and would really like to salvage it.  Is there anything I may have missed that might get this working again?

Reply
Options

10381 Posts

01-02-2010

US

39200 Signins

404697 Page Views

  • Posts: 10381
  • Registered: ‎01-02-2010
  • Location: US
  • Views: 404697
  • Message 2 of 2

Re: Helix 1st Gen won't boot after fan replacement

2019-09-27, 15:31 PM

I haven't worked on that model in a while, but I remember 2 things.  There was a cable that ran from under the motherboard to the top surface, near the battery that was easy to forget.  Also, there are 3 cables from the LCD to the motherboard (video, misc. connections and touch) that are fairly tight.  They can be difficult to get inserted all the way.  The whole machine is tightly packed. Just reseat all the connections


Rich


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save