cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
srinathkrishna
What's DOS?
Posts: 1
Registered: ‎05-07-2018
Location: US
Views: 118
Message 1 of 2

SMART Self Test not running

I recently got a Thinkpad X230 with an SSD and 4 gigs of RAM. I've been having some stuttering and freezing when trying to use something that's compute intensive - mostly YouTube videos or Hangouts calls or the like. I've tried different browsers and the effect is the same. My primary OS is Arch Linux with the 4.16 kernel. I've tried with my other OS - Windows 10 and this happens there as well, albeit less frequently.

 

I suspected there could be issues with my memory or SSD and tried to diagnose it with the tools in the BIOS. The memory checks ran fine and didn't throw any errors while the SSD tests all passed except for the Self test. The self test was "In Progress" for an entire night at 0% and I suspected it ever ran. The logs didn't indicate that they did.

 

Does this mean that my SSD needs to be replaced? Is there any other test that I can run to prove this conclusively? Or is it just a case of low RAM? I don't have swap enabled on my linux and I'm guessing the 4 gigs is simply not enough for the task.

Community SeniorMod
Community SeniorMod
Posts: 9,255
Registered: ‎01-01-2010
Location: US
Views: 102
Message 2 of 2

Re: SMART Self Test not running

Run CrystalDiskInfo (freeware) and see what it says.  Some SSDs don't do SMART testing well, but work fine.


Rich


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.

Check out current deals!


Shop current deals

Top Kudoed Authors