English Community

ThinkPad NotebooksThinkPad: X Series Tablet and Helix Laptops
All Forum Topics
Options

3 Posts

03-01-2011

US

6 Signins

119 Page Views

  • Posts: 3
  • Registered: ‎03-01-2011
  • Location: US
  • Views: 119
  • Message 1 of 2

Thinkpad X1 tablet with productivity module and onelink doc display ports not working...

2019-04-30, 21:34 PM

I have a X1 Tablet with a productivity module attached.  I connect a Onelink+ doc to the Onelink+ port on the prod module.  Everything works great except when attaching a Monitor to the display port with an HDMI adapter, I cannot get the display to work unless I reboot the whole system with everything attached.  Then I can extend my display to the 2nd display.   If I disconnect the display and go home and I try to connect my HDMI monitor to the HDMI port on the prod module I cannot get it to work at all....even on a reboot.   The monitor says no signal detected.  If I try to detect the 2nd monitor it just fails saying I don't have one attached.  I have all the latest firmware and bios installed on the onlink and X1.  There does not seem to be anything I can find for the Prod module.  I have called Lenovo service and they have replaced both the Prod module and the Onlink+.   Same problems.

Anyone else experiencing difficulties with  this setup?   Rebooting is a real pain every day to get things working in the office, but the HDMI port not working at home is a real downer. 

I also have a dongle that converts the mini displayport to HDMI and that works fine. 

Thoughts?

Reply
Options

0 Posts

01-23-2020

US

0 Signins

0 Page Views

  • Posts: 0
  • Registered: ‎01-23-2020
  • Location: US
  • Views: 0
  • Message 2 of 2

Re: Thinkpad X1 tablet with productivity module and onelink doc display ports not working...

2020-01-23, 16:44 PM

I have this issue too. HDMI port is not working until performing a hard reset.

 

In order to perform a hard reset, disconnect the power adapter, take a pin and insert into the hole at the backside of X1, close to SD card slot. Then press gently.

 

X1 will shutdown, then you can restart again with the power button. In this method, you can use the HDMI port but will work in the first connection. When you disconnect HDMI cable, it will turn back again the initial situation and you will not use it again.

 

I tried many things to solve it but no success.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete