English Community

ThinkPad NotebooksThinkPad: X Series Tablet and Helix Laptops
All Forum Topics
Options

1 Posts

07-06-2018

US

2 Signins

29 Page Views

  • Posts: 1
  • Registered: ‎07-06-2018
  • Location: US
  • Views: 29
  • Message 1 of 1

X1 Tablet 1st Gen -- cannot run firmware updates from live boot (windows recovery)

2018-07-06, 17:24 PM

I run Ubuntu on my X1 tablet, and in general it's been great. (I completed removed Windows). However the digitizer pen jumps around in one particular part of my screen, and the touchscreen works only intermittently. I thought from another thread that this was perhaps a firmware issue, and decided it was a good idea to update my firmware anyway. So I made a USB stick with Windows PE on it (I also tried Windows Recovery), booted into it, and went to run the executables I downloaded here. But when I try to run them (from the Windows command line, which is my only option) I get, for example:

 

This version of C:\Updates\n17wn01w.exe is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher.

 

Only one executable ran, and it was the TPM Firmware Update utility, in particular "TpmFlash64.exe". It told me there was nothing for it to update.

I get the following from running ``ver``:

 

Microsoft Windows [Version 10.0.17134.1]

 

So I don't understand why the executables labeled Windows 10 on the Lenovo website won't run. My last idea was to build a x86 instead of amd64 Windows flash drive, in hopes that that would somehow fix things, but the X1 Tablet can't boot in Legacy mode, so I can't even get that to run.

 

Any input would be greatly appreciated! I'm pretty disappointed that my touchscreen isn't working correctly. In any case it seems like a good idea to be able to update my firmware.

 

Cheers!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete