cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
etiemuis
Paper Tape
Posts: 1
Registered: ‎10-06-2013
Location: The Hague, Netherlands
Views: 360
Message 1 of 1

X1 not charching after clean install Windows 7 Home SP1

Hi all,

 

I purchased a second-hand Lenovo X1.

It had Windows 7 Pro installed on it and everything worked fine. But because i wanted it to be clean I installed my own official Windows 7 Home Premium on it. Everything went well, except that the battery doens't charge anymore.

The battery is recognized as empty, not charging. In Lenovo Power Manager the status is inactive and the condition is good. All the setting in Lenovo Power Manager are good and i've tried all options for battery management etc.

 

I've been working on it for days but I can't fix it. Because of my experience and the results sofar I'm convinced that it must be an issue with the combination of my Windows 7 and the battery drivers/bios.

 

Because i don't want you to waste you're time here are the things I already tried :

 

Reinstalling Windows:

- reinstall and run windows update and then Lenovo Software update (and in reverse order, first system update and than window update

 

 

Lenovo driver updates

- i've tried all the patches and Power manger updates wich are available

- the available firmware update for battery's. The update stated that my battery didn't need new software

- the only update i can't run is the BIOS update. Because for this you need a charged battery. Because the battery is now empty it's not possible to install it. Where it might be te solution!

 

 

Internet solutions

- On the internet there is solution where in short you disconnect the battery and uninstall the battery ACPI drivers. reconnect battery and so on

- i even tried this by unscrewing the keyboard and disconnect the battery plug

- did al the steps, but diddn't work

- for other solutions i've searched everyting and everywhere

 


Energy report with cmd powercfg -energy

- most important was that the report stated that the PCI Express ASPM is inactive due to know compatibility issues with this hardware

- i ran an energyreport on my other Lenovo (T410S), and there i didn't mention any of this kind

- i tried al settings for PCI Express ASPM, it still comes back as inactive in the energyreport

 

I hope that anyone has an solution to fix this, as i said, it worked fine till the clean install of windows.

 

Configuration

- Lenovo X1, 1294 W1F

- Windows 7 Home Premium SP1 (Dutch language)

- battery type is 42T4977

 

tnx for you're time

 

 

 

Check out current deals!


Shop current deals

Top Kudoed Authors