Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Serial Port
Posts: 20
Registered: ‎06-12-2009
Location: Netherlands
0 Kudos

X200 Tablet: unable to install trackpoint utility and driver.

Everytime the last few months I ran the update utility it ended with the fault unable to update the trackpoint driver.Install manually.

This week again it happened and I decided to uninstall the old driver (4.72) and to download and install the new driver (4.73.1)

Uninstall gave no strange messages but when I tried to install the new driver nothing happened. Absolutely nothing. It extracted the package to the correct folder (DIVER) but that's it.

I tried after that to install it myself via setup.exe but NO luck.

Who can help??


Posts: 955
Topics: 3
Kudos: 80
Solutions: 65
Registered: ‎01-05-2010
Location: INDIA
0 Kudos

Re: X200 Tablet: unable to install trackpoint utility and driver.

Kindly update the BIOS and also the ThinkVantage Technology software.


Restart the system and then install the Track Point driver


Best Regards,


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!