Showing results for 
Search instead for 
Do you mean 

X220T ThinkPad tablet pen and digitizer accuracy firmware update

0 Kudos
Helpful? Click ►
Started ‎12-07-2011 by
Modified ‎12-07-2011 by

X220T ThinkPad tablet pen and digitizer accuracy firmware update

by ‎12-07-2011 08:05 PM - edited ‎12-07-2011 08:07 PM (5,056 Views)

Question

When I move the pen on my X220T near the edge or especially near corners and cursor just runs away from pen tip towards that edge. In the most affected corner, pen movement of about 1-2 mm causes cursor movement of about 5 mm. It is also slightly dependant on the angle at which I'm holding the pen. If I hold it perpendicular to the screen, then issue becomes less pronounced.

 

When trying to draw straight lines, the line appears deflected when drawn at certain points of the screen.  This is most easily demonstrated when drawing diagonal lines with a straight edge.

 

Answer

 

 

Updated Digitizer Firmware has been released that should address pen accuracy once installed and the calibration run again.  Customers report success with 4 and 16 point calibration in forum discussion..

 

This has also been released as a formal tip on the Lenovo Support site here

 

Please go through the readme file before installing the firmware.

 

--------------------------------------------------------------------------------
WHAT THIS PACKAGE DOES

This utility will examine your system configuration and detect supported
digitizer device installed in your ThinkPad X220 Tablet.

The utility will then check the firmware version of the ditizer and judge whether
your system requires a firmware update or not.  If required, an update button will
be enabled to run the firmware update program for your digitizer.


--------------------------------------------------------------------------------
CHANGES IN THIS RELEASE
  Release fwdigi01

<Fix>
 Improved accuracy of the digitizer.


--------------------------------------------------------------------------------
MAKING A DOWNLOADED FILE TO USE

  This section assumes to use Internet Explorer and Windows Explorer.

  Downloading file
  1. Click once on the underlined file name. Once this is done, some pop-up
     windows will appear.
  2. Follow the instructions on the screen.
  3. In the window to choose Run or Save, click the Save button.
  4. Choose the folder you would like to download the file to and click the Save
     button.
     A different window will appear and the download will begin and complete.
     Once the download has completed, there may or may not be a message stating
     that the download completed successfully.

  Extracting the Digitizer Firmware Update Utility
  5. Locate the folder where the file was downloaded.
  6. Double click the file saved.
  7. Copy "fwdigi01.exe" to the located folder.

  Finally delete the file saved in the step 4.


--------------------------------------------------------------------------------
INSTALLATION GUIDE

After the above sections "MAKING A DOWNLOADED FILE TO USE" have been completed,
follow these steps.

Please connect the AC adapter and use a fully charged battery to power the
ThinkPad system during the update.  This will avoid an accidental loss of power.

1. Run the "fwdigi01.exe".
2. The update utility examins a digitizer firmware version and judges update
   required or not.
3. If your digitizer firmware needs to be updated, the update button is able to push.
   If not, you can push the exit button only.
4. Follow the instructions on the screen to update the firmware.
   The update utility updates the firmware and verifies it.
5. When the update is completed, press the exit button to end the Firmware Update
   Utility.
6. Shutdown and power on again.
7. Finally delete the update utility.

Attention: Please do not power off the ThinkPad during the firmware update,
            or your digitizer may NOT be usable anymore.

 Notes:
 - The Digitizer Firmware Update Utility does not support a suspend/hibernation/
   resume feature of the ThinkPad while the firmware update utility is running.
   Please do not use Fn-F4, close LID or equivalent functions.


--------------------------------------------------------------------------------

 

 

Firmware here

 

Readme here

 

 

 

 

 

 

 

 

Was this information helpful?

Your feedback helps to improve this site.

Comments
roberrygmail
Paper Tape

Doesn't work.  Lenovo is selling a product that they know doesn't work.  I had an X61 that worked great.  So far two X220s have not worked.  Makes the tablet useless.  Don't buy one.

al2011
Paper Tape

I've just tried this utility.

The update completed successfully, as I can verify bu running th exe file again. However, the results are not better.

I am doing calibration using the utility in "Tablet Pc Settings" in Control Panel?

Could Lenovo please comment whether this is the right calibration method? I should say that by using that utility I am only given the option to do a 4 point calibration. Since 16 points calibration is mentioned in the descirption of this fix, I was wondering how can one do a 16 point calibration instead?

 

al

brokentech
Blue Screen Again

I have a X220 with the daylight screen. I have updated the driver using this utility within the past couple weeks. I have tried the 16 point calibration and the 4 point calibration. (The 16 pt is run first and then rerunning the calibration runs the four point). When I run the 16 pt calibration the digitizer circles are WAY off when I tap. Then, when I follow with the four point, they are right on the marks. However, then when I use the pen in windows there is an offset that depends on which corner of the screen I am pointing. The offset is worse in the 'optimal screen resolution' 1366x768. If I lower resolution to 1280x768 the calibration is better, only with the screen centered (black edges, not using full screen size capabilities).

 

The problem is quite serious in Windows Journal, and the calibration seems to be different in the application compared to windows. When I recalibrate, the offset is tolerable in 1280x768, but still annoying. I have also tried making the start bar autohide, but I did not notice an improvement.

 

I had an X61 that worked well. I am dissapointed that so much development time is spent on 'bells and whistles' add-ons like all the Lenovo tools the duplicate windows functions and add additional processes. I wish the development time was spent on making the basic features work reliably. I do like this machine, but it is very annoying when the calibrations don't calibrate adequately. This should be basic geometry, even scaling. But something is goofy with the digitizer pen compared to the mouse that works fine, even with this new firmware update.

 

I am amazed at all the posts that I see in other threads that have not pointed to this thread. I can see that there are a lot of other frustrated users out there. If anyone has further advice, please help.

 

By the way, if you are a user out there trying to find the calibration, the documentation is very poor. In Win 7 you can find the calibration by 'Start' and type 'tablet PC Settings' into the search box.

kvirtanen
802.11n

No change after updating, unfortunately. I've tried various driver combinations to make the screen usable.

 

Sad stuff...

tomnash8778
Fanfold Paper

I am having the problem that this thread began with in 2011.

 

One difference is the problem exists with only one Windows 7 user account.  It began about a week ago while I was in process of using the bottom as an eraser in Microsoft One Note.

 

In another user account, the pen works fine.

 

Any other suggestions?

 

Is there a place to manage user settings specific to the pen?