cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DAVANDEN
Ctrl-Alt-Del
Posts: 14
Registered: ‎12-25-2012
Location: Alexandria, VA, USA
Views: 1,816
Message 1 of 3

X230 Tablet Ultranav Not Working

I have a Thinkpad X230 Tablet.  The trackpoint and touchpad have stopped working.  This just happened today, after about six months of use. 

 

When I boot the machine, I can move the mouse cursor for a few seconds, but then it stops.  I don't see any error messages.  The Ultranav panel in the mouse control panel applet shows the controls for both trackpoint and touchpad greyed out--they can't be clicked on, and the "enabled" boxes are not checked.  The device manager says that the device is working.  If I try to update the driver, I'm told it is up to date. 

 

If I uninstall the driver and reboot, the trackball and touchpad work, but they seem to be using generic drivers--the ultranav panel does not show in the mouse applet.  I'm told to reboot to complete installation.  However, if I do that, I'm back to square one, with the ultranav not working. 

 

I checked the boot configuration, and it shows both the trackpoint and touchpad as enabled.

del_psi
Token Ring
Posts: 194
Registered: ‎06-21-2012
Location: US
Views: 1,789
Message 2 of 3

Re: X230 Tablet Ultranav Not Working


@DAVANDEN wrote:

I have a Thinkpad X230 Tablet.  The trackpoint and touchpad have stopped working.  This just happened today, after about six months of use. 

 

When I boot the machine, I can move the mouse cursor for a few seconds, but then it stops.  I don't see any error messages.  The Ultranav panel in the mouse control panel applet shows the controls for both trackpoint and touchpad greyed out--they can't be clicked on, and the "enabled" boxes are not checked.  The device manager says that the device is working.  If I try to update the driver, I'm told it is up to date. 

 

If I uninstall the driver and reboot, the trackball and touchpad work, but they seem to be using generic drivers--the ultranav panel does not show in the mouse applet.  I'm told to reboot to complete installation.  However, if I do that, I'm back to square one, with the ultranav not working. 

 

I checked the boot configuration, and it shows both the trackpoint and touchpad as enabled.


Well , as a last resort you could either do a full reinstall or do a factory restore. If that doesn't work then I would assume it's a hardware problem.

FlyGuy2480
Paper Tape
Posts: 6
Registered: ‎03-13-2013
Location: United States
Views: 1,434
Message 3 of 3

Re: X230 Tablet Ultranav Not Working

I had the same issue, and I fixed it by uninstalling the driver (including the driver software) and (before restarting the system) then manually reinstalled it using the package available on Lenovo's support site for my particular make & model laptop.