cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bortiz3466
Not applicable
Posts: 4
Registered: ‎09-02-2015
Location: United States
Views: 2,578
Message 1 of 3

"HID-compliant pen" device missing in Device Manager

I am using a Lenovo Thinkpad Helix (system model 36984SU) on Windows 8.1 Pro, 64-bit. I recently factory reset the computer to downgrade from Windows 10 (I was past the 1-month "downgrade-for-free" option with no Windows 8 recovery files) to Windows 8, then I upgraded to Windows 8.1.

 

I had issues with the digitizer pen in the past that were never resolved, and I guess factory resetting the device still didn't solve them. I've looked at all the "install this pen driver" threads out there, and then I realized that my Device Manager doesn't even recognize a pen (see picture below, "HID-compliant pen" is nowhere to be found. I would love to use the digitizer someday..... so what do I do?

IDontWantAScree
Not applicable
Posts: 1
Registered: ‎01-22-2018
Location: US
Views: 1,228
Message 2 of 3

Re: "HID-compliant pen" device missing in Device Manager

Did you ever get this answered? I'm experiencing similar issues and would love to use the pen on my laptop again. I can't find any helpful information on the internet (other than using troubleshooter or installing windows updates both of which don't solve the issue).

mxyptl
Not applicable
Posts: 3
Registered: ‎10-13-2010
Location: IE
Views: 744
Message 3 of 3

Re: "HID-compliant pen" device missing in Device Manager

Just in case you're still looking for an answer, it might be worth trying this because it just fixed it for me.

 

My Helix got it's upgrade to 1803 and then around that time the pen stopped working.

I can't be certain that it was directly connected to the upgrade but it's pretty likely.

 

I tried a lot of different suggestions, using the reset button combination, trying to install a few different versions of WinTab and other driver based suggestions.

Nothing helped.

 

A lot of posts suggested restarting the services at various points but that didn't help but no-one suggested a 

 

Start the cmd prompt as administrator (Right click > Run as administrator)

Type the command sfc /scannow 

It will take some time to complete, reboot when finished.

Hopefully it fixes the problem for you.

 

"The sfc /scannow command will scan all protected system files, and replace corrupted files with a cached copy that is located in a compressed folder at %WinDir%\System32\dllcache. The %WinDir% placeholder represents the Windows operating system folder."

 

Personally I partially blame the hardware getting stuck in the off mode. When inserted apparenty the pen turns off the digitizer. In future I won't use this again and will only use the 3rd party pressure sensitive pen. Maybe that will help...

 

 

Check out current deals!


Shop current deals

Top Kudoed Authors