cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jchammerpants
Token Ring
Posts: 197
Registered: ‎10-08-2011
Location: Florida
Views: 326
Message 1 of 5

x41 won't acknowledge AC adaptor.

Hey, folks. Thanks in advance for assistance.

 

I searched and found similar threads, including one that explained how to clear out any lingering charge to fix the issues.  But none of the other posts reflected exactly my issue.

 

I have an X41 tablet that worked great, but hasn't been touched in about 2 years.  I tried to start it, but when I plug in the AC adaptor, the X41 does nothing.  The charging light does NOT come on.  I've tried with and without several batteries (I have extras).  I've also verififed that the brick itself does charge other devices, and even used another brick  on the X41, but same issue.

 

I hope to figure out what is wrong without spending too much, so I can decide whether its worth fixing.  Any suggestions on how I might further diagnose it, or should I resign myself to paying for a service fee?

 

Thanks,

JCHP

SGolf
Punch Card
Posts: 62
Registered: ‎07-27-2012
Location: Terra
Views: 308
Message 2 of 5

Re: x41 won't acknowledge AC adaptor.

At first I would've suggested the CMOS battery is dead but we have x41's and have disconnected the CMOS battery in the past to clear gremlins and noticed the boxes still charge and even power up without the CMOS battery.

 

Have you tried disconnecting the CMOS battery (maybe dead anyway) and trying to recharge / restart the x41 with it disconnected ?

 

Whenever we do, all BIOS settings reset to defaults, the TPM retains its data along with the enrolled fingerprints but it is similar to an F10 / Reset to Defaults and Save.

Signature:
Let us know what happened,and share your solutions so others may benefit from our experiences. "It doesn't really matter what kind of computers I own since right now the conversation is about the problems on the computers that YOU OWN!" -Mark Twain
Guru
Posts: 7,626
Registered: ‎11-23-2007
Location: USA
Views: 298
Message 3 of 5

Re: x41 won't acknowledge AC adaptor.

The type of behaviour that you're describing leads me to believe that there's a blown fuse in the charging circuit.

 

If you're up for opening up the machine and going over these with a multimeter, it should be fairly easy to find the culprit, presuming I'm right which may or may not be the case.

 

If it's indeed a blown fuse, a new one can be soldered over it, "piggy-back" style.

 

Good luck.

Cheers,

George




In daily use: R60F, R500F, T61, T410

Collecting dust: T60

Enjoying retirement: A31p, T42p,

Non-ThinkPads: Panasonic CF-31 & CF-52, HP 8760W




Starting Thursday, 08/14/2014 I'll be away from the forums until further notice. Please do NOT send private messages since I won't be able to read them. Thank you.
.
jchammerpants
Token Ring
Posts: 197
Registered: ‎10-08-2011
Location: Florida
Views: 277
Message 4 of 5

Re: x41 won't acknowledge AC adaptor.

Thanks for both of the responses.

 

I went ahead and changed the CMOS battery, but no luck.

 

As for the fuse- that's a little beyond my ability.  So, I'm going to take it to the shop and hope its something simple, like a fuse, and not a bad systemboard.

 

JCHP

Former Administrator
Posts: 8,592
Registered: ‎11-19-2007
Location: US
Views: 261
Message 5 of 5

Re: x41 won't acknowledge AC adaptor.

JCHP,

 

Some good suggestions here so far...and it sounds like you've done your homework.

 

Probably it will wind up being the system board as George suggests, but one other thing you might check out is the power connector.  Most ThinkPads have a DC power in jack with a short pigtail connection to the system board.  It is possible that the connector is broken and could be replaced...

 

Have you tried gently wiggling the DC input plug a bit to see if the lights flicker?

 

Mark

Check out current deals!


Shop current deals