cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
ThinkServerAdm
Fanfold Paper
Posts: 7
Registered: ‎01-21-2016
Location: USA
Views: 1,601
Message 1 of 2

BIOS Settings Blank with Cursor after BIOS Update

I just updated our RD 630 to BIOS version 9.60 (latest). The BIOS update seems to work without errors.

 

Upon rebooting, I can no longer get into the BIOS settings. If I press F1 at startup, I see the usual startup screens, and then after that, all I see is a black screen with a blinking cursor in the middle. Nothing else.

 

Everything else works. I can still select boot devices (F12) and the system boots into Windows. Only the BIOS setup is affected.

 

I tried reloading the BIOS twice using DOS boot. After searching online, I also tried loading it from Windows. The fans are louder at startup after the BIOS update from Windows. Otherwise there is no difference.

 

Can anyone suggest ways to get the BIOS Settings screens back? Thanks!

ThinkServerAdm
Fanfold Paper
Posts: 7
Registered: ‎01-21-2016
Location: USA
Views: 1,566
Message 2 of 2

Re: BIOS Settings Blank with Cursor after BIOS Update

I would like to share the solution that eventually worked for me. See above for a description of the problem. You can also find additional related discussion in this thread:

 

https://forums.lenovo.com/t5/ThinkServer-Rack-Mounted/Time-to-Update-BIOS-and-Remote-Management-Firm...

 

I had help via private messaging (You know who you are - Thank You!), but unfortunately they did not pan out. Finally, I got support from Lenovo Support.

 

IMPORTANT NOTE: This solution contains links to files that are out of date. Furthermore, the latest BIOS may not be 9.60 as it was when I wrote this. Pay attention to versions, etc. Think about what you are doing before you do it. 

 

READ EVERYTHING BELOW CAREFULLY BEFORE DOING ANYTHING. YOU HAVE BEEN WARNED!

 

Here is what worked for me:

 

Step 1: Run the Easy Update software from Lenovo.

IMPORTANT NOTE: This solution downgrades the BIOS firmware to an earlier version, which has its own risks and is not recommended in general. If you got here because you are in the same situation that I was in (unable to access the BIOS menus at all) then "Desparate times call for desparate measures!"  :-o

 

a. Download the Lenovo ThinkServer EasyUpdate Firmware Updater software. It comes in a .iso file, which you can download from here:

http://support.lenovo.com/us/en/products/servers/thinkserver-rack-servers/thinkserver-rd630/download...

 

NOTE: This .iso file does NOT contain the latest BIOS or BMC firmware. Other firmware may not be the latest either.

 

b. Burn the .iso file to a DVD. In case it matters, I used Toast Titanium on a Mac to do it, but there is lots of software you can use on Windows, Linux, or Mac. Most of it is free or included with the OS. You could also use the .iso to create a bootable USB drive if you wish. 

 

c. Boot the RD 630 and insert the DVD as soon as you can, then press F12 at the appropriate time to choose the boot device. If you are booting from a DVD, choose "P0: HL-DT-ST DVDRAM GT50N", which is the DVD drive. (If you use a USB, then choose accordingly.)

 

d. When the EasyUpdate DVD (or USB) finishes booting, choose a language. Click the Next button on the Welcome screen. You will be presented with a list of updates to install. Because I had already updated my BIOS (to 9.60), the only item checked was the RAID controller firmware. Lenovo support advised me to leave the RAID checked, but they advised me to check the BIOS 9.1 firmware update (which is a DOWNGRADE!) but to leave the BMC update unchecked. 

 

e. Follow the prompts to install the chosen "updates" (which downgraded the BIOS for my RD 630). 

 

f. Reboot your RD 630. At this point, I was able to press F1 and see the BIOS menus, which was my goal.

 

g. The next step is to update the BIOS to version 9.60, in order to incorporate the latest firmware and security updates from Lenovo. See Step 3, below. IMPORTANT: You will need access to your ThinkServer Management Module - if you cannot access it, see Step 2, below.

 

 

Step 2: Accessing the ThinkServer Management Module (aka BMC)

 

(To get to Step 3, you will need to connect to your RD 630 (or comparable computer) usinng the ThinkServer Management Module from a browser on your local LAN. There is a separate special Ethernet port on the back of your ThinkServer for this function.)

 

a. Configure the remote management IP address in your BIOS. Boot the RD 630 and press F1 at the prompt just after startup. In the BIOS menu,

 

b. Set the management IP address (on your local LAN) in the BIOS->Server Management->BMC Network Configuration (return key).

 

c. On my system, I set the following: Dedicated, Static (popup menu when you press Return at "Configuration Address Source" ... This gives you the opportunity to set the IP address, subnet mask, and gateway. Choose the appropriate values for your network, pressing Return appropriately. Use ESC to back out of the menus. 

 

d. From the top menu, choose Save & Exit and then save your work. (I do not remember if you have to restart to establish a connection on the new IP address.) 

 

e. From your browser on another computer, enter "https://IPaddress" where the IP address is the one you chose above. If all went well, you should see the ThinkServer Management Module web interface. 

 

 

Step 3: Update your BIOS back to version 9.60 (and keep your BIOS setup menu working this time.

At this point, you should be able to see the ThinkServer Management Module interface in the browser on a separate computer. The default login is username: lenovo, password: lenovo (WARNING! You should change this later for security reasons.) If the default password fails and you can't find the new password, then you are stuck with a serious problem that is beyond the scope of this note. You can update your BIOS from Windows (not tested by me) but you still have a problem to access the management (BMC) interface.

 

IMPORTANT: I ran the following steps with the RD 630 shutdown. The updater turned on (or instructed me to turn on) what it needed on the RD 630 at the appropriate times. 

 

 

a. Download the BIOS updater file here: http://support.lenovo.com/us/en/products/Servers/ThinkServer-rack-servers/ThinkServer-RD630/download...

 

b. Uncompress the .tgz file that you find there. The important BIOS file is called "amiboot.rbu" in the BIOSWeb folder.

 

c. Follow the instructions in the files to upload the BIOS update (amiboot.rbu). Here is a summary:

 

d. In the ThinkServer Management Module interface, click on Update. Choose Firmware Type: BIOS. File Path: (Choose your amiboot.rbu file). Click Upload.

 

e. Follow the prompts. 

 

 

ADDITIONAL NOTES: 

 

* Be sure you carefully secure the ThinkServer Management Module (BMC) from the bad guys. Leaving your BMC set to the default password is not a good idea (doh!). Changing it and not being able to find it later is just as bad. If you aren't sure and you have easy physical access to the server, unplug the management ethernet cable until you need it. 

 

* I hope this helps someone who runs into the same issues I did. 

 

 

Check out current deals!


Shop current deals

Top Kudoed Authors