cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
unexpectedly
Not applicable
Posts: 9
Registered: ‎03-11-2014
Location: United States
Views: 5,664
Message 1 of 6

RD430 how to disable onboard RAID 300?

Hi,

 

I've got a sas3 hardware raid controller card so I'm not using the onboard raid 300, which takes FOR-EV-ERRRRR to get through POST. Is there a way I can disable that? I even tried attaching drives to it to see if I could change controller settings, but no...

 

Also, I'm booting the os (lmde) to another pcie card so I'm not using the onboard raid at all.

 

Thanks,

Chris

I_am_Nivek
Not applicable
Posts: 543
Registered: ‎01-30-2014
Location: US
Views: 5,642
Message 2 of 6

Re: RD430 how to disable onboard RAID 300?

You can disable the on-board RAID by doing the following:

1. Enter F1 BIOS Setup
2. Go to Advanced
3. Select SATA/SAS Configuration
4. Set the SATA Mode to AHCI (not RAID). This may already be selected.
5. Scroll down to Disable SCU Devices and set to "Enabled"
6. Press F10 or Exit and Save setup.

The system will reboot, now it will not POST the on-board RAID controller and go straight to the hardware RAID controller.

Let me know if this does not work for you.
unexpectedly
Not applicable
Posts: 9
Registered: ‎03-11-2014
Location: United States
Views: 5,624
Message 3 of 6

Re: RD430 how to disable onboard RAID 300?

Thank you for your reply, it worked, the software SLI MegaRaid bios is no longer interrupting the boot process.

 

Sadly, after this, the server wouldn't boot. As it turns out, something about this one change cased a shift in the UEFI nvram and my system wouldn't restart. And then the OS would not reinstall using the same methods I had successfully used before.

 

This post helped me get going: http://forums.debian.net/viewtopic.php?f=16&t=81120

 

Quite interesting, this UEFI stuff...

unexpectedly
Not applicable
Posts: 9
Registered: ‎03-11-2014
Location: United States
Views: 5,608
Message 4 of 6

Re: RD430 how to disable onboard RAID 300?

I_am_Nivek, in the future, you should probably ask what bios version people are on. On the RD430, version 2.12 seems to me to not handle non Windows operating systems very well. As I detail on this post, nearly any change I make to the RD430 (including update-grub) would cause the uefi boot entry menu to be corrupted.

 

That includes making your one change in the bios. 

 

After reinstalling the OS 10+ times, I next turned to a ThinkServer TS140 we have. I put a raid controller on it and installed the same linux OS as on the RD430 and the TS140 was completely stable, including after running update-grub. I updated the RD430 to V8.10 bios and it has now been stable through a couple of small configuration changes, but notably is the first time I was able to recover to the installation once UEFI had lost it.

 

Thanks,

Chris

I_am_Nivek
Not applicable
Posts: 543
Registered: ‎01-30-2014
Location: US
Views: 5,598
Message 5 of 6

Re: RD430 how to disable onboard RAID 300?

Thanks for the feedback. I wrongly assumed you were running the latest BIOS. I am glad you were able to get everything up and running and it's working as desired. The question was simply how to disable the onboard RAID 300, to which I responded. I wasn't aware of the other problems until your next post.

Thanks again for the updates / feedback!
unexpectedly
Not applicable
Posts: 9
Registered: ‎03-11-2014
Location: United States
Views: 5,589
Message 6 of 6

Re: RD430 how to disable onboard RAID 300?

Nivek, no worries. Smiley Happy Your answer wasn't the cause of everything else. I wasn't yet aware of the "Patsburg SCU" option's function in the bios and you got me on the right path. 

 

And I wasn't understanding the various aspects of my problem well enough yet to ask for help. 

 

I mentioned in the uefi thread that I would love if there was a bios-independent efi program that could reset and validate the boot menu in the nvram. 

 

Thanks,

Chris

Check out current deals!


Shop current deals