Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkStationThinkStation Workstations
All Forum Topics
Options

2 Posts

07-02-2021

Canada

3 Signins

20 Page Views

  • Posts: 2
  • Registered: ‎07-02-2021
  • Location: Canada
  • Views: 20
  • Message 1 of 6

P500 - Boot on NVME

2021-07-02, 12:28 PM

Good day everyone!

I've been trying to make this work for the last few days but I haven't got much luck yet!

 

Here's my setup:

    -P500 Workstation (ThinkStation) - Type 30A6 - UEFI Bios A4KTABA
    -UGREEN M.2 PCIe NVME or PCIe AHCI SSD to PCIe 3.0 X4 X8 X16 Adapter Card - Link: https://www.amazon.ca/gp/product/B07YFW5HBN 
    -Samsung 970 EVO Plus 1TB NVMe M.2 Internal SSD

 

Problem: 

    -The NVME drive doesn't appear in the boot option. I was able to install W10 on it but I can't select it in the BIOS.

    -The drive is linking/training properly in the IIO0 configuration menu 

    -I tried to enable the OS Optimized Defaults but everytime, the PC stops booting and I have to flash the bios to make it work again.

 

 

I'm open to any suggestion to make this work!

Reply
Options

1257 Posts

01-14-2014

United States of America

2155 Signins

17099 Page Views

  • Posts: 1257
  • Registered: ‎01-14-2014
  • Location: United States of America
  • Views: 17099
  • Message 2 of 6

Re:P500 - Boot on NVME

2021-07-06, 19:20 PM

Unfortunately, the P500 (as well as the other platforms in that generation such as P700 and P900) don't fully support UEFI.  UEFI is typically needed to be able to boot to NVMe drives and without BIOS support for UEFI will make this a non-bootable NVMe drive in your P500 system.  

Reply
Options

2 Posts

07-02-2021

Canada

3 Signins

20 Page Views

  • Posts: 2
  • Registered: ‎07-02-2021
  • Location: Canada
  • Views: 20
  • Message 3 of 6

Re:P500 - Boot on NVME

2021-07-06, 19:25 PM

Thanks for the information! I was able to make it work with a bootloader (Clover). It's not perfect, but it's better than nothing.

Reply
Options

1257 Posts

01-14-2014

United States of America

2155 Signins

17099 Page Views

  • Posts: 1257
  • Registered: ‎01-14-2014
  • Location: United States of America
  • Views: 17099
  • Message 4 of 6

Re:P500 - Boot on NVME

2021-07-06, 20:28 PM

Feel free to share how you were able to make this work here for other users trying to do something similar. 

Reply
Options

8 Posts

07-18-2021

Russian Federation

14 Signins

170 Page Views

  • Posts: 8
  • Registered: ‎07-18-2021
  • Location: Russian Federation
  • Views: 170
  • Message 5 of 6

Re:P500 - Boot on NVME

2021-07-22, 0:28 AM

Hi, guys,

The NVME boot option was initially possible on my machie until I upgraded it to the latest bios version.

Then I stopped being able to boot from it anymore.

If you know how to safely downgrade your bios, here's the bios I had before I stupidly went for an upgrade: A4KT65AUS dated 03/13/2015. I found the bios file and will gladly share it with you if you wish.

Reply
Options

5195 Posts

02-22-2010

United States of America

3671 Signins

51380 Page Views

  • Posts: 5195
  • Registered: ‎02-22-2010
  • Location: United States of America
  • Views: 51380
  • Message 6 of 6

Re:P500 - Boot on NVME

2021-07-22, 12:23 PM

Point of correction....the P500/700/900 platforms do fully support UEFI.  I think mebsterbball might be confusing the mixed UEFI support statement with the prior generation of platforms (S30/C30/D30) as we transitioned to UEFI support midstream during those platforms.  Just want to make that clarification.

 

Typically NVMe was only supported in UEFI mode, though some have been able to get it to work legacy mode as well.  Changing OS Optimized defaults to enabled should set UEFI boot mode, but it also changes a few other settings within BIOS (disables CSM, enables secure boot, etc.).  If setting OS Optimized Defaults to enabled isn't resolving the NVMe boot issue, you could try leaving it disabled but going into Startup --> CSM configuration and setting the storage OPROM to UEFI.  Changing the boot mode setting from Auto to UEFI might also work, just be aware that I think that also changes all the OPROM settings to UEFI...so you need to make sure the rest of your system is able to boot in UEFI mode (primarily the GPU as it could cause a non-boot scenario if the GPU is legacy only).  I'd recommend making sure you understand the clear CMOS procedure before trying these setting changes just in case you get into a non-boot situation where you lose graphics.  Using the CMOS clear procedure should reset BIOS back to factory settings.




If we've helped resolve your issue, please be sure to mark your topic as solved!
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms